aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/dctc/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-04 18:03:54 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-04 18:03:54 +0000
commitfd3eb836b9f6d8fc622cb53a5d493ce7315c239e (patch)
treeb9c4d08a90b4eb15bb3f97263eda66c31ebb93f1 /net-p2p/dctc/Makefile
parent55c9ec812355eedfe0fd0ba083b2f49cd6bf1d38 (diff)
downloadports-fd3eb836b9f6d8fc622cb53a5d493ce7315c239e.tar.gz
ports-fd3eb836b9f6d8fc622cb53a5d493ce7315c239e.zip
Notes
Diffstat (limited to 'net-p2p/dctc/Makefile')
-rw-r--r--net-p2p/dctc/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/net-p2p/dctc/Makefile b/net-p2p/dctc/Makefile
index 45410abcd11e..6730b66747d2 100644
--- a/net-p2p/dctc/Makefile
+++ b/net-p2p/dctc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dctc
-PORTVERSION= 0.83.1
+PORTVERSION= 0.83.2
CATEGORIES= net
MASTER_SITES= http://ac2i.tzo.com/dctc/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -20,11 +20,12 @@ LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4 \
USE_GNOMENG= yes
USE_GNOME= glib12
USE_PERL5= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt \
- ${PTHREAD_LIBS}"
+ ${PTHREAD_LIBS:S/"//g}"
CONFIGURE_ARGS= --enable-manual-db-detect
MANCOMPRESSED= no
@@ -36,16 +37,25 @@ DOC_FILES= COPYING ChangeLog INSTALL README \
Documentation/BerkeleyDB \
Documentation/BerkeleyDB.nl \
Documentation/DCextensions/p2p_capabilities \
+ Documentation/DCextensions/p2p_capabilities.nl \
Documentation/DCextensions/search_by_content \
+ Documentation/DCextensions/search_by_content.nl \
Documentation/GDL.nl \
Documentation/GDL Documentation/VAR \
+ Documentation/LS_cache Documentation/UNODE.nl \
+ Documentation/VAR.nl \
Documentation/UNODE Documentation/Vshare \
Documentation/Vshare.nl \
Documentation/commands \
+ Documentation/commands.nl \
Documentation/programs.nl \
Documentation/programs.pl \
+ Documentation/output.nl \
Documentation/output Documentation/programs
+post-extract:
+ @${CP} ${FILESDIR}/lp_mutex.c ${WRKSRC}/src
+
post-patch:
.for file in ${DOC_FILES}
@${PERL} -pi -e 's|(hublist)|dc_\1|' ${WRKSRC}/${file}
@@ -59,16 +69,18 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${PERL} -pi -e 's|/usr/bin/env perl|${PERL}|' \
${WRKSRC}/GDLjoiner
+ @${REINPLACE_CMD} -E -e 's|^(dctc_SOURCES.+)$$|\1 lp_mutex.c|; \
+ s|^(dctc_OBJECTS[^\\]+)(\\*)$$|\1 lp_mutex.o \2|' \
+ ${WRKSRC}/src/Makefile.in
pre-build:
@${ECHO_CMD} '#ifndef MSG_NOSIGNAL' >> ${CONFIGURE_WRKSRC}/config.h
@${ECHO_CMD} '# define MSG_NOSIGNAL 0' >> ${CONFIGURE_WRKSRC}/config.h
@${ECHO_CMD} '#endif' >> ${CONFIGURE_WRKSRC}/config.h
- @${ECHO_CMD} '#include <errno.h>' >> ${CONFIGURE_WRKSRC}/config.h
@${ECHO_CMD} '#ifndef ENODATA' >> ${CONFIGURE_WRKSRC}/config.h
@${ECHO_CMD} '# define ENODATA ENOMSG' >> ${CONFIGURE_WRKSRC}/config.h
@${ECHO_CMD} '#endif' >> ${CONFIGURE_WRKSRC}/config.h
- @${ECHO_CMD} '#include <sys/param.h>' >> ${CONFIGURE_WRKSRC}/config.h
+ @${ECHO_CMD} '#define HAVE_SYS_PARAM_H 1' >> ${CONFIGURE_WRKSRC}/config.h
do-install:
.ifndef(NOPORTDOCS)