aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-10-26 16:52:22 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-10-26 16:52:22 +0000
commitaaf4dfde485e1066338dfe42990210fe718b5dc0 (patch)
tree43d979e7eb9aee41564c9e9592a1e22fee151394 /net-p2p/deluge/Makefile
parentd48ac71bab458d04c725ee76b9f3643a626714cb (diff)
downloadports-aaf4dfde485e1066338dfe42990210fe718b5dc0.tar.gz
ports-aaf4dfde485e1066338dfe42990210fe718b5dc0.zip
Notes
Diffstat (limited to 'net-p2p/deluge/Makefile')
-rw-r--r--net-p2p/deluge/Makefile69
1 files changed, 6 insertions, 63 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 848364020a4e..cd772e3b5673 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -2,78 +2,21 @@
PORTNAME= deluge
PORTVERSION= 1.3.13
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-p2p python
-MASTER_SITES= http://download.deluge-torrent.org/source/
MAINTAINER= rm@FreeBSD.org
COMMENT= Bittorrent client using Python, GTK2, and libtorrent-rasterbar
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>=0.18:devel/py-xdg \
- ${PYTHON_PKGNAMEPREFIX}libtorrent-rasterbar>=0:net-p2p/libtorrent-rasterbar-python \
- ${PYTHON_PKGNAMEPREFIX}openssl>=0.8:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}chardet>=1.0.1:textproc/py-chardet \
- ${PYTHON_PKGNAMEPREFIX}mako>=0.2.5:textproc/py-mako
-
-USE_RC_SUBR= deluged deluge_web
-SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
-
-NO_ARCH= yes
-USES= gettext python:2.7 tar:xz twisted:run,web
-USE_PYTHON= autoplist distutils
-
-OPTIONS_DEFINE= DOCS GTK2
-OPTIONS_DEFAULT=GTK2
-OPTIONS_SUB= yes
-
-GTK2_RUN_DEPENDS= \
- ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83:devel/py-dbus \
${PYTHON_PKGNAMEPREFIX}game>=1.8.1:devel/py-game \
${PYTHON_PKGNAMEPREFIX}notify>=0.1.1:devel/py-notify \
- xdg-utils>=1.0.2:devel/xdg-utils
-GTK2_USE= gnome=intltool,librsvg2,pygnome2,pygtk2
-GTK2_USES= desktop-file-utils
-GTK2_VARS= installs_icons=yes
-
-PORTDOCS= ChangeLog README
-
-post-patch:
- @${REINPLACE_CMD} -e '/"new_release_check":/s|True,|False,|g ; \
- /"geoip_db_location":/s|/usr/share/GeoIP/GeoIP.dat|${LOCALBASE}/share/GeoIP/GeoIP.dat|g' \
- ${WRKSRC}/deluge/core/preferencesmanager.py
- @${REINPLACE_CMD} -e '/"check_new_releases":/s|True,|False,|g ; \
- /"show_new_releases":/s|True,|False,|g' \
- ${WRKSRC}/deluge/ui/gtkui/gtkui.py
-
-post-install:
-# do these by hand, else they wind up in the wrong place
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps ; \
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/icons/scalable/apps/deluge.svg \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
-.for size in 16 22 24 32 36 48 64 72 96 128 192 256
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}x${size}/apps ; \
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/icons/hicolor/${size}x${size}/apps/deluge.png \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/${size}x${size}/apps
-.endfor
-.for pic in png xpm
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/pixmaps/deluge.${pic} \
- ${STAGEDIR}${PREFIX}/share/pixmaps
-.endfor
-
-# install man pages
-.for man in deluge.1 deluge-console.1 deluge-gtk.1 deluge-web.1 deluged.1
- ${INSTALL_MAN} ${WRKSRC}/docs/man/${man} ${STAGEDIR}${MANPREFIX}/man/man1/
-.endfor
-
-post-install-GTK2-on:
- ${INSTALL_DATA} ${WRKSRC}/deluge/data/share/applications/deluge.desktop \
- ${STAGEDIR}${PREFIX}/share/applications
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ xdg-utils>=1.0.2:devel/xdg-utils \
+ deluge:net-p2p/deluge-cli
+USE_GNOME= librsvg2 pygtk2
+USES= python:-2.7 metaport
.include <bsd.port.mk>