aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge/files
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-08-05 23:27:42 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-08-05 23:27:42 +0000
commit46a859eb5acfdfd6e6afd15020e41d33cb0e25e7 (patch)
tree1e5a28b79f7b36a7b95a2625b74f246046ff6baf /net-p2p/deluge/files
parent2af6c2bf8805e65a565ca1151ea408a0c93cdc22 (diff)
Notes
Diffstat (limited to 'net-p2p/deluge/files')
-rw-r--r--net-p2p/deluge/files/patch-setup.py50
-rw-r--r--net-p2p/deluge/files/patch-src___init__.py15
-rw-r--r--net-p2p/deluge/files/patch-src_interface.py15
-rw-r--r--net-p2p/deluge/files/patch-src_pref.py11
4 files changed, 50 insertions, 41 deletions
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge/files/patch-setup.py
index 42711e85d2dc..c91584f15ef8 100644
--- a/net-p2p/deluge/files/patch-setup.py
+++ b/net-p2p/deluge/files/patch-setup.py
@@ -1,43 +1,41 @@
---- setup.py.orig Thu Jul 5 22:49:16 2007
-+++ setup.py Thu Jul 5 22:55:47 2007
-@@ -105,7 +105,7 @@
+--- setup.py.orig 2007-08-05 13:03:56.000000000 -0500
++++ setup.py 2007-08-05 13:06:12.000000000 -0500
+@@ -101,13 +101,13 @@
+ "-DHAVE_INCLUDE_LIBTORRENT_ASIO_SSL_STREAM_HPP=1",
+ "-DHAVE_INCLUDE_LIBTORRENT_ASIO_IP_TCP_HPP=1",
+ "-DHAVE_PTHREAD=1", "-DTORRENT_USE_OPENSSL=1", "-DHAVE_SSL=1",
+- "-DNDEBUG=1", "-O2"]
++ "-DNDEBUG=1"]
+ if ARCH == "x64":
+ EXTRA_COMPILE_ARGS.append("-DAMD64")
- includedirs = ['./libtorrent', './libtorrent/include',
+ includedirs = ['./libtorrent', './libtorrent/include',
'./libtorrent/include/libtorrent',
- '/usr/include/python' + python_version]
+ '%%LOCALBASE%%/include']
- if OS == "linux":
- if os.WEXITSTATUS(os.system('grep -iq "Debian GNU/Linux 4.0\|Ubuntu 7.04\|Ubuntu 6.06\|Ubuntu 6.10\|Fedora Core release 6\|openSUSE 10.2\|Mandriva Linux release 2007.1\|Fedora release 7" /etc/issue')) == 0:
-@@ -117,7 +117,7 @@
- else:
- boosttype = 'mt'
- removals = ['-g', '-Wstrict-prototypes']
-- additions = ['-DNDEBUG', '-O2']
-+ additions = ['-DNDEBUG']
-
- if python_version == '2.5':
- cv_opt = sysconfig.get_config_vars()["CFLAGS"]
-@@ -152,11 +152,11 @@
+ if OS == "linux":
+ if os.WEXITSTATUS(os.system('grep -iq "Debian GNU/Linux 4.0\|Ubuntu 7.04\|Ubuntu 6.06\|Ubuntu 6.10\|Fedora Core release 6\|openSUSE 10.2\|Mandriva Linux release 2007.1\|Fedora release 7\|BLAG release 60001\|Yellow Dog Linux release 5.0 (Phoenix)\|CentOS release 5 (Final)" /etc/issue')) == 0:
+@@ -150,11 +150,11 @@
# Ubuntu possible.
if boosttype == "nomt":
- librariestype = ['boost_filesystem', 'boost_date_time',
-- 'boost_thread', 'z', 'pthread', 'ssl']
-+ 'boost_thread', 'z', 'ssl']
- print 'Libraries nomt'
+ librariestype = ['boost_filesystem', 'boost_date_time',
+- 'boost_thread', 'z', 'pthread', 'ssl']
++ 'boost_thread', 'z', 'ssl']
+ print 'Libraries nomt'
elif boosttype == "mt":
- librariestype = ['boost_filesystem-mt', 'boost_date_time-mt',
-- 'boost_thread-mt', 'z', 'pthread', 'ssl']
-+ 'boost_thread-mt', 'z', 'ssl']
- print 'Libraries mt'
+ librariestype = ['boost_filesystem-mt', 'boost_date_time-mt',
+- 'boost_thread-mt', 'z', 'pthread', 'ssl']
++ 'boost_thread-mt', 'z', 'ssl']
+ print 'Libraries mt'
def fetchCpp():
-@@ -175,8 +175,10 @@
+@@ -173,8 +173,10 @@
deluge_core = Extension('deluge_core',
include_dirs = includedirs,
+ library_dirs = ['%%LOCALBASE%%/lib'],
- libraries = librariestype,
+ libraries = librariestype,
extra_compile_args = EXTRA_COMPILE_ARGS,
+ extra_link_args = ['%%PTHREAD_LIBS%%'],
sources = sources)
diff --git a/net-p2p/deluge/files/patch-src___init__.py b/net-p2p/deluge/files/patch-src___init__.py
new file mode 100644
index 000000000000..442d86f4263f
--- /dev/null
+++ b/net-p2p/deluge/files/patch-src___init__.py
@@ -0,0 +1,15 @@
+--- src/__init__.py.orig 2007-08-05 13:08:25.000000000 -0500
++++ src/__init__.py 2007-08-05 13:08:40.000000000 -0500
+@@ -6,9 +6,9 @@
+
+ APP = 'deluge'
+ DIR = os.path.join(INSTALL_PREFIX, 'share', 'locale')
+-locale.setlocale(locale.LC_ALL, '')
+-locale.bindtextdomain(APP, DIR)
+-locale.textdomain(APP)
++#locale.setlocale(locale.LC_ALL, '')
++#locale.bindtextdomain(APP, DIR)
++#locale.textdomain(APP)
+ gettext.bindtextdomain(APP, DIR)
+ gettext.textdomain(APP)
+ gettext.install(APP, DIR)
diff --git a/net-p2p/deluge/files/patch-src_interface.py b/net-p2p/deluge/files/patch-src_interface.py
deleted file mode 100644
index 959e3cb7d95c..000000000000
--- a/net-p2p/deluge/files/patch-src_interface.py
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/interface.py.orig Thu Jul 5 22:48:09 2007
-+++ src/interface.py Thu Jul 5 22:48:21 2007
-@@ -43,9 +43,9 @@
- def __init__(self):
- APP = 'deluge'
- DIR = os.path.join(common.INSTALL_PREFIX, 'share', 'locale')
-- locale.setlocale(locale.LC_ALL, '')
-- locale.bindtextdomain(APP, DIR)
-- locale.textdomain(APP)
-+# locale.setlocale(locale.LC_ALL, '')
-+# locale.bindtextdomain(APP, DIR)
-+# locale.textdomain(APP)
- gettext.bindtextdomain(APP, DIR)
- gettext.textdomain(APP)
- gettext.install(APP, DIR)
diff --git a/net-p2p/deluge/files/patch-src_pref.py b/net-p2p/deluge/files/patch-src_pref.py
new file mode 100644
index 000000000000..a84ed36a3ae9
--- /dev/null
+++ b/net-p2p/deluge/files/patch-src_pref.py
@@ -0,0 +1,11 @@
+--- src/pref.py.orig 2007-08-05 18:25:21.000000000 -0500
++++ src/pref.py 2007-08-05 18:25:36.000000000 -0500
+@@ -108,7 +108,7 @@
+ "tray_downloadspeedlist" : [5.0, 10.0, 30.0, 80.0, 300.0],
+ "tray_passwd" : "",
+ "tray_uploadspeedlist" : [5.0, 10.0, 30.0, 80.0, 300.0],
+- "use_compact_storage" : False,
++ "use_compact_storage" : True,
+ "use_default_dir" : False,
+ "use_natpmp" : False,
+ "use_upnp" : False,