aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/eiskaltdcpp-daemon/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-24 22:20:59 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-24 22:20:59 +0000
commitfb97b52598f8b0669b3697e79d7d9c40c3733c74 (patch)
tree5898649e647351979a2aca79521d26a220a4f2b5 /net-p2p/eiskaltdcpp-daemon/Makefile
parent0f6cee1df143ab8b470c0db43610fbfc037994ea (diff)
downloadports-fb97b52598f8b0669b3697e79d7d9c40c3733c74.tar.gz
ports-fb97b52598f8b0669b3697e79d7d9c40c3733c74.zip
Notes
Diffstat (limited to 'net-p2p/eiskaltdcpp-daemon/Makefile')
-rw-r--r--net-p2p/eiskaltdcpp-daemon/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/net-p2p/eiskaltdcpp-daemon/Makefile b/net-p2p/eiskaltdcpp-daemon/Makefile
index 3dff08b3d7d7..963171a4833d 100644
--- a/net-p2p/eiskaltdcpp-daemon/Makefile
+++ b/net-p2p/eiskaltdcpp-daemon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= eiskaltdcpp-daemon
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.4
CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
@@ -21,12 +21,14 @@ LIB_DEPENDS+= eiskaltdcpp:${PORTSDIR}/net-p2p/eiskaltdcpp-lib
PROJECTHOST= eiskaltdc
USE_XZ= yes
-USE_GCC= 4.2+
+USE_GCC= 4.4+
USE_GETTEXT= yes
USE_CMAKE= yes
USE_OPENSSL= yes
MAKE_JOBS_SAFE= yes
+OPTIONS= XMLRPC "XMLRPC interface support" on
+
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
@@ -38,12 +40,23 @@ CMAKE_ARGS+= -DUSE_QT:BOOL=OFF
CMAKE_ARGS+= -DUSE_GTK:BOOL=OFF
CMAKE_ARGS+= -DNO_UI_DAEMON:BOOL=ON
CMAKE_ARGS+= -DEISKALTDCPP_INCLUDE_DIR:STRING="${LOCALBASE}/include/eiskaltdcpp"
+CMAKE_ARGS+= -DUSE_IDNA:BOOL=OFF
CMAKE_ARGS+= -DCREATE_MO:BOOL=OFF
CMAKE_ARGS+= -DCMAKE_LIBRARY_PATH:PATH="${LOCALBASE}/lib:${PREFIX}/lib"
+CMAKE_ARGS+= -DCMAKE_SKIP_RPATH:BOOL=ON
BUILD_WRKSRC= ${WRKSRC}/nasdc
INSTALL_WRKSRC= ${WRKSRC}/nasdc
+.include <bsd.port.options.mk>
+
+.if defined(WITH_XMLRPC) && !defined(WITHOUT_XMLRPC)
+LIB_DEPENDS+= xmlrpc++:${PORTSDIR}/net/xmlrpc-c-devel
+CMAKE_ARGS+= -DXMLRPC_DAEMON:BOOL=ON
+.else
+CMAKE_ARGS+= -DXMLRPC_DAEMON:BOOL=OFF
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700024