aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/eiskaltdcpp-daemon/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-10 16:44:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-10 16:44:26 +0000
commit494bd7de134d5fb96cdca2c32bd6a29398b9df0b (patch)
treeda9b3a1715b2845fe9af08fab71f44850ec443f0 /net-p2p/eiskaltdcpp-daemon/Makefile
parent4ba7ea37a64ef479dabb07f0152e7b1715fb5611 (diff)
downloadports-494bd7de134d5fb96cdca2c32bd6a29398b9df0b.tar.gz
ports-494bd7de134d5fb96cdca2c32bd6a29398b9df0b.zip
Notes
Diffstat (limited to 'net-p2p/eiskaltdcpp-daemon/Makefile')
-rw-r--r--net-p2p/eiskaltdcpp-daemon/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/net-p2p/eiskaltdcpp-daemon/Makefile b/net-p2p/eiskaltdcpp-daemon/Makefile
index e777bcba775b..8e1b922cf7a3 100644
--- a/net-p2p/eiskaltdcpp-daemon/Makefile
+++ b/net-p2p/eiskaltdcpp-daemon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: net-p2p/eiskaltdc
-# Date created: 28 Aug 2009
-# Whom: Stas Timokhin <stast@bsdportal.ru>
-#
+# Created by: Stas Timokhin <stast@bsdportal.ru>
# $FreeBSD$
-#
PORTNAME= eiskaltdcpp-daemon
PORTVERSION= 2.2.4
@@ -30,7 +26,9 @@ USES= cmake gettext
USE_OPENSSL= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= XMLRPC "XMLRPC interface support" on
+OPTIONS_DEFINE= XMLRPC
+OPTIONS_DEFAULT= XMLRPC
+XMLRPC_DESC= XMLRPC interface support
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
@@ -53,20 +51,14 @@ INSTALL_WRKSRC= ${WRKSRC}/nasdc
.include <bsd.port.options.mk>
-.if defined(WITH_XMLRPC) && !defined(WITHOUT_XMLRPC)
+.if ${PORT_OPTIONS:MXMLRPC}
LIB_DEPENDS+= xmlrpc++:${PORTSDIR}/net/xmlrpc-c-devel
CMAKE_ARGS+= -DXMLRPC_DAEMON:BOOL=ON
.else
CMAKE_ARGS+= -DXMLRPC_DAEMON:BOOL=OFF
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700024
-USE_OPENSSL_PORT=yes
-.endif
-
post-build:
${LOCALBASE}/bin/chrpath -r "${_GCC_RUNTIME}" "${WRKSRC}/nasdc/${PORTNAME}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>