aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/giftcurs/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 11:19:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-06 11:19:54 +0000
commit39a56d0d40b573dfc1b7c2da52fc46f0e6a0cd2c (patch)
tree5d011cbea354a01400af429ffe88f5ee8fbfb170 /net-p2p/giftcurs/Makefile
parent2a7129d9c875d3fd68e7eee4997da17dc3bca613 (diff)
downloadports-39a56d0d40b573dfc1b7c2da52fc46f0e6a0cd2c.tar.gz
ports-39a56d0d40b573dfc1b7c2da52fc46f0e6a0cd2c.zip
Notes
Diffstat (limited to 'net-p2p/giftcurs/Makefile')
-rw-r--r--net-p2p/giftcurs/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-p2p/giftcurs/Makefile b/net-p2p/giftcurs/Makefile
new file mode 100644
index 000000000000..a514d378d244
--- /dev/null
+++ b/net-p2p/giftcurs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: giFTcurs
+# Date created: 2003-09-04
+# Whom: Stefan Ehmann <shoesoft@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giFTcurs
+PORTVERSION= 0.6.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= giftcurs/giFTcurs.pkg/${PORTVERSION}/
+
+MAINTAINER= shoesoft@gmx.net
+COMMENT= A cursed frontend to the giFT daemon
+
+RUN_DEPENDS= ${LOCALBASE}/bin/giftd:${PORTSDIR}/net/gift
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= glib20
+
+MAN1= giFTcurs.1
+MAN5= giFTcurs.conf.5
+
+DOC_FILES= AUTHORS COPYING ChangeLog \
+ INSTALL NEWS README TODO
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>