aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gkremldk/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-20 14:56:38 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-20 14:56:38 +0000
commit424fb2f38518cd0cbab81f8efd7cdfeeb86a0925 (patch)
tree399a1b3ad00cb0995c67429254479d90e456be7b /net-p2p/gkremldk/Makefile
parent9b5b1503ef194d55a8dddbf5c6942bc978da8fd3 (diff)
downloadports-424fb2f38518cd0cbab81f8efd7cdfeeb86a0925.tar.gz
ports-424fb2f38518cd0cbab81f8efd7cdfeeb86a0925.zip
Notes
Diffstat (limited to 'net-p2p/gkremldk/Makefile')
-rw-r--r--net-p2p/gkremldk/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/net-p2p/gkremldk/Makefile b/net-p2p/gkremldk/Makefile
index b234aae0a821..a267e6065474 100644
--- a/net-p2p/gkremldk/Makefile
+++ b/net-p2p/gkremldk/Makefile
@@ -18,13 +18,11 @@ BUILD_DEPENDS= \
${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-USES= pkgconfig
-USE_BZIP2= yes
+USES= pkgconfig tar:bzip2
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -E \
-e 's|^(LFLAGS).*|\1 = ${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib|' \
@@ -33,8 +31,8 @@ post-patch:
${WRKSRC}/Makefile.in
do-install:
- @${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
@${INSTALL_DATA} ${WRKSRC}/gkremldk.so \
- ${PREFIX}/libexec/gkrellm2/plugins
+ ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
.include <bsd.port.mk>