aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gnunet/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-29 15:37:26 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-29 15:37:26 +0000
commitafef1f03b5a14b63f8e960e56b98cc9bf8b2ebf7 (patch)
tree103803979a501e72e7db10d3d2a9adf3a3d672da /net-p2p/gnunet/Makefile
parentc4bd8aa8500f30df4a5b798917d85d2f467f877e (diff)
downloadports-afef1f03b5a14b63f8e960e56b98cc9bf8b2ebf7.tar.gz
ports-afef1f03b5a14b63f8e960e56b98cc9bf8b2ebf7.zip
Notes
Diffstat (limited to 'net-p2p/gnunet/Makefile')
-rw-r--r--net-p2p/gnunet/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index f1899589deb1..6fda7510d9c5 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gnunet
-PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTVERSION= 0.6.1c
CATEGORIES= net
MASTER_SITES= http://www.ovmj.org/GNUnet/download/ \
${MASTER_SITE_GNU}
@@ -97,9 +96,12 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @{FIND} ${WRKSRC} -name configure | ${XARGS} \
- @${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name configure | ${XARGS} \
+ ${REINPLACE_CMD} -e \
's|-pthread [\$$]CFLAGS|${PTHREAD_CFLAGS} \$$CFLAGS|g ; \
s|-lpthread|${PTHREAD_LIBS}|g'
+ ${REINPLACE_CMD} -e \
+ 's|^#include <values.h>|#include <limits.h>|g' \
+ ${WRKSRC}/src/applications/afs/module/manager.c
.include <bsd.port.mk>