aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gnunet/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-05-31 13:27:41 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-05-31 13:27:41 +0000
commitf847ee66b135fa7e039a0e8d7195789f6ba31282 (patch)
tree2da555fcdb4895429b0e719e3f11731919ab4f01 /net-p2p/gnunet/Makefile
parent5b3c113ff0240c235a806424f3a8d5dc0585a4d0 (diff)
downloadports-f847ee66b135fa7e039a0e8d7195789f6ba31282.tar.gz
ports-f847ee66b135fa7e039a0e8d7195789f6ba31282.zip
Notes
Diffstat (limited to 'net-p2p/gnunet/Makefile')
-rw-r--r--net-p2p/gnunet/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 8cfd07b004e4..f310389a6ca6 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnunet
DISTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= net-p2p ipv6 security
MASTER_SITES= GNU
@@ -52,6 +53,9 @@ MAN1= gnunet-arm.1 gnunet-directory.1 gnunet-download.1 \
gnunet-search.1 gnunet-statistics.1 gnunet-transport.1 \
gnunet-unindex.1 gnunet-vpn.1
+#If a non-default GNUNET_DAEMON_DIR is defined, the home directory
+#of the gnunet user may need to be adjusted -- e.g., via:
+#pw usermod gnunet -d $GNUNET_DAEMON_DIR
GNUNET_DAEMON_DIR?= /var/lib/gnunet
PLIST_SUB= GNUNET_DAEMON_DIR=${GNUNET_DAEMON_DIR}
SUB_FILES= pkg-message
@@ -63,7 +67,8 @@ PORTDOCS= AUTHORS COPYING ChangeLog NEWS README
.endif
.if !defined(NOPORTEXAMPLES)
-PORTEXAMPLES= gnunet_janitor.py gnunet_pyexpect.py hostlist.cgi hostlist.php report.sh
+PORTEXAMPLES= gnunet_janitor.py gnunet_pyexpect.py hostlist.cgi hostlist.php \
+report.sh
.endif
.if defined(WITH_HTTP)
@@ -125,8 +130,8 @@ post-patch:
${WRKSRC}/pkgconfig/Makefile.in
post-install:
- @${PRINTF} "%s\n%s\n" "[PATHS]" "SERVICEHOME = ${GNUNET_DAEMON_DIR}" \
- > ${PREFIX}/etc/gnunet.conf.sample
+ @${PRINTF} "%s\n%s\n%s\n" "[PATHS]" "SERVICEHOME = ${GNUNET_DAEMON_DIR}" \
+ "DEFAULTCONFIG = ${PREFIX}/etc/gnunet.conf" > ${PREFIX}/etc/gnunet.conf.sample
.if !exists(${PREFIX}/etc/gnunet.conf)
@${CP} ${PREFIX}/etc/gnunet.conf.sample ${PREFIX}/etc/gnunet.conf
.endif