aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gnunet
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-04 23:14:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-04 23:14:16 +0000
commit1e342c6976d57bb1619e7a6b79f5d2a3e12a27d8 (patch)
tree6c2762ce1416e466828c2963d28958db1ff0df7a /net-p2p/gnunet
parent119c0720e58269230f7591f6bd859e4910e88303 (diff)
downloadports-1e342c6976d57bb1619e7a6b79f5d2a3e12a27d8.tar.gz
ports-1e342c6976d57bb1619e7a6b79f5d2a3e12a27d8.zip
Notes
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/Makefile28
-rw-r--r--net-p2p/gnunet/distinfo6
-rw-r--r--net-p2p/gnunet/files/patch-src__include__platform.h10
-rw-r--r--net-p2p/gnunet/files/patch-src__util__boot__lib_argz.c10
-rw-r--r--net-p2p/gnunet/pkg-plist32
5 files changed, 61 insertions, 25 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index 57fafa084537..f20977f0d383 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gnunet
-PORTVERSION= 0.8.0c
+PORTVERSION= 0.8.1
CATEGORIES= net-p2p ipv6
MASTER_SITES= GNU \
http://gnunet.org/download/
@@ -30,30 +30,33 @@ OPTIONS= MYSQL "Enable MySQL support" on \
PGSQL "Enable PostgreSQL support" off \
SQLITE "Enable SQLite support" off
-USE_BZIP2= yes
USE_GNOME= gnomehack libglade2
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libltdl:22 libtool:22
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-ltdl-install \
- --without-dialog \
- --without-cdialog \
- --without-qt
+CONFIGURE_ARGS= --with-dialog=no \
+ --with-cdialog=no \
+ --with-qt=no \
+ --with-daemon-home-dir=${DBDIR} \
+ --with-daemon-config-dir=${PREFIX}/etc
USE_LDCONFIG= yes
+PLIST_SUB= DBDIR="${DBDIR}"
+
MAN1= gnunet-auto-share.1 gnunet-chat.1 gnunet-directory.1 \
- gnunet-download-manager.1 gnunet-download.1 gnunet-insert.1 \
- gnunet-peer-info.1 gnunet-pseudonym.1 gnunet-search.1 \
- gnunet-setup.1 gnunet-stats.1 gnunet-tbench.1 \
- gnunet-testbed.1 gnunet-tracekit.1 gnunet-transport-check.1 \
- gnunet-unindex.1 gnunet-update.1 gnunet-vpn.1 \
- gnunetd.1
+ gnunet-download.1 gnunet-insert.1 gnunet-peer-info.1 \
+ gnunet-pseudonym.1 gnunet-search.1 gnunet-setup.1 \
+ gnunet-stats.1 gnunet-tbench.1 gnunet-testbed.1 \
+ gnunet-tracekit.1 gnunet-transport-check.1 gnunet-unindex.1 \
+ gnunet-update.1 gnunet-vpn.1 gnunetd.1
MAN5= gnunet.conf.5 gnunetd.conf.5
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+DBDIR= /var/db/${PORTNAME}
+
.include <bsd.port.pre.mk>
.if defined(WITHOUT_MYSQL)
@@ -90,6 +93,7 @@ post-patch:
.endfor
post-install:
+ @${MKDIR} ${DBDIR}
.for i in gnunet.conf gnunetd.conf
${INSTALL_DATA} ${WRKSRC}/contrib/${i} ${PREFIX}/etc/${i}-dist
.endfor
diff --git a/net-p2p/gnunet/distinfo b/net-p2p/gnunet/distinfo
index 8356c366b6ef..5bf66a5fb3c8 100644
--- a/net-p2p/gnunet/distinfo
+++ b/net-p2p/gnunet/distinfo
@@ -1,3 +1,3 @@
-MD5 (GNUnet-0.8.0c.tar.bz2) = c98c4c8c538013f69e12e586c63b281e
-SHA256 (GNUnet-0.8.0c.tar.bz2) = 03ad449f8acc3abb0f6afcd496dfb04a48c1eb811df57a856f46eb9334e79c22
-SIZE (GNUnet-0.8.0c.tar.bz2) = 1448541
+MD5 (GNUnet-0.8.1.tar.gz) = 906a65f70f403f70798bb7c89b45b3b6
+SHA256 (GNUnet-0.8.1.tar.gz) = 84da584f2b60f2026a19e38d4264c794420135323644f7b0785d67ed44815355
+SIZE (GNUnet-0.8.1.tar.gz) = 2339085
diff --git a/net-p2p/gnunet/files/patch-src__include__platform.h b/net-p2p/gnunet/files/patch-src__include__platform.h
new file mode 100644
index 000000000000..f10dbcd587bf
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src__include__platform.h
@@ -0,0 +1,10 @@
+--- src/include/platform.h.orig 2009-10-01 07:11:14.000000000 +0900
++++ src/include/platform.h 2010-01-05 00:27:09.000000000 +0900
+@@ -189,6 +189,7 @@
+ #endif
+
+ #ifdef FREEBSD
++typedef int error_t;
+ #define __BYTE_ORDER BYTE_ORDER
+ #define __BIG_ENDIAN BIG_ENDIAN
+ #endif
diff --git a/net-p2p/gnunet/files/patch-src__util__boot__lib_argz.c b/net-p2p/gnunet/files/patch-src__util__boot__lib_argz.c
new file mode 100644
index 000000000000..c8b7914e1ddb
--- /dev/null
+++ b/net-p2p/gnunet/files/patch-src__util__boot__lib_argz.c
@@ -0,0 +1,10 @@
+--- src/util/boot/lib_argz.c.orig 2009-11-17 03:51:38.000000000 +0900
++++ src/util/boot/lib_argz.c 2010-01-05 00:27:35.000000000 +0900
+@@ -16,6 +16,7 @@
+ with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */
+
++#include "platform.h"
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/net-p2p/gnunet/pkg-plist b/net-p2p/gnunet/pkg-plist
index ed25ad3789d1..07be59a6ff28 100644
--- a/net-p2p/gnunet/pkg-plist
+++ b/net-p2p/gnunet/pkg-plist
@@ -14,7 +14,6 @@ bin/gnunet-transport-check
bin/gnunet-unindex
bin/gnunet-update
bin/gnunetd
-bin/remotetest
etc/gnunet.conf-dist
etc/gnunetd.conf-dist
include/GNUnet/gnunet_bootstrap_service.h
@@ -22,10 +21,12 @@ include/GNUnet/gnunet_chat_lib.h
include/GNUnet/gnunet_collection_lib.h
include/GNUnet/gnunet_core.h
include/GNUnet/gnunet_datastore_service.h
-include/GNUnet/gnunet_dht_lib.h
-include/GNUnet/gnunet_dht_service.h
+include/GNUnet/gnunet_dhtlog_service.h
include/GNUnet/gnunet_directories.h
include/GNUnet/gnunet_dstore_service.h
+include/GNUnet/gnunet_dv_dht_lib.h
+include/GNUnet/gnunet_dv_dht_service.h
+include/GNUnet/gnunet_dv_service.h
include/GNUnet/gnunet_ecrs_lib.h
include/GNUnet/gnunet_fragmentation_service.h
include/GNUnet/gnunet_fs_lib.h
@@ -86,15 +87,24 @@ lib/GNUnet/libgnunetmodule_chat.so
lib/GNUnet/libgnunetmodule_datastore.a
lib/GNUnet/libgnunetmodule_datastore.la
lib/GNUnet/libgnunetmodule_datastore.so
-lib/GNUnet/libgnunetmodule_dht.a
-lib/GNUnet/libgnunetmodule_dht.la
-lib/GNUnet/libgnunetmodule_dht.so
+%%MYSQL%%lib/GNUnet/libgnunetmodule_dhtlog_mysql.a
+%%MYSQL%%lib/GNUnet/libgnunetmodule_dhtlog_mysql.la
+%%MYSQL%%lib/GNUnet/libgnunetmodule_dhtlog_mysql.so
%%MYSQL%%lib/GNUnet/libgnunetmodule_dstore_mysql.a
%%MYSQL%%lib/GNUnet/libgnunetmodule_dstore_mysql.la
%%MYSQL%%lib/GNUnet/libgnunetmodule_dstore_mysql.so
%%SQLITE%%lib/GNUnet/libgnunetmodule_dstore_sqlite.a
%%SQLITE%%lib/GNUnet/libgnunetmodule_dstore_sqlite.la
%%SQLITE%%lib/GNUnet/libgnunetmodule_dstore_sqlite.so
+lib/GNUnet/libgnunetmodule_dv.a
+lib/GNUnet/libgnunetmodule_dv.la
+lib/GNUnet/libgnunetmodule_dv.so
+lib/GNUnet/libgnunetmodule_dv_dht.a
+lib/GNUnet/libgnunetmodule_dv_dht.la
+lib/GNUnet/libgnunetmodule_dv_dht.so
+lib/GNUnet/libgnunetmodule_dv_tbench.a
+lib/GNUnet/libgnunetmodule_dv_tbench.la
+lib/GNUnet/libgnunetmodule_dv_tbench.so
lib/GNUnet/libgnunetmodule_fragmentation.a
lib/GNUnet/libgnunetmodule_fragmentation.la
lib/GNUnet/libgnunetmodule_fragmentation.so
@@ -191,10 +201,10 @@ lib/libgnunetcore.a
lib/libgnunetcore.la
lib/libgnunetcore.so
lib/libgnunetcore.so.0
-lib/libgnunetdhtapi.a
-lib/libgnunetdhtapi.la
-lib/libgnunetdhtapi.so
-lib/libgnunetdhtapi.so.0
+lib/libgnunetdvdhtapi.a
+lib/libgnunetdvdhtapi.la
+lib/libgnunetdvdhtapi.so
+lib/libgnunetdvdhtapi.so.0
lib/libgnunetecrs.a
lib/libgnunetecrs.la
lib/libgnunetecrs.so
@@ -296,3 +306,5 @@ share/locale/vi/LC_MESSAGES/GNUnet.mo
@dirrm share/GNUnet
@dirrm lib/GNUnet
@dirrm include/GNUnet
+@exec mkdir -p %%DBDIR%%
+@unexec rmdir %%DBDIR%% 2>/dev/null || true