aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gtk-gnutella/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-25 15:27:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-25 15:27:11 +0000
commit1331c17c9147bbd71a081386ab89d0eb1de3ce24 (patch)
treeff7b1dcda77facdfafa6db2951538d87b0c39f71 /net-p2p/gtk-gnutella/Makefile
parent22e1be531eea2188ac3d4adb0eab63df0d947e11 (diff)
downloadports-1331c17c9147bbd71a081386ab89d0eb1de3ce24.tar.gz
ports-1331c17c9147bbd71a081386ab89d0eb1de3ce24.zip
Notes
Diffstat (limited to 'net-p2p/gtk-gnutella/Makefile')
-rw-r--r--net-p2p/gtk-gnutella/Makefile33
1 files changed, 28 insertions, 5 deletions
diff --git a/net-p2p/gtk-gnutella/Makefile b/net-p2p/gtk-gnutella/Makefile
index a1ab15e99c64..61d6940e3a0f 100644
--- a/net-p2p/gtk-gnutella/Makefile
+++ b/net-p2p/gtk-gnutella/Makefile
@@ -24,8 +24,7 @@
#
PORTNAME= gtk-gnutella
-PORTVERSION= 0.95.4
-PORTREVISION= 1
+DISTVERSION= 0.96b
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://gtk-gnutella.sourceforge.net/download/ \
@@ -47,16 +46,24 @@ CONFIGURE_ARGS= -Dyacc='bison -y' -Dofficial='true' -Dprefix=${PREFIX} \
-Dprivlib=${PREFIX}/share/gtk-gnutella \
-Dsysman=${PREFIX}/man/man1 -Dlocale=${PREFIX}/share/locale \
-Dcc='${CC}' -Dccflags='${CFLAGS} -I${LOCALBASE}/include' \
- -Doptimize='undef' -Dlibpth='/usr/lib ${LOCALBASE}/lib'
+ -Doptimize='undef' -Dlibpth='/usr/lib ${LOCALBASE}/lib' \
+ -Dd_enablenls='define'
MAN1= gtk-gnutella.1
-OPTIONS= DEBUG "Build with debugging symbols" off \
- GTK2 "Build with gtk2 frontend" on \
+OPTIONS= GTK2 "Build with gtk2 frontend" on \
+ TLS "enable GNU TLS encryption support" off \
+ IPV6 "enable IPv6 support" off \
+ DBUS "enable DBUS support" off \
+ DEBUG "Build with debugging symbols" off \
PORTABILITY "Use the PATH variable at run-time" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile"
+.endif
+
.if !defined(INTERACTIVE_CONFIGURE)
CONFIGURE_ARGS+= -d -e
.endif
@@ -77,4 +84,20 @@ USE_GNOME+= gtk12
CONFIGURE_ARGS+= -Dd_portable=true
.endif
+.if defined(WITH_TLS)
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+.else
+CONFIGURE_ARGS+= -Dd_gnutls=undef
+.endif
+
+.if !defined(WITH_IPV6)
+CONFIGURE_ARGS+= -D ipv6=false
+.endif
+
+.if defined(WITH_DBUS)
+LIB_DEPENDS+= dbus:${PORTSDIR}/devel/dbus
+.else
+CONFIGURE_ARGS+= -D dbus=false
+.endif
+
.include <bsd.port.post.mk>