aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gtkhx
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-11-19 15:07:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-11-19 15:07:19 +0000
commit96bc072f91d794be75613052a73cac2aa11734b3 (patch)
treebd1c091c83efb856a4eb23d8216d7a1f645d7a54 /net-p2p/gtkhx
parent0409b687800bde7a13caf32c4c17c69171d2b7be (diff)
downloadports-96bc072f91d794be75613052a73cac2aa11734b3.tar.gz
ports-96bc072f91d794be75613052a73cac2aa11734b3.zip
Notes
Diffstat (limited to 'net-p2p/gtkhx')
-rw-r--r--net-p2p/gtkhx/Makefile37
-rw-r--r--net-p2p/gtkhx/distinfo2
-rw-r--r--net-p2p/gtkhx/files/patch-src__cicn.h23
-rw-r--r--net-p2p/gtkhx/files/patch-src__files.c20
-rw-r--r--net-p2p/gtkhx/files/patch-src__hx.h13
-rw-r--r--net-p2p/gtkhx/pkg-descr5
-rw-r--r--net-p2p/gtkhx/pkg-plist13
7 files changed, 0 insertions, 113 deletions
diff --git a/net-p2p/gtkhx/Makefile b/net-p2p/gtkhx/Makefile
deleted file mode 100644
index 4fc66125bed2..000000000000
--- a/net-p2p/gtkhx/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# Created by: Josh Elsasser <jre@vineyard.net>
-# $FreeBSD$
-
-PORTNAME= gtkhx
-PORTVERSION= 0.9.4
-PORTREVISION= 8
-CATEGORIES= net-p2p
-MASTER_SITES= SF
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GTK+ version of Hx, a UNIX Hotline Client
-
-LICENSE= GPLv2
-
-USES= pathfix gmake
-USE_GNOME= gdkpixbuf
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
-NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-I/usr/local/include||g ; \
- s|-L/usr/local/lib||g ; \
- s|^mandir =.*$$|mandir = $${prefix}/man/man1|g'
- @${REINPLACE_CMD} -e 's|^CC =|#CC =|g' ${WRKSRC}/plugins/eliza/Makefile
- @${REINPLACE_CMD} -e 's|^CC=|#CC=|g ; \
- s|$$CFLAGS -O2|$$CFLAGS|g ; \
- s|-g -Wall|$$CFLAGS -Wall|g' ${WRKSRC}/configure
-
-.include <bsd.port.mk>
diff --git a/net-p2p/gtkhx/distinfo b/net-p2p/gtkhx/distinfo
deleted file mode 100644
index 481226049a74..000000000000
--- a/net-p2p/gtkhx/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gtkhx-0.9.4.tar.gz) = b6dc5f2c8e23a7e78bf81eee73f29878f028def7c1552cd83466abf274ae1db2
-SIZE (gtkhx-0.9.4.tar.gz) = 579966
diff --git a/net-p2p/gtkhx/files/patch-src__cicn.h b/net-p2p/gtkhx/files/patch-src__cicn.h
deleted file mode 100644
index 9b4b6ec77043..000000000000
--- a/net-p2p/gtkhx/files/patch-src__cicn.h
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/cicn.h.orig 2014-11-05 22:52:21.000000000 -0800
-+++ src/cicn.h 2014-11-05 22:54:42.000000000 -0800
-@@ -1,7 +1,9 @@
-+#include <inttypes.h>
-+
- #define TYPE_cicn 0x6369636e
-
--typedef void *Ptr;
--typedef void **Handle;
-+typedef uint32_t Ptr;
-+typedef uint32_t Handle;
- typedef guint32 Fixed;
-
- struct Rect {
-@@ -39,7 +41,7 @@
- };
-
- typedef struct ColorTable ColorTable;
--typedef ColorTable *CTabPtr, **CTabHandle;
-+typedef uint32_t CTabHandle;
-
- struct PixMap {
- Ptr baseAddr PACKED; /* pointer to pixels */
diff --git a/net-p2p/gtkhx/files/patch-src__files.c b/net-p2p/gtkhx/files/patch-src__files.c
deleted file mode 100644
index d7150d1539a2..000000000000
--- a/net-p2p/gtkhx/files/patch-src__files.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/files.c.orig Tue Apr 8 05:05:31 2003
-+++ src/files.c Sun Jan 6 01:52:06 2008
-@@ -1000,7 +1000,7 @@
- gtk_hlist_clear(GTK_HLIST(files_list));
-
- for (fh = cfl->fh; (guint32)((char *)fh - (char *)cfl->fh) < cfl->fhlen;
-- (char *)fh += fh->len + SIZEOF_HL_DATA_HDR) {
-+ fh = (char *)fh + fh->len + SIZEOF_HL_DATA_HDR) {
- fh->fnlen = ntohl(fh->fnlen);
- fh->len = ntohs(fh->len);
- fh->fsize = ntohl(fh->fsize);
-@@ -1304,7 +1304,7 @@
- return 0;
-
- for (fh = cfl->fh; (guint32)((char *)fh - (char *)cfl->fh) < cfl->fhlen;
-- (char *)fh += fh->len + SIZEOF_HL_DATA_HDR) {
-+ fh = (char *)fh + fh->len + SIZEOF_HL_DATA_HDR) {
- if ((int)fh->fnlen == len && !strncmp(fh->fname, ent, len))
- return 1;
- }
diff --git a/net-p2p/gtkhx/files/patch-src__hx.h b/net-p2p/gtkhx/files/patch-src__hx.h
deleted file mode 100644
index 5a10948e68cc..000000000000
--- a/net-p2p/gtkhx/files/patch-src__hx.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/hx.h.orig Tue Apr 8 05:05:31 2003
-+++ src/hx.h Fri Jan 11 01:49:32 2008
-@@ -172,10 +172,6 @@
-
- extern char **hxd_environ;
-
--#if !defined(HAVE_INET_NTOA_R)
--extern int inet_ntoa_r (struct in_addr in, char *buf, size_t buflen);
--#endif
--
- #ifndef HAVE_LOCALTIME_R
- extern struct tm *localtime_r (const time_t *t, struct tm *tm);
- #endif
diff --git a/net-p2p/gtkhx/pkg-descr b/net-p2p/gtkhx/pkg-descr
deleted file mode 100644
index e4e11a6c7bca..000000000000
--- a/net-p2p/gtkhx/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-GtkHx is a GTK Hotline client. Hotline is a protocol which allows you
-to chat, send messages, read and post news, and transfer files with
-other users connected to a Hotline server.
-
-WWW: http://gtkhx.sourceforge.net/
diff --git a/net-p2p/gtkhx/pkg-plist b/net-p2p/gtkhx/pkg-plist
deleted file mode 100644
index 83eec511f373..000000000000
--- a/net-p2p/gtkhx/pkg-plist
+++ /dev/null
@@ -1,13 +0,0 @@
-bin/gtkhx
-man/man1/gtkhx.1.gz
-%%DATADIR%%/sounds/chatinvite.aiff
-%%DATADIR%%/sounds/chatpost.aiff
-%%DATADIR%%/sounds/error.aiff
-%%DATADIR%%/sounds/filedone.aiff
-%%DATADIR%%/sounds/join.aiff
-%%DATADIR%%/sounds/logged-in.aiff
-%%DATADIR%%/sounds/message.aiff
-%%DATADIR%%/sounds/newspost.aiff
-%%DATADIR%%/sounds/part.aiff
-%%DATADIR%%/icons.rsrc
-%%NLS%%share/locale/fr/LC_MESSAGES/gtkhx.mo