aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/i2p
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-04-21 20:09:35 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-04-21 20:09:35 +0000
commitdb71196212257043a80aa9276487ecee238b2c54 (patch)
treeb10b9501204b145d3938b5bfa5d24c251e7236d9 /net-p2p/i2p
parent503c332b132411fe9c89637fa85dc0bd5c0ba2a5 (diff)
downloadports-db71196212257043a80aa9276487ecee238b2c54.tar.gz
ports-db71196212257043a80aa9276487ecee238b2c54.zip
Notes
Diffstat (limited to 'net-p2p/i2p')
-rw-r--r--net-p2p/i2p/Makefile28
-rw-r--r--net-p2p/i2p/files/patch-apps__jetty__build.xml11
-rw-r--r--net-p2p/i2p/files/patch-build.xml10
3 files changed, 48 insertions, 1 deletions
diff --git a/net-p2p/i2p/Makefile b/net-p2p/i2p/Makefile
index 2145601bbf59..b93d38111e18 100644
--- a/net-p2p/i2p/Makefile
+++ b/net-p2p/i2p/Makefile
@@ -7,13 +7,22 @@
PORTNAME= i2p
PORTVERSION= 0.6.1.16
+PORTREVISION= 1
CATEGORIES= net-p2p java security
MASTER_SITES= http://dev.i2p.net/i2p/
MAINTAINER= lioux@FreeBSD.org
COMMENT= An anonymous network
-BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.a:${PORTSDIR}/math/libgmp4
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.a:${PORTSDIR}/math/libgmp4 \
+ ${JAVASHAREDIR}/jetty/ext/ant.jar:${PORTSDIR}/www/jetty \
+ ${JAVASHAREDIR}/jetty/ext/commons-el.jar:${PORTSDIR}/www/jetty \
+ ${JAVASHAREDIR}/jetty/ext/commons-logging.jar:${PORTSDIR}/www/jetty \
+ ${JAVASHAREDIR}/jetty/ext/jasper-compiler.jar:${PORTSDIR}/www/jetty \
+ ${JAVASHAREDIR}/jetty/ext/jasper-runtime.jar:${PORTSDIR}/www/jetty \
+ ${JAVASHAREDIR}/jetty/ext/xercesImpl.jar:${PORTSDIR}/www/jetty \
+ ${JAVASHAREDIR}/jetty/lib/javax.servlet.jar:${PORTSDIR}/www/jetty \
+ ${JAVASHAREDIR}/jetty/lib/org.mortbay.jetty.jar:${PORTSDIR}/www/jetty
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
USE_BZIP2= yes
@@ -70,6 +79,16 @@ PLIST_FILES= \
%%DATADIR%%/i2p.tar.bz2 \
%%DATADIR%%/i2pupdate.zip
+JETTY_JAR_FILES= \
+ ext/ant.jar \
+ ext/commons-el.jar \
+ ext/commons-logging.jar \
+ ext/jasper-compiler.jar \
+ ext/jasper-runtime.jar \
+ ext/xercesImpl.jar \
+ lib/javax.servlet.jar \
+ lib/org.mortbay.jetty.jar
+
post-patch:
@${SED} \
-e "s|%%DATADIR%%|${DATADIR}|" \
@@ -79,6 +98,13 @@ post-patch:
-e 's|./i2prouter[[:space:]]+start||' \
${WRKSRC}/installer/resources/postinstall.sh
+pre-build:
+# copy jetty jars instead of fetching/building
+ @${MKDIR} ${WRKSRC}/apps/jetty/jettylib
+.for file in ${JETTY_JAR_FILES}
+ @${CP} ${JAVASHAREDIR}/jetty/${file} ${WRKSRC}/apps/jetty/jettylib
+.endfor
+
do-install:
@${MKDIR} ${DATADIR}
# install
diff --git a/net-p2p/i2p/files/patch-apps__jetty__build.xml b/net-p2p/i2p/files/patch-apps__jetty__build.xml
new file mode 100644
index 000000000000..575047a96e6b
--- /dev/null
+++ b/net-p2p/i2p/files/patch-apps__jetty__build.xml
@@ -0,0 +1,11 @@
+--- apps/jetty/build.xml.orig Fri Apr 21 15:31:49 2006
++++ apps/jetty/build.xml Fri Apr 21 15:32:09 2006
+@@ -37,7 +37,7 @@
+ <copy file="jetty-5.1.6/ext/commons-logging-api.jar" tofile="jettylib/commons-logging.jar" />
+ <delete dir="jetty-5.1.6" />
+ </target>
+- <target name="build" depends="fetchJettylib" />
++ <target name="build" />
+ <target name="builddep" />
+ <target name="compile" />
+ <target name="jar" />
diff --git a/net-p2p/i2p/files/patch-build.xml b/net-p2p/i2p/files/patch-build.xml
new file mode 100644
index 000000000000..d761e63d11e4
--- /dev/null
+++ b/net-p2p/i2p/files/patch-build.xml
@@ -0,0 +1,10 @@
+--- build.xml.orig Mon Feb 20 06:27:46 2006
++++ build.xml Fri Apr 21 15:02:11 2006
+@@ -41,7 +41,6 @@
+ <copy file="router/java/build/router.jar" todir="build/" />
+ </target>
+ <target name="buildWEB">
+- <ant dir="apps/jetty" target="fetchJettylib" />
+ <ant dir="apps/routerconsole/java" target="build" />
+ <copy file="apps/routerconsole/java/build/routerconsole.jar" todir="build/" />
+ <copy file="apps/routerconsole/java/build/routerconsole.war" todir="build/" />