aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/ktorrent
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-21 20:39:12 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-21 20:39:12 +0000
commit893c707955a3839d9ee9ae0b35a23f6268b62279 (patch)
tree57a8c912f88f8cfd58634793c6fd160da29e5279 /net-p2p/ktorrent
parent85c841d500bbca3bebe0a30017ec576bc129d88d (diff)
downloadports-893c707955a3839d9ee9ae0b35a23f6268b62279.tar.gz
ports-893c707955a3839d9ee9ae0b35a23f6268b62279.zip
Notes
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/Makefile21
-rw-r--r--net-p2p/ktorrent/distinfo6
-rw-r--r--net-p2p/ktorrent/pkg-plist426
3 files changed, 36 insertions, 417 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index c924ea81eefe..3fc48b2fd8f5 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ktorrent
-PORTVERSION= 3.3.4
-PORTREVISION= 4
+PORTVERSION= 4.0.4
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${PORTVERSION}/
@@ -16,26 +15,22 @@ COMMENT= BitTorrent client for KDE
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
qca.2:${PORTSDIR}/devel/qca \
- streamanalyzer.0:${PORTSDIR}/deskutils/strigi \
- tag.1:${PORTSDIR}/audio/taglib
+ tag.1:${PORTSDIR}/audio/taglib \
+ ktorrent.2:${PORTSDIR}/net-p2p/libktorrent
USE_BZIP2= yes
USE_KDE4= kdelibs kdehier kdeprefix automoc4
USE_QT_VER= 4
-QT_COMPONENTS= qt3support dbus gui network sql svg xml \
- qmake_build moc_build rcc_build uic_build
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
USE_CMAKE= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
OPTIONS= SYNDICATION "Enable RSS/Atom plugin" on \
PLASMA "Enable Ktorrent Plasma applet" on
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-MAKE_JOBS_SAFE= yes
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(WITHOUT_SYNDICATION)
USE_KDE4+= pimlibs
@@ -56,6 +51,8 @@ pre-configure:
.if defined(WITHOUT_PLASMA)
${REINPLACE_CMD} -e '/add_subdirectory(applet)/d' \
${WRKSRC}/plasma/CMakeLists.txt
+ ${REINPLACE_CMD} -e '/^macro_kt_plugin.*shutdown/d' \
+ ${WRKSRC}/plugins/CMakeLists.txt
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/ktorrent/distinfo b/net-p2p/ktorrent/distinfo
index bf859d7db89f..bba344654b09 100644
--- a/net-p2p/ktorrent/distinfo
+++ b/net-p2p/ktorrent/distinfo
@@ -1,3 +1,3 @@
-MD5 (ktorrent-3.3.4.tar.bz2) = 7d7dba06a78d09494199bd4ef82e5527
-SHA256 (ktorrent-3.3.4.tar.bz2) = f31fb80569df7f102685c85becb73fa1cac239ae8e9399424abb8c0048289826
-SIZE (ktorrent-3.3.4.tar.bz2) = 2786041
+MD5 (ktorrent-4.0.4.tar.bz2) = bbd5f1419d9ec1411f4191c871c57101
+SHA256 (ktorrent-4.0.4.tar.bz2) = 4de04972e373716f89ea6d056faeda73b787b0112d5a805e82098830074b774f
+SIZE (ktorrent-4.0.4.tar.bz2) = 2816236
diff --git a/net-p2p/ktorrent/pkg-plist b/net-p2p/ktorrent/pkg-plist
index f9a289d9c6aa..fb5f2d8343cc 100644
--- a/net-p2p/ktorrent/pkg-plist
+++ b/net-p2p/ktorrent/pkg-plist
@@ -1,147 +1,12 @@
+bin/ktmagnetdownloader
bin/ktorrent
bin/ktupnptest
-include/libbtcore/bcodec/bdecoder.h
-include/libbtcore/bcodec/bencoder.h
-include/libbtcore/bcodec/bnode.h
-include/libbtcore/bcodec/value.h
-include/libbtcore/btcore_export.h
-include/libbtcore/btversion.h
-include/libbtcore/datachecker/datachecker.h
-include/libbtcore/datachecker/datacheckerjob.h
-include/libbtcore/datachecker/datacheckerlistener.h
-include/libbtcore/datachecker/datacheckerthread.h
-include/libbtcore/datachecker/multidatachecker.h
-include/libbtcore/datachecker/singledatachecker.h
-include/libbtcore/dht/announcetask.h
-include/libbtcore/dht/database.h
-include/libbtcore/dht/dht.h
-include/libbtcore/dht/dhtbase.h
-include/libbtcore/dht/dhttrackerbackend.h
-include/libbtcore/dht/kbucket.h
-include/libbtcore/dht/kclosestnodessearch.h
-include/libbtcore/dht/key.h
-include/libbtcore/dht/node.h
-include/libbtcore/dht/nodelookup.h
-include/libbtcore/dht/pack.h
-include/libbtcore/dht/rpccall.h
-include/libbtcore/dht/rpcmsg.h
-include/libbtcore/dht/rpcserver.h
-include/libbtcore/dht/task.h
-include/libbtcore/dht/taskmanager.h
-include/libbtcore/diskio/cache.h
-include/libbtcore/diskio/cachefile.h
-include/libbtcore/diskio/chunk.h
-include/libbtcore/diskio/chunkmanager.h
-include/libbtcore/diskio/deletedatafilesjob.h
-include/libbtcore/diskio/dndfile.h
-include/libbtcore/diskio/movedatafilesjob.h
-include/libbtcore/diskio/multifilecache.h
-include/libbtcore/diskio/piecedata.h
-include/libbtcore/diskio/preallocationjob.h
-include/libbtcore/diskio/preallocationthread.h
-include/libbtcore/diskio/singlefilecache.h
-include/libbtcore/download/chunkdownload.h
-include/libbtcore/download/chunkselector.h
-include/libbtcore/download/downloader.h
-include/libbtcore/download/packet.h
-include/libbtcore/download/piece.h
-include/libbtcore/download/request.h
-include/libbtcore/interfaces/blocklistinterface.h
-include/libbtcore/interfaces/cachefactory.h
-include/libbtcore/interfaces/chunkdownloadinterface.h
-include/libbtcore/interfaces/chunkselectorinterface.h
-include/libbtcore/interfaces/exitoperation.h
-include/libbtcore/interfaces/logmonitorinterface.h
-include/libbtcore/interfaces/monitorinterface.h
-include/libbtcore/interfaces/peerinterface.h
-include/libbtcore/interfaces/peersource.h
-include/libbtcore/interfaces/piecedownloader.h
-include/libbtcore/interfaces/queuemanagerinterface.h
-include/libbtcore/interfaces/torrentfileinterface.h
-include/libbtcore/interfaces/torrentinterface.h
-include/libbtcore/interfaces/trackerinterface.h
-include/libbtcore/interfaces/trackerslist.h
-include/libbtcore/interfaces/webseedinterface.h
-include/libbtcore/migrate/cachemigrate.h
-include/libbtcore/migrate/ccmigrate.h
-include/libbtcore/migrate/migrate.h
-include/libbtcore/mse/bigint.h
-include/libbtcore/mse/encryptedauthenticate.h
-include/libbtcore/mse/encryptedserverauthenticate.h
-include/libbtcore/mse/functions.h
-include/libbtcore/mse/rc4encryptor.h
-include/libbtcore/mse/streamsocket.h
-include/libbtcore/net/address.h
-include/libbtcore/net/bufferedsocket.h
-include/libbtcore/net/downloadthread.h
-include/libbtcore/net/networkthread.h
-include/libbtcore/net/portlist.h
-include/libbtcore/net/reverseresolver.h
-include/libbtcore/net/socket.h
-include/libbtcore/net/socketgroup.h
-include/libbtcore/net/socketmonitor.h
-include/libbtcore/net/socks.h
-include/libbtcore/net/speed.h
-include/libbtcore/net/uploadthread.h
-include/libbtcore/peer/accessmanager.h
-include/libbtcore/peer/authenticate.h
-include/libbtcore/peer/authenticatebase.h
-include/libbtcore/peer/authenticationmonitor.h
-include/libbtcore/peer/chunkcounter.h
-include/libbtcore/peer/packetreader.h
-include/libbtcore/peer/packetwriter.h
-include/libbtcore/peer/peer.h
-include/libbtcore/peer/peerdownloader.h
-include/libbtcore/peer/peerid.h
-include/libbtcore/peer/peermanager.h
-include/libbtcore/peer/peeruploader.h
-include/libbtcore/peer/serverauthenticate.h
-include/libbtcore/peer/utpex.h
-include/libbtcore/torrent/advancedchokealgorithm.h
-include/libbtcore/torrent/choker.h
-include/libbtcore/torrent/globals.h
-include/libbtcore/torrent/job.h
-include/libbtcore/torrent/jobqueue.h
-include/libbtcore/torrent/peersourcemanager.h
-include/libbtcore/torrent/server.h
-include/libbtcore/torrent/statsfile.h
-include/libbtcore/torrent/timeestimator.h
-include/libbtcore/torrent/torrent.h
-include/libbtcore/torrent/torrentcontrol.h
-include/libbtcore/torrent/torrentcreator.h
-include/libbtcore/torrent/torrentfile.h
-include/libbtcore/torrent/torrentstats.h
-include/libbtcore/torrent/uploader.h
-include/libbtcore/tracker/httptracker.h
-include/libbtcore/tracker/tracker.h
-include/libbtcore/tracker/trackermanager.h
-include/libbtcore/tracker/udptracker.h
-include/libbtcore/tracker/udptrackersocket.h
-include/libbtcore/util/array.h
-include/libbtcore/util/autorotatelogjob.h
-include/libbtcore/util/bitset.h
-include/libbtcore/util/compressfilejob.h
-include/libbtcore/util/constants.h
-include/libbtcore/util/decompressfilejob.h
-include/libbtcore/util/error.h
-include/libbtcore/util/extractfilejob.h
-include/libbtcore/util/file.h
-include/libbtcore/util/fileops.h
-include/libbtcore/util/functions.h
-include/libbtcore/util/log.h
-include/libbtcore/util/logsystemmanager.h
-include/libbtcore/util/ptrmap.h
-include/libbtcore/util/sha1hash.h
-include/libbtcore/util/sha1hashgen.h
-include/libbtcore/util/timer.h
-include/libbtcore/util/urlencoder.h
-include/libbtcore/util/waitjob.h
-include/libbtcore/util/win32.h
lib/kde4/ktbwschedulerplugin.so
lib/kde4/ktdownloadorderplugin.so
lib/kde4/ktinfowidgetplugin.so
lib/kde4/ktipfilterplugin.so
lib/kde4/ktlogviewerplugin.so
+lib/kde4/ktmagnetgeneratorplugin.so
lib/kde4/ktmediaplayerplugin.so
lib/kde4/ktscanfolderplugin.so
lib/kde4/ktscriptingplugin.so
@@ -154,191 +19,21 @@ lib/kde4/ktwebinterfaceplugin.so
lib/kde4/ktzeroconfplugin.so
%%PLASMA%%lib/kde4/plasma_applet_ktorrent.so
lib/kde4/plasma_engine_ktorrent.so
-lib/libbtcore.so
-lib/libbtcore.so.12
-lib/libbtcore.so.12.3.0
lib/libktcore.so
-lib/libktcore.so.10
-lib/libktcore.so.10.2.0
+lib/libktcore.so.11
+lib/libktcore.so.11.0.3
lib/libktupnp.so
lib/libktupnp.so.4
-lib/libktupnp.so.4.1.0
+lib/libktupnp.so.4.0.2
share/applications/kde4/ktorrent.desktop
-share/apps/cmake/modules/FindBTCore.cmake
-share/apps/ktorrent/FLAGS_LICENCE
-share/apps/ktorrent/ad.png
-share/apps/ktorrent/ae.png
-share/apps/ktorrent/af.png
-share/apps/ktorrent/ag.png
-share/apps/ktorrent/ai.png
-share/apps/ktorrent/al.png
-share/apps/ktorrent/am.png
-share/apps/ktorrent/an.png
-share/apps/ktorrent/ao.png
-share/apps/ktorrent/aq.png
-share/apps/ktorrent/ar.png
-share/apps/ktorrent/as.png
-share/apps/ktorrent/at.png
-share/apps/ktorrent/au.png
-share/apps/ktorrent/aw.png
-share/apps/ktorrent/az.png
-share/apps/ktorrent/ba.png
-share/apps/ktorrent/bb.png
-share/apps/ktorrent/bd.png
-share/apps/ktorrent/be.png
-share/apps/ktorrent/bf.png
-share/apps/ktorrent/bg.png
-share/apps/ktorrent/bh.png
-share/apps/ktorrent/bi.png
-share/apps/ktorrent/bj.png
-share/apps/ktorrent/bm.png
-share/apps/ktorrent/bn.png
-share/apps/ktorrent/bo.png
-share/apps/ktorrent/br.png
-share/apps/ktorrent/bs.png
-share/apps/ktorrent/bt.png
-share/apps/ktorrent/bv.png
-share/apps/ktorrent/bw.png
-share/apps/ktorrent/by.png
-share/apps/ktorrent/bz.png
-share/apps/ktorrent/ca.png
-share/apps/ktorrent/cc.png
-share/apps/ktorrent/cd.png
-share/apps/ktorrent/cf.png
-share/apps/ktorrent/cg.png
-share/apps/ktorrent/ch.png
-share/apps/ktorrent/ci.png
-share/apps/ktorrent/ck.png
-share/apps/ktorrent/cl.png
-share/apps/ktorrent/cm.png
-share/apps/ktorrent/cn.png
-share/apps/ktorrent/co.png
-share/apps/ktorrent/cr.png
-share/apps/ktorrent/cs.png
-share/apps/ktorrent/cu.png
-share/apps/ktorrent/cv.png
-share/apps/ktorrent/cx.png
-share/apps/ktorrent/cy.png
-share/apps/ktorrent/cz.png
-share/apps/ktorrent/de.png
-share/apps/ktorrent/dj.png
-share/apps/ktorrent/dk.png
-share/apps/ktorrent/dm.png
-share/apps/ktorrent/do.png
-share/apps/ktorrent/dz.png
-share/apps/ktorrent/ec.png
-share/apps/ktorrent/ee.png
-share/apps/ktorrent/eg.png
-share/apps/ktorrent/eh.png
-share/apps/ktorrent/er.png
-share/apps/ktorrent/es.png
-share/apps/ktorrent/et.png
-share/apps/ktorrent/eu.png
-share/apps/ktorrent/fi.png
-share/apps/ktorrent/fj.png
-share/apps/ktorrent/fk.png
-share/apps/ktorrent/fm.png
-share/apps/ktorrent/fo.png
-share/apps/ktorrent/fr.png
-share/apps/ktorrent/ga.png
-share/apps/ktorrent/gb.png
-share/apps/ktorrent/gd.png
-share/apps/ktorrent/ge.png
-share/apps/ktorrent/gf.png
-share/apps/ktorrent/gh.png
-share/apps/ktorrent/gi.png
-share/apps/ktorrent/gl.png
-share/apps/ktorrent/gm.png
-share/apps/ktorrent/gn.png
-share/apps/ktorrent/gp.png
-share/apps/ktorrent/gq.png
-share/apps/ktorrent/gr.png
-share/apps/ktorrent/gs.png
-share/apps/ktorrent/gt.png
-share/apps/ktorrent/gu.png
-share/apps/ktorrent/gw.png
-share/apps/ktorrent/gy.png
-share/apps/ktorrent/hk.png
-share/apps/ktorrent/hm.png
-share/apps/ktorrent/hn.png
-share/apps/ktorrent/hr.png
-share/apps/ktorrent/ht.png
-share/apps/ktorrent/hu.png
-share/apps/ktorrent/id.png
-share/apps/ktorrent/ie.png
-share/apps/ktorrent/il.png
-share/apps/ktorrent/in.png
-share/apps/ktorrent/io.png
-share/apps/ktorrent/iq.png
-share/apps/ktorrent/ir.png
-share/apps/ktorrent/is.png
-share/apps/ktorrent/it.png
-share/apps/ktorrent/jm.png
-share/apps/ktorrent/jo.png
-share/apps/ktorrent/jp.png
-share/apps/ktorrent/ke.png
-share/apps/ktorrent/kg.png
-share/apps/ktorrent/kh.png
-share/apps/ktorrent/ki.png
-share/apps/ktorrent/km.png
-share/apps/ktorrent/kn.png
-share/apps/ktorrent/kp.png
-share/apps/ktorrent/kr.png
share/apps/ktorrent/ktdownloadorderpluginui.rc
+share/apps/ktorrent/ktmagnetgeneratorpluginui.rc
share/apps/ktorrent/ktmediaplayerpluginui.rc
share/apps/ktorrent/ktorrent.notifyrc
share/apps/ktorrent/ktorrentui.rc
share/apps/ktorrent/ktsearchpluginui.rc
%%PLASMA%%share/apps/ktorrent/ktshutdownpluginui.rc
%%SYNDICATION%%share/apps/ktorrent/ktsyndicationpluginui.rc
-share/apps/ktorrent/kw.png
-share/apps/ktorrent/ky.png
-share/apps/ktorrent/kz.png
-share/apps/ktorrent/la.png
-share/apps/ktorrent/lb.png
-share/apps/ktorrent/lc.png
-share/apps/ktorrent/li.png
-share/apps/ktorrent/lk.png
-share/apps/ktorrent/lr.png
-share/apps/ktorrent/ls.png
-share/apps/ktorrent/lt.png
-share/apps/ktorrent/lu.png
-share/apps/ktorrent/lv.png
-share/apps/ktorrent/ly.png
-share/apps/ktorrent/ma.png
-share/apps/ktorrent/mc.png
-share/apps/ktorrent/md.png
-share/apps/ktorrent/mg.png
-share/apps/ktorrent/mh.png
-share/apps/ktorrent/mk.png
-share/apps/ktorrent/ml.png
-share/apps/ktorrent/mm.png
-share/apps/ktorrent/mn.png
-share/apps/ktorrent/mo.png
-share/apps/ktorrent/mp.png
-share/apps/ktorrent/mq.png
-share/apps/ktorrent/mr.png
-share/apps/ktorrent/ms.png
-share/apps/ktorrent/mt.png
-share/apps/ktorrent/mu.png
-share/apps/ktorrent/mv.png
-share/apps/ktorrent/mw.png
-share/apps/ktorrent/mx.png
-share/apps/ktorrent/my.png
-share/apps/ktorrent/mz.png
-share/apps/ktorrent/na.png
-share/apps/ktorrent/nc.png
-share/apps/ktorrent/ne.png
-share/apps/ktorrent/nf.png
-share/apps/ktorrent/ng.png
-share/apps/ktorrent/ni.png
-share/apps/ktorrent/nl.png
-share/apps/ktorrent/no.png
-share/apps/ktorrent/np.png
-share/apps/ktorrent/nr.png
-share/apps/ktorrent/nu.png
-share/apps/ktorrent/nz.png
-share/apps/ktorrent/om.png
share/apps/ktorrent/opensearch/bitenova/opensearch.xml
share/apps/ktorrent/opensearch/bittorrent/opensearch.xml
share/apps/ktorrent/opensearch/btjunkie/opensearch.xml
@@ -346,28 +41,6 @@ share/apps/ktorrent/opensearch/ktorrents/opensearch.xml
share/apps/ktorrent/opensearch/legittorrents/opensearch.xml
share/apps/ktorrent/opensearch/mininova/opensearch.xml
share/apps/ktorrent/opensearch/thepiratebay/opensearch.xml
-share/apps/ktorrent/pa.png
-share/apps/ktorrent/pe.png
-share/apps/ktorrent/pf.png
-share/apps/ktorrent/pg.png
-share/apps/ktorrent/ph.png
-share/apps/ktorrent/pk.png
-share/apps/ktorrent/pl.png
-share/apps/ktorrent/pm.png
-share/apps/ktorrent/pn.png
-share/apps/ktorrent/pr.png
-share/apps/ktorrent/ps.png
-share/apps/ktorrent/pt.png
-share/apps/ktorrent/pw.png
-share/apps/ktorrent/py.png
-share/apps/ktorrent/qa.png
-share/apps/ktorrent/re.png
-share/apps/ktorrent/ro.png
-share/apps/ktorrent/ru.png
-share/apps/ktorrent/rw.png
-share/apps/ktorrent/sa.png
-share/apps/ktorrent/sb.png
-share/apps/ktorrent/sc.png
share/apps/ktorrent/scripts/auto_remove/auto_remove.desktop
share/apps/ktorrent/scripts/auto_remove/auto_remove.py
share/apps/ktorrent/scripts/auto_remove/auto_remove.ui
@@ -379,8 +52,6 @@ share/apps/ktorrent/scripts/email_notifications/email_notifications.py
share/apps/ktorrent/scripts/email_notifications/emailconfig.ui
share/apps/ktorrent/scripts/tracker_groups/tracker_groups.desktop
share/apps/ktorrent/scripts/tracker_groups/tracker_groups.py
-share/apps/ktorrent/sd.png
-share/apps/ktorrent/se.png
share/apps/ktorrent/search/home/body-background.jpg
share/apps/ktorrent/search/home/box-bottom-left.png
share/apps/ktorrent/search/home/box-bottom-middle.png
@@ -395,54 +66,8 @@ share/apps/ktorrent/search/home/home.css
share/apps/ktorrent/search/home/home.html
share/apps/ktorrent/search/home/ktorrent-icon.png
share/apps/ktorrent/search/home/ktorrent_infopage.css
-share/apps/ktorrent/sg.png
-share/apps/ktorrent/sh.png
-share/apps/ktorrent/si.png
-share/apps/ktorrent/sj.png
-share/apps/ktorrent/sk.png
-share/apps/ktorrent/sl.png
-share/apps/ktorrent/sm.png
-share/apps/ktorrent/sn.png
-share/apps/ktorrent/so.png
-share/apps/ktorrent/sr.png
-share/apps/ktorrent/st.png
-share/apps/ktorrent/sv.png
-share/apps/ktorrent/sy.png
-share/apps/ktorrent/sz.png
-share/apps/ktorrent/tc.png
-share/apps/ktorrent/td.png
-share/apps/ktorrent/tf.png
-share/apps/ktorrent/tg.png
-share/apps/ktorrent/th.png
-share/apps/ktorrent/tj.png
-share/apps/ktorrent/tk.png
-share/apps/ktorrent/tl.png
-share/apps/ktorrent/tm.png
-share/apps/ktorrent/tn.png
-share/apps/ktorrent/to.png
-share/apps/ktorrent/tp.png
-share/apps/ktorrent/tr.png
-share/apps/ktorrent/tt.png
-share/apps/ktorrent/tv.png
-share/apps/ktorrent/tw.png
-share/apps/ktorrent/tz.png
-share/apps/ktorrent/ua.png
-share/apps/ktorrent/ug.png
-share/apps/ktorrent/um.png
-share/apps/ktorrent/us.png
-share/apps/ktorrent/uy.png
-share/apps/ktorrent/uz.png
-share/apps/ktorrent/va.png
-share/apps/ktorrent/vc.png
-share/apps/ktorrent/ve.png
-share/apps/ktorrent/vg.png
-share/apps/ktorrent/vi.png
-share/apps/ktorrent/vn.png
-share/apps/ktorrent/vu.png
-share/apps/ktorrent/wf.png
-share/apps/ktorrent/ws.png
-share/apps/ktorrent/www/coldmilk/coldmilk.html
share/apps/ktorrent/www/coldmilk/coldmilk.js
+share/apps/ktorrent/www/coldmilk/interface.html
share/apps/ktorrent/www/coldmilk/login.html
share/apps/ktorrent/www/coldmilk/page_update.js
share/apps/ktorrent/www/coldmilk/style.css
@@ -478,12 +103,6 @@ share/apps/ktorrent/www/mobile/interface.html
share/apps/ktorrent/www/mobile/login.html
share/apps/ktorrent/www/mobile/mobile.css
share/apps/ktorrent/www/mobile/mobile.js
-share/apps/ktorrent/ye.png
-share/apps/ktorrent/yt.png
-share/apps/ktorrent/yu.png
-share/apps/ktorrent/za.png
-share/apps/ktorrent/zm.png
-share/apps/ktorrent/zw.png
share/icons/hicolor/128x128/apps/ktorrent.png
%%SYNDICATION%%share/icons/hicolor/16x16/actions/kt-add-feeds.png
%%SYNDICATION%%share/icons/hicolor/16x16/actions/kt-add-filters.png
@@ -491,6 +110,7 @@ share/icons/hicolor/16x16/actions/kt-change-tracker.png
share/icons/hicolor/16x16/actions/kt-check-data.png
share/icons/hicolor/16x16/actions/kt-chunks.png
share/icons/hicolor/16x16/actions/kt-info-widget.png
+share/icons/hicolor/16x16/actions/kt-magnet.png
share/icons/hicolor/16x16/actions/kt-pause.png
share/icons/hicolor/16x16/actions/kt-queue-manager.png
%%SYNDICATION%%share/icons/hicolor/16x16/actions/kt-remove-feeds.png
@@ -511,6 +131,7 @@ share/icons/hicolor/16x16/apps/ktorrent.png
%%SYNDICATION%%share/icons/hicolor/22x22/actions/kt-add-feeds.png
%%SYNDICATION%%share/icons/hicolor/22x22/actions/kt-add-filters.png
share/icons/hicolor/22x22/actions/kt-encrypted.png
+share/icons/hicolor/22x22/actions/kt-magnet.png
share/icons/hicolor/22x22/actions/kt-pause.png
%%SYNDICATION%%share/icons/hicolor/22x22/actions/kt-remove-feeds.png
%%SYNDICATION%%share/icons/hicolor/22x22/actions/kt-remove-filters.png
@@ -526,6 +147,7 @@ share/icons/hicolor/22x22/apps/ktorrent.png
%%SYNDICATION%%share/icons/hicolor/32x32/actions/kt-add-feeds.png
%%SYNDICATION%%share/icons/hicolor/32x32/actions/kt-add-filters.png
share/icons/hicolor/32x32/actions/kt-info-widget.png
+share/icons/hicolor/32x32/actions/kt-magnet.png
share/icons/hicolor/32x32/actions/kt-pause.png
share/icons/hicolor/32x32/actions/kt-queue-manager.png
%%SYNDICATION%%share/icons/hicolor/32x32/actions/kt-remove-feeds.png
@@ -545,6 +167,7 @@ share/icons/hicolor/48x48/actions/kt-change-tracker.png
share/icons/hicolor/48x48/actions/kt-check-data.png
share/icons/hicolor/48x48/actions/kt-chunks.png
share/icons/hicolor/48x48/actions/kt-info-widget.png
+share/icons/hicolor/48x48/actions/kt-magnet.png
share/icons/hicolor/48x48/actions/kt-pause.png
share/icons/hicolor/48x48/actions/kt-plugins.png
share/icons/hicolor/48x48/actions/kt-queue-manager.png
@@ -561,9 +184,11 @@ share/icons/hicolor/48x48/actions/kt-stop-all.png
share/icons/hicolor/48x48/actions/kt-stop.png
share/icons/hicolor/48x48/actions/kt-upnp.png
share/icons/hicolor/48x48/apps/ktorrent.png
+share/icons/hicolor/64x64/actions/kt-magnet.png
share/icons/hicolor/64x64/apps/ktorrent.png
%%SYNDICATION%%share/icons/hicolor/scalable/actions/kt-add-feeds.svgz
%%SYNDICATION%%share/icons/hicolor/scalable/actions/kt-add-filters.svgz
+share/icons/hicolor/scalable/actions/kt-magnet.svgz
%%SYNDICATION%%share/icons/hicolor/scalable/actions/kt-remove-feeds.svgz
%%SYNDICATION%%share/icons/hicolor/scalable/actions/kt-remove-filters.svgz
share/icons/hicolor/scalable/actions/kt-set-max-download-speed.svgz
@@ -574,6 +199,7 @@ share/kde4/services/ktdownloadorderplugin.desktop
share/kde4/services/ktinfowidgetplugin.desktop
share/kde4/services/ktipfilterplugin.desktop
share/kde4/services/ktlogviewerplugin.desktop
+share/kde4/services/ktmagnetgeneratorplugin.desktop
share/kde4/services/ktmediaplayerplugin.desktop
share/kde4/services/ktscanfolderplugin.desktop
share/kde4/services/ktscriptingplugin.desktop
@@ -584,10 +210,12 @@ share/kde4/services/ktstatsplugin.desktop
share/kde4/services/ktupnpplugin.desktop
share/kde4/services/ktwebinterfaceplugin.desktop
share/kde4/services/ktzeroconfplugin.desktop
+share/kde4/services/magnet.protocol
%%PLASMA%%share/kde4/services/plasma-applet-ktorrent.desktop
share/kde4/services/plasma-dataengine-ktorrent.desktop
share/kde4/servicetypes/ktorrentplugin.desktop
share/locale/ar/LC_MESSAGES/ktorrent.mo
+share/locale/ast/LC_MESSAGES/ktorrent.mo
share/locale/be/LC_MESSAGES/ktorrent.mo
share/locale/bg/LC_MESSAGES/ktorrent.mo
share/locale/ca/LC_MESSAGES/ktorrent.mo
@@ -597,9 +225,11 @@ share/locale/da/LC_MESSAGES/ktorrent.mo
share/locale/de/LC_MESSAGES/ktorrent.mo
share/locale/el/LC_MESSAGES/ktorrent.mo
share/locale/en_GB/LC_MESSAGES/ktorrent.mo
+share/locale/eo/LC_MESSAGES/ktorrent.mo
share/locale/es/LC_MESSAGES/ktorrent.mo
share/locale/et/LC_MESSAGES/ktorrent.mo
share/locale/eu/LC_MESSAGES/ktorrent.mo
+share/locale/fi/LC_MESSAGES/ktorrent.mo
share/locale/fr/LC_MESSAGES/ktorrent.mo
share/locale/ga/LC_MESSAGES/ktorrent.mo
share/locale/gl/LC_MESSAGES/ktorrent.mo
@@ -626,14 +256,20 @@ share/locale/pt_BR/LC_MESSAGES/ktorrent.mo
share/locale/ro/LC_MESSAGES/ktorrent.mo
share/locale/ru/LC_MESSAGES/ktorrent.mo
share/locale/se/LC_MESSAGES/ktorrent.mo
+share/locale/si/LC_MESSAGES/ktorrent.mo
share/locale/sk/LC_MESSAGES/ktorrent.mo
share/locale/sl/LC_MESSAGES/ktorrent.mo
share/locale/sr/LC_MESSAGES/ktorrent.mo
+share/locale/sr@ijekavian/LC_MESSAGES/ktorrent.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/ktorrent.mo
+share/locale/sr@latin/LC_MESSAGES/ktorrent.mo
share/locale/sv/LC_MESSAGES/ktorrent.mo
share/locale/tr/LC_MESSAGES/ktorrent.mo
share/locale/uk/LC_MESSAGES/ktorrent.mo
share/locale/zh_CN/LC_MESSAGES/ktorrent.mo
share/locale/zh_TW/LC_MESSAGES/ktorrent.mo
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
@dirrm share/apps/ktorrent/www/mobile
@dirrm share/apps/ktorrent/www/default
@dirrm share/apps/ktorrent/www/common
@@ -655,17 +291,3 @@ share/locale/zh_TW/LC_MESSAGES/ktorrent.mo
@dirrm share/apps/ktorrent/opensearch/bitenova
@dirrm share/apps/ktorrent/opensearch
@dirrm share/apps/ktorrent
-@dirrm include/libbtcore/util
-@dirrm include/libbtcore/tracker
-@dirrm include/libbtcore/torrent
-@dirrm include/libbtcore/peer
-@dirrm include/libbtcore/net
-@dirrm include/libbtcore/mse
-@dirrm include/libbtcore/migrate
-@dirrm include/libbtcore/interfaces
-@dirrm include/libbtcore/download
-@dirrm include/libbtcore/diskio
-@dirrm include/libbtcore/dht
-@dirrm include/libbtcore/datachecker
-@dirrm include/libbtcore/bcodec
-@dirrm include/libbtcore