aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/ktorrent
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 20:29:18 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 20:43:17 +0000
commitc47397b58e8a612f3bbe987b97fb40665b70df53 (patch)
tree8cda1ca64675c0091e895e987c6fa8e4943acb16 /net-p2p/ktorrent
parentbf089b31aaf7c53237fc8ee1a8c988fb10be5767 (diff)
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 9b8c8ffd6758..3065b1bca206 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -1,33 +1,33 @@
PORTNAME= ktorrent
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-p2p kde kde-applications
-# Since libktorrent is released with ktorrent, it lives in a
-# strange download directory; keep this in-sync with net-p2p/libktorrent.
-
MAINTAINER= kde@FreeBSD.org
COMMENT= BitTorrent client for KDE
CONFLICTS_BUILD= libtorrent
-USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
-
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:devel/boost-libs
LIB_DEPENDS= libKF5Torrent.so:net-p2p/libktorrent \
libgcrypt.so:security/libgcrypt \
libgmp.so:math/gmp \
libtag.so:audio/taglib
+
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons dnssd i18n iconthemes itemviews \
jobwidgets kcmutils kio kross notifications \
notifyconfig parts plotting service \
solid sonnet syndication textwidgets widgetsaddons \
- windowsystem xmlgui
+ windowsystem xmlgui \
+ ecm_build
USE_QT= concurrent core dbus gui network phonon4 script widgets xml \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS WORKSPACE
+OPTIONS_DEFINE= DOCS WORKSPACE
OPTIONS_DEFAULT= WORKSPACE
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
WORKSPACE_USE= KDE=plasma-workspace
WORKSPACE_DESC= Shutdown on completion support