aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libbt/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-04-17 14:14:00 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-04-17 14:14:00 +0000
commit8aa0836e38d56ef994bc4f919f52e9e5adbd6b4e (patch)
tree4b04b0275bf749b51573e26d1c77124b4cea7889 /net-p2p/libbt/Makefile
parentcc07cbe5e382c1dc658b82861b186482c24e7ac9 (diff)
downloadports-8aa0836e38d56ef994bc4f919f52e9e5adbd6b4e.tar.gz
ports-8aa0836e38d56ef994bc4f919f52e9e5adbd6b4e.zip
Notes
Diffstat (limited to 'net-p2p/libbt/Makefile')
-rw-r--r--net-p2p/libbt/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/net-p2p/libbt/Makefile b/net-p2p/libbt/Makefile
index 307b717ccccc..bd2b5850ab02 100644
--- a/net-p2p/libbt/Makefile
+++ b/net-p2p/libbt/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= libbt
-PORTVERSION= 0.03
+PORTVERSION= 1.01
CATEGORIES= net devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= flz@xbsd.org
COMMENT= C library implementing the core BitTorrent protocol
@@ -18,8 +17,6 @@ COMMENT= C library implementing the core BitTorrent protocol
LIB_DEPENDS= uuid.1:${PORTSDIR}/sysutils/e2fsprogs \
curl.2:${PORTSDIR}/ftp/curl
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -28,13 +25,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha"
-BROKEN= "Does not compile on alpha"
-.endif
+ONLY_FOR_ARCHS= i386
post-patch:
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@|' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@ |' ${WRKSRC}/src/Makefile.in
do-install:
${INSTALL_DATA} ${WRKSRC}/src/libbt.a ${PREFIX}/lib
@@ -42,7 +37,7 @@ do-install:
.for i in btcheck btget btlist
${INSTALL_PROGRAM} ${WRKSRC}/src/${i} ${PREFIX}/bin
.endfor
-.for i in benc.h bitset.h bterror.h bts.h context.h peer.h random.h segmenter.h strbuf.h stream.h types.h util.h
+.for i in benc.h bitset.h bterror.h btmessage.h bts.h context.h peer.h random.h segmenter.h strbuf.h stream.h types.h util.h
${INSTALL_DATA} ${WRKSRC}/include/${i} ${PREFIX}/include/libbt
.endfor