aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libbt
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-04-19 16:57:19 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-04-19 16:57:19 +0000
commit12c05f36a2218bd8340c412dbe3d03a7ea091cb8 (patch)
treec682302a067fd7cf3827acfbe6b76b5d342b2224 /net-p2p/libbt
parentd709fa8022fb665722aaf09076cc2bb2bc22b0d6 (diff)
downloadports-12c05f36a2218bd8340c412dbe3d03a7ea091cb8.tar.gz
ports-12c05f36a2218bd8340c412dbe3d03a7ea091cb8.zip
Notes
Diffstat (limited to 'net-p2p/libbt')
-rw-r--r--net-p2p/libbt/Makefile6
-rw-r--r--net-p2p/libbt/files/patch-src::peer.c6
2 files changed, 9 insertions, 3 deletions
diff --git a/net-p2p/libbt/Makefile b/net-p2p/libbt/Makefile
index bd2b5850ab02..cce0bb926054 100644
--- a/net-p2p/libbt/Makefile
+++ b/net-p2p/libbt/Makefile
@@ -20,12 +20,14 @@ LIB_DEPENDS= uuid.1:${PORTSDIR}/sysutils/e2fsprogs \
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-
+USE_GCC= 3.3
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-ONLY_FOR_ARCHS= i386
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
diff --git a/net-p2p/libbt/files/patch-src::peer.c b/net-p2p/libbt/files/patch-src::peer.c
index 15ad4cc51605..6c2104deda6c 100644
--- a/net-p2p/libbt/files/patch-src::peer.c
+++ b/net-p2p/libbt/files/patch-src::peer.c
@@ -1,10 +1,14 @@
--- src/peer.c Wed Apr 7 06:14:44 2004
+++ src/peer.c.new Tue Apr 13 19:29:01 2004
-@@ -20,6 +20,7 @@
+@@ -20,6 +20,11 @@
# endif
#endif
#include <sys/types.h>
++#if __FreeBSD__ >= 5
+#include <sys/limits.h>
++#else
++#include <machine/limits.h>
++#endif
#include <string.h>
#ifdef HAVE_STRINGS_H
# include <strings.h>