aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libktorrent
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-03-07 15:25:42 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-03-07 15:25:42 +0000
commitf7c01a282298fca10134662b428d943a6361da28 (patch)
tree618bcd4a92a4dbcced2a60d7cf8709405377bf7a /net-p2p/libktorrent
parentc5fe5d73535a4c7929b2956ded7ef6a22918cfc0 (diff)
downloadports-f7c01a282298fca10134662b428d943a6361da28.tar.gz
ports-f7c01a282298fca10134662b428d943a6361da28.zip
Notes
Diffstat (limited to 'net-p2p/libktorrent')
-rw-r--r--net-p2p/libktorrent/Makefile5
-rw-r--r--net-p2p/libktorrent/distinfo4
-rw-r--r--net-p2p/libktorrent/files/patch-src__net__address.cpp10
-rw-r--r--net-p2p/libktorrent/files/patch-src__net__socket.cpp18
-rw-r--r--net-p2p/libktorrent/pkg-plist11
5 files changed, 22 insertions, 26 deletions
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index 3eba2d39b5ed..f8917c99c73e 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libktorrent
-DISTVERSION= 1.1.3
-PORTREVISION= 1
+DISTVERSION= 1.2.0
CATEGORIES= net-p2p kde
MASTER_SITES= http://ktorrent.org/downloads/${DISTVERSION:S,^1,4,}/
@@ -27,7 +26,7 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-SHLIB_VER= 3.0.3
+SHLIB_VER= 4.0.0
PLIST_SUB+= SHLIB_VER=${SHLIB_VER} \
SHLIB_SHVER=${SHLIB_VER:R:R}
diff --git a/net-p2p/libktorrent/distinfo b/net-p2p/libktorrent/distinfo
index 1d86e7c8f02a..5f64a4cec31f 100644
--- a/net-p2p/libktorrent/distinfo
+++ b/net-p2p/libktorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libktorrent-1.1.3.tar.bz2) = b6a0c9f2e2a9ce0bb16cb3b82cac894ab43bdaaa95736a26f41778d7aae97b57
-SIZE (libktorrent-1.1.3.tar.bz2) = 922651
+SHA256 (libktorrent-1.2.0.tar.bz2) = 24801cd43dfb78a5b8f4c468283dc774ad4025f1bf71909d79344414a8ff8298
+SIZE (libktorrent-1.2.0.tar.bz2) = 919037
diff --git a/net-p2p/libktorrent/files/patch-src__net__address.cpp b/net-p2p/libktorrent/files/patch-src__net__address.cpp
new file mode 100644
index 000000000000..e379162cbed6
--- /dev/null
+++ b/net-p2p/libktorrent/files/patch-src__net__address.cpp
@@ -0,0 +1,10 @@
+--- ./src/net/address.cpp.orig 2012-02-28 17:35:19.000000000 +0000
++++ ./src/net/address.cpp 2012-03-06 13:36:25.728553394 +0000
+@@ -21,6 +21,7 @@
+ #include "address.h"
+ #include <arpa/inet.h>
+ #include <util/log.h>
++#include <sys/socket.h>
+
+ using namespace bt;
+
diff --git a/net-p2p/libktorrent/files/patch-src__net__socket.cpp b/net-p2p/libktorrent/files/patch-src__net__socket.cpp
deleted file mode 100644
index 8b459b5412f5..000000000000
--- a/net-p2p/libktorrent/files/patch-src__net__socket.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./src/net/socket.cpp.orig 2010-06-14 20:29:14.000000000 +0400
-+++ ./src/net/socket.cpp 2010-06-16 01:32:57.006817314 +0400
-@@ -54,6 +54,15 @@
- #define errno WSAGetLastError()
- #endif
- #include <kdebug.h>
-+
-+#ifndef SOL_IP
-+#define SOL_IP IPPROTO_IP
-+#endif
-+
-+#ifndef SOL_IPV6
-+#define SOL_IPV6 IPPROTO_IPV6
-+#endif
-+
- using namespace bt;
-
- namespace net
diff --git a/net-p2p/libktorrent/pkg-plist b/net-p2p/libktorrent/pkg-plist
index 779dddecb342..9f49b36948bf 100644
--- a/net-p2p/libktorrent/pkg-plist
+++ b/net-p2p/libktorrent/pkg-plist
@@ -68,14 +68,15 @@ include/libktorrent/migrate/ccmigrate.h
include/libktorrent/migrate/migrate.h
include/libktorrent/mse/bigint.h
include/libktorrent/mse/encryptedauthenticate.h
+include/libktorrent/mse/encryptedpacketsocket.h
include/libktorrent/mse/encryptedserverauthenticate.h
include/libktorrent/mse/functions.h
include/libktorrent/mse/rc4encryptor.h
-include/libktorrent/mse/streamsocket.h
include/libktorrent/net/address.h
-include/libktorrent/net/bufferedsocket.h
+include/libktorrent/net/addressresolver.h
include/libktorrent/net/downloadthread.h
include/libktorrent/net/networkthread.h
+include/libktorrent/net/packetsocket.h
include/libktorrent/net/poll.h
include/libktorrent/net/portlist.h
include/libktorrent/net/reverseresolver.h
@@ -86,6 +87,8 @@ include/libktorrent/net/socketgroup.h
include/libktorrent/net/socketmonitor.h
include/libktorrent/net/socks.h
include/libktorrent/net/speed.h
+include/libktorrent/net/streamsocket.h
+include/libktorrent/net/trafficshapedsocket.h
include/libktorrent/net/uploadthread.h
include/libktorrent/net/wakeuppipe.h
include/libktorrent/peer/accessmanager.h
@@ -94,7 +97,6 @@ include/libktorrent/peer/authenticatebase.h
include/libktorrent/peer/authenticationmonitor.h
include/libktorrent/peer/chunkcounter.h
include/libktorrent/peer/packetreader.h
-include/libktorrent/peer/packetwriter.h
include/libktorrent/peer/peer.h
include/libktorrent/peer/peerconnector.h
include/libktorrent/peer/peerdownloader.h
@@ -134,6 +136,7 @@ include/libktorrent/upnp/upnprouter.h
include/libktorrent/util/array.h
include/libktorrent/util/autorotatelogjob.h
include/libktorrent/util/bitset.h
+include/libktorrent/util/bufferpool.h
include/libktorrent/util/circularbuffer.h
include/libktorrent/util/compressfilejob.h
include/libktorrent/util/constants.h
@@ -158,6 +161,7 @@ include/libktorrent/util/win32.h
include/libktorrent/utp/connection.h
include/libktorrent/utp/delaywindow.h
include/libktorrent/utp/localwindow.h
+include/libktorrent/utp/packetbuffer.h
include/libktorrent/utp/pollpipe.h
include/libktorrent/utp/remotewindow.h
include/libktorrent/utp/timevalue.h
@@ -174,6 +178,7 @@ share/locale/ar/LC_MESSAGES/libktorrent.mo
share/locale/ast/LC_MESSAGES/libktorrent.mo
share/locale/be/LC_MESSAGES/libktorrent.mo
share/locale/bg/LC_MESSAGES/libktorrent.mo
+share/locale/bs/LC_MESSAGES/libktorrent.mo
share/locale/ca/LC_MESSAGES/libktorrent.mo
share/locale/ca@valencia/LC_MESSAGES/libktorrent.mo
share/locale/cs/LC_MESSAGES/libktorrent.mo