aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent-rasterbar-16-python
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-05-17 08:44:12 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-05-17 08:44:12 +0000
commita0d4b7ae989f4c845be533e9fe3698dce0f2cabc (patch)
tree346c3e833f9df40b1ae88e80074f24037ff874c2 /net-p2p/libtorrent-rasterbar-16-python
parent014f054c4fd41476b7aac64c538720634012a8e7 (diff)
downloadports-a0d4b7ae989f4c845be533e9fe3698dce0f2cabc.tar.gz
ports-a0d4b7ae989f4c845be533e9fe3698dce0f2cabc.zip
Notes
Diffstat (limited to 'net-p2p/libtorrent-rasterbar-16-python')
-rw-r--r--net-p2p/libtorrent-rasterbar-16-python/Makefile46
-rw-r--r--net-p2p/libtorrent-rasterbar-16-python/pkg-plist1
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/libtorrent-rasterbar-16-python/Makefile b/net-p2p/libtorrent-rasterbar-16-python/Makefile
new file mode 100644
index 000000000000..753a83f38b40
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-16-python/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: libtorrent-rasterbar-16-python
+# Date created: 5 May 2012
+# Whom: Doug Barton, dougb@FreeBSD.org
+#
+#
+# $FreeBSD$
+
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+COMMENT= Python bindings for libtorrent-rasterbar-16
+CATEGORIES= net-p2p python
+
+USE_PYTHON= 2.5+
+
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>=0.6:${PORTSDIR}/devel/py-setuptools
+LIB_DEPENDS+= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
+ torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-16
+
+BUILD_WRKSRC= ${WRKSRC}/bindings/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+PLIST= ${.CURDIR}/pkg-plist
+
+INSTALLS_EGGINFO= yes
+PYDISTUTILS_EGGINFO= python_libtorrent-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
+NOPORTDOCS= yes
+
+slave-post-patch:
+ @${REINPLACE_CMD} -E -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/bindings/python/setup.py.in
+
+slave-post-install:
+# fix installation permissions
+ @${CHMOD} ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/libtorrent.so
+
+MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar-16
+.include "${MASTERDIR}/Makefile"
+
+##
+# information available after <bsd.port.pre.mk>
+##
+# insure python paths are correctly identified
+CONFIGURE_ENV+= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
+ PYTHON_VERSION="${PYTHON_VERSION}"
+# prefix PKGNAME with python- so that the egg info file is properly named.
+PYDISTUTILS_PKGNAME= python-${PORTNAME}
diff --git a/net-p2p/libtorrent-rasterbar-16-python/pkg-plist b/net-p2p/libtorrent-rasterbar-16-python/pkg-plist
new file mode 100644
index 000000000000..128a4b8d4812
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-16-python/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/libtorrent.so