aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent-rasterbar-python
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-06 11:42:15 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-06 11:42:15 +0000
commita878f09f22e527a46349381ec9faf2df150cf128 (patch)
tree318862b34a496182a16a2d4b3e4a0fd1bf7449aa /net-p2p/libtorrent-rasterbar-python
parentc060db7dbd27f32db23fa6ed6bdb7a5def1f6735 (diff)
Notes
Diffstat (limited to 'net-p2p/libtorrent-rasterbar-python')
-rw-r--r--net-p2p/libtorrent-rasterbar-python/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-p2p/libtorrent-rasterbar-python/Makefile b/net-p2p/libtorrent-rasterbar-python/Makefile
new file mode 100644
index 000000000000..e8d51c2d0c9b
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-python/Makefile
@@ -0,0 +1,31 @@
+# Created by: Doug Barton <dougb@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= net-p2p python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+COMMENT= Python bindings for libtorrent-rasterbar
+
+LIB_DEPENDS= libtorrent-rasterbar.so:${PORTSDIR}/net-p2p/libtorrent-rasterbar \
+ libboost_python.so:${PORTSDIR}/devel/boost-python-libs
+
+MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar
+
+BUILD_WRKSRC= ${WRKSRC}/bindings/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+SLAVE_PORT= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python_libtorrent
+
+PLIST= ${NONEXISTENT}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/libtorrent.so
+
+OPTIONS_EXCLUDE= DOCS EXAMPLES
+
+# insure python paths are correctly identified
+CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
+ PYTHON_VERSION="${PYTHON_VERSION}"
+
+.include "${MASTERDIR}/Makefile"