aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent-rasterbar
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-02-16 11:49:32 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-02-16 11:49:32 +0000
commit7d4bd5dedb129bf6ecb4e338d39a7297eb07922b (patch)
tree8611826f7fea9edaffd2d38569cdc8ebdef1887b /net-p2p/libtorrent-rasterbar
parentc9699bcce39a6d78b2f57f22a1f16325e88266d3 (diff)
Notes
Diffstat (limited to 'net-p2p/libtorrent-rasterbar')
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar/distinfo4
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-src__disk_io_thread.cpp11
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-src__storage.cpp11
4 files changed, 3 insertions, 25 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 91d89a223223..12938032e359 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libtorrent-rasterbar
-PORTVERSION= 0.16.14
+PORTVERSION= 0.16.15
CATEGORIES?= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME:S/-rasterbar//}/${PORTNAME:S/-rasterbar//}/
diff --git a/net-p2p/libtorrent-rasterbar/distinfo b/net-p2p/libtorrent-rasterbar/distinfo
index 710ed7b6050e..798e84b94495 100644
--- a/net-p2p/libtorrent-rasterbar/distinfo
+++ b/net-p2p/libtorrent-rasterbar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libtorrent-rasterbar-0.16.14.tar.gz) = 4c54207850c32c0a65c7b5bb089731e50285024e0992fe6e29f831249c198e68
-SIZE (libtorrent-rasterbar-0.16.14.tar.gz) = 3012772
+SHA256 (libtorrent-rasterbar-0.16.15.tar.gz) = 820fdfeca3f45a58ec2fc5de138887e890637b3d62fe5717eb8dcd072f249f75
+SIZE (libtorrent-rasterbar-0.16.15.tar.gz) = 3014808
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-src__disk_io_thread.cpp b/net-p2p/libtorrent-rasterbar/files/patch-src__disk_io_thread.cpp
deleted file mode 100644
index adb2601a3ade..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/patch-src__disk_io_thread.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/disk_io_thread.cpp.orig 2013-09-26 03:30:20.000000000 +0200
-+++ ./src/disk_io_thread.cpp 2014-02-13 21:36:20.000000000 +0100
-@@ -1765,7 +1765,7 @@
- #endif
- TORRENT_ASSERT(j.buffer);
- session_settings const* s = ((session_settings*)j.buffer);
-- TORRENT_ASSERT(s->cache_size >= 0);
-+ TORRENT_ASSERT(s->cache_size >= -1);
- TORRENT_ASSERT(s->cache_expiry > 0);
-
- #if defined TORRENT_WINDOWS
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-src__storage.cpp b/net-p2p/libtorrent-rasterbar/files/patch-src__storage.cpp
deleted file mode 100644
index 9082aa36c542..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/patch-src__storage.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/storage.cpp.orig 2014-01-24 11:05:39.000000000 +0100
-+++ ./src/storage.cpp 2014-02-13 21:33:49.000000000 +0100
-@@ -1223,7 +1223,7 @@
- // if the file has priority 0, don't allocate it
- int file_index = files().file_index(*file_iter);
- if (m_allocate_files && (op.mode & file::rw_mask) != file::read_only
-- && (m_file_priority.size() < file_index || m_file_priority[file_index] > 0))
-+ && (m_file_priority.size() <= file_index || m_file_priority[file_index] > 0))
- {
- TORRENT_ASSERT(m_file_created.size() == files().num_files());
- if (m_file_created[file_index] == false)