aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-12 10:19:49 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-12 10:19:49 +0000
commitcbe5c931ce08bcd7c9ddcc55bf032d6342433506 (patch)
treed26d35826a0bbbd00f133535be031c8e91471039 /net-p2p/libtorrent/Makefile
parent77bad5e28211d5931802dcb098f706e3cf4ec588 (diff)
downloadports-cbe5c931ce08bcd7c9ddcc55bf032d6342433506.tar.gz
ports-cbe5c931ce08bcd7c9ddcc55bf032d6342433506.zip
Notes
Diffstat (limited to 'net-p2p/libtorrent/Makefile')
-rw-r--r--net-p2p/libtorrent/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
new file mode 100644
index 000000000000..71c238f82794
--- /dev/null
+++ b/net-p2p/libtorrent/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: libtorrent
+# Date created: Jan 07 2005
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtorrent
+PORTVERSION= 0.4.5
+CATEGORIES= net
+MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
+
+MAINTAINER= flz@xbsd.org
+COMMENT= BitTorrent Library written in C++
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
+ sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
+
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4
+.endif
+
+pre-everything::
+.if !defined(WITH_CLIENT) && ${OSVERSION} >= 500000
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_CLIENT to build libtorrent client'
+ @${ECHO_MSG} '===>'
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s#\(pkgconfigdir =\).*#\1 ${PREFIX}/libexec/pkgconfig#" \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s#-Wall -O3 -g#${CFLAGS} -fpermissive#" \
+ ${WRKSRC}/client/Makefile2
+# uphold CXXFLAGS
+ @${REINPLACE_CMD} -E \
+ -e 's#^(CXXFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CXXFLAGS}#' \
+ -e 's#^(CFLAGS[[:space:]]*=[[:space:]]*).*-O.*$$#\1${CFLAGS}#' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.if defined(WITH_CLIENT)
+.if ${OSVERSION} < 500000
+BROKEN= "Client doesn't compile on 4.x"
+.endif
+
+PLIST_FILES= bin/rtorrent
+
+post-build:
+ @(cd ${WRKSRC}/client; make -f Makefile2)
+
+post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/client/rtorrent ${PREFIX}/bin
+.endif
+
+.include <bsd.port.post.mk>