aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/linuxdcpp/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-10-24 17:31:54 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-10-24 17:31:54 +0000
commit9608e3ad93758af28850ce24e4104bc386146fb6 (patch)
treeb60d4d8a381ecf46b9f52468becf9c927567e8f7 /net-p2p/linuxdcpp/Makefile
parent173beecc167ddc522fce68bbdc96f786e49551e6 (diff)
downloadports-9608e3ad93758af28850ce24e4104bc386146fb6.tar.gz
ports-9608e3ad93758af28850ce24e4104bc386146fb6.zip
Notes
Diffstat (limited to 'net-p2p/linuxdcpp/Makefile')
-rw-r--r--net-p2p/linuxdcpp/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index a68a0216c2ea..95861188c583 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -2,12 +2,12 @@
PORTNAME= linuxdcpp
PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p
MASTER_SITES= http://launchpadlibrarian.net/69733951/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A port of the DC++ Direct Connect client to Unix-like systems
+COMMENT= Port of the DC++ Direct Connect client to Unix-like systems
LICENSE= GPLv2
@@ -15,16 +15,28 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-li
USE_BZIP2= yes
USE_GNOME= libglade2
-USES= iconv pkgconfig
-USE_SCONS= yes
+USES= iconv pkgconfig scons
USE_OPENSSL= yes
PORTDOCS= *
+DESTDIRNAME= FAKE_ROOT
-SCONS_BUILDENV= ${SCONS_ENV}
+OPTIONS_DEFINE= NOTIFY
+OPTIONS_DEFAULT=NOTIFY
.if defined(WITH_DEBUG)
-SCONS_ARGS= debug=1
+MAKE_ARGS+= debug=1
.endif
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNOTIFY}
+LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
+.else
+MAKE_ARGS+= libnotify=0
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/'iconv'/'${ICONV_LIB:S/-l//}'/" \
+ ${WRKSRC}/SConstruct
+
.include <bsd.port.mk>