aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/linuxdcpp/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-07-29 17:46:11 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-07-29 17:46:11 +0000
commitded61394acb679bec96e378366f943f87b14997b (patch)
tree0034cc83f87d4d01533e0cbc46ea536b1ba984f5 /net-p2p/linuxdcpp/Makefile
parent865f26699fea4e057ce1c8fa6be9855fc015f51a (diff)
Notes
Diffstat (limited to 'net-p2p/linuxdcpp/Makefile')
-rw-r--r--net-p2p/linuxdcpp/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
new file mode 100644
index 000000000000..1cdf4340a100
--- /dev/null
+++ b/net-p2p/linuxdcpp/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: linuxdcpp
+# Date created: 19 June 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linuxdcpp
+PORTVERSION= 0.0.1.20060726 #0.0.1.YYYYMMDD
+CATEGORIES= net-p2p
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR=mezz
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A port of the win32 DC++ direct connect client to POSIX-like systems
+
+USE_GCC= 3.4
+USE_XLIB= yes
+USE_BZIP2= yes
+USE_GNOME= libglade2
+USE_SCONS= yes
+SCONS_ARGS= release=1
+
+DATADIR= ${PREFIX}/share/ldcpp
+DOCSDIR= ${PREFIX}/share/doc/ldcpp
+
+post-extract:
+ @${RM} ${WRKSRC}/linux/prefix.*
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ; s|%%CXX%%|${CXX}|g ; \
+ s|%%CXXFLAGS%%|${CXXFLAGS}|g' ${WRKSRC}/SConstruct
+
+.include <bsd.port.mk>