aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/linuxdcpp/Makefile
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2014-06-18 12:23:54 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2014-06-18 12:23:54 +0000
commit8598b0c728bd048bbbb670edd55c5167ca16f2d4 (patch)
treeb13ab789338df5f64b85c19f40f576b66cd9cff9 /net-p2p/linuxdcpp/Makefile
parentf7fcc01d590e364f76e468acb92739a2b82415a3 (diff)
downloadports-8598b0c728bd048bbbb670edd55c5167ca16f2d4.tar.gz
ports-8598b0c728bd048bbbb670edd55c5167ca16f2d4.zip
Notes
Diffstat (limited to 'net-p2p/linuxdcpp/Makefile')
-rw-r--r--net-p2p/linuxdcpp/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index b36a6b228bab..38db74ea9a1f 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -13,9 +13,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-libs
-USE_BZIP2= yes
USE_GNOME= libglade2
-USES= iconv pkgconfig scons
+USES= iconv pkgconfig scons tar:bzip2
USE_OPENSSL= yes
PORTDOCS= *
DESTDIRNAME= FAKE_ROOT
@@ -27,16 +26,18 @@ OPTIONS_DEFAULT=NOTIFY
MAKE_ARGS+= debug=1
.endif
-.include <bsd.port.options.mk>
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
-.else
-MAKE_ARGS+= libnotify=0
-.endif
+NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+NOTIFY_MAKE_ARGS_OFF= libnotify=0
post-patch:
@${REINPLACE_CMD} -e "s/'iconv'/'${ICONV_LIB:S/-l//}'/" \
${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|' ${WRKSRC}/SConstruct
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>