aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/linuxdcpp
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-04-02 16:57:48 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-04-02 16:57:48 +0000
commit551fded38f17dae9a22c4621b1eee090e543099b (patch)
treedf00dbb24d7d42f2eaa7fc70c4e51ed69f31aabe /net-p2p/linuxdcpp
parentcf6b4e340f6179342f4ce1bd64e01ec0f6513069 (diff)
downloadports-551fded38f17dae9a22c4621b1eee090e543099b.tar.gz
ports-551fded38f17dae9a22c4621b1eee090e543099b.zip
Notes
Diffstat (limited to 'net-p2p/linuxdcpp')
-rw-r--r--net-p2p/linuxdcpp/Makefile1
-rw-r--r--net-p2p/linuxdcpp/files/patch-client_Text.cpp32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index 35cc9757a73f..4e6dcf1e8ed9 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= linuxdcpp
PORTVERSION= 0.0.1.20070324 #0.0.1.YYYYMMDD
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.freebsd.org/~mezz/distfiles/
diff --git a/net-p2p/linuxdcpp/files/patch-client_Text.cpp b/net-p2p/linuxdcpp/files/patch-client_Text.cpp
new file mode 100644
index 000000000000..959bd01da306
--- /dev/null
+++ b/net-p2p/linuxdcpp/files/patch-client_Text.cpp
@@ -0,0 +1,32 @@
+===================================================================
+RCS file: /cvsroot/linuxdcpp/linuxdcpp/client/Text.cpp,v
+retrieving revision 1.15
+retrieving revision 1.16
+diff -u -r1.15 -r1.16
+--- client/Text.cpp 2007/03/24 18:33:17 1.15
++++ client/Text.cpp 2007/03/28 00:03:12 1.16
+@@ -25,6 +25,7 @@
+ #ifndef _WIN32
+ #include <errno.h>
+ #include <iconv.h>
++#include <langinfo.h>
+
+ #ifndef ICONV_CONST
+ #define ICONV_CONST
+@@ -38,12 +39,16 @@
+ void Text::initialize() {
+ setlocale(LC_ALL, "");
+
++#ifdef _WIN32
+ char *ctype = setlocale(LC_CTYPE, NULL);
+ if(ctype) {
+ systemCharset = string(ctype);
+ } else {
+ dcdebug("Unable to determine the program's locale");
+ }
++#else
++ systemCharset = string(nl_langinfo(CODESET));
++#endif
+ }
+
+ int Text::utf8ToWc(const char* str, wchar_t& c) {