aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/linuxdcpp
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-09-12 20:53:20 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-09-12 20:53:20 +0000
commitcce892a6a8d4b99ab4450f0ee89fa8b5b3513d2c (patch)
tree50c27cc6a100cc00a6f23db36fa09640b5ca2680 /net-p2p/linuxdcpp
parent9a891a097e28f956db8243a963a7463750638670 (diff)
downloadports-cce892a6a8d4b99ab4450f0ee89fa8b5b3513d2c.tar.gz
ports-cce892a6a8d4b99ab4450f0ee89fa8b5b3513d2c.zip
Notes
Diffstat (limited to 'net-p2p/linuxdcpp')
-rw-r--r--net-p2p/linuxdcpp/Makefile2
-rw-r--r--net-p2p/linuxdcpp/distinfo6
-rw-r--r--net-p2p/linuxdcpp/files/patch-client_HashManager.cpp13
3 files changed, 17 insertions, 4 deletions
diff --git a/net-p2p/linuxdcpp/Makefile b/net-p2p/linuxdcpp/Makefile
index c9efb6f3d789..5b92fba9f646 100644
--- a/net-p2p/linuxdcpp/Makefile
+++ b/net-p2p/linuxdcpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= linuxdcpp
-PORTVERSION= 0.0.1.20060901 #0.0.1.YYYYMMDD
+PORTVERSION= 0.0.1.20060911 #0.0.1.YYYYMMDD
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=mezz
diff --git a/net-p2p/linuxdcpp/distinfo b/net-p2p/linuxdcpp/distinfo
index 6eaf8b771a93..a0a2441afa51 100644
--- a/net-p2p/linuxdcpp/distinfo
+++ b/net-p2p/linuxdcpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (linuxdcpp-0.0.1.20060901.tar.bz2) = d0cb7cebb39182ecf6ab5a1f13f0e3d9
-SHA256 (linuxdcpp-0.0.1.20060901.tar.bz2) = bf18172b3348f2aa35a665f6c769026f48f686619b4c95008b8224ec4892de96
-SIZE (linuxdcpp-0.0.1.20060901.tar.bz2) = 348060
+MD5 (linuxdcpp-0.0.1.20060911.tar.bz2) = f8990b033af251a6a7e8032bc229a3d0
+SHA256 (linuxdcpp-0.0.1.20060911.tar.bz2) = 4a890cc770e740e307413ba710df358ceea3a7b8d012362b132f19a036f73da2
+SIZE (linuxdcpp-0.0.1.20060911.tar.bz2) = 348540
diff --git a/net-p2p/linuxdcpp/files/patch-client_HashManager.cpp b/net-p2p/linuxdcpp/files/patch-client_HashManager.cpp
new file mode 100644
index 000000000000..4e3bb9961cb5
--- /dev/null
+++ b/net-p2p/linuxdcpp/files/patch-client_HashManager.cpp
@@ -0,0 +1,13 @@
+--- client/HashManager.cpp.orig Mon Sep 11 22:01:37 2006
++++ client/HashManager.cpp Mon Sep 11 22:02:43 2006
+@@ -552,6 +552,10 @@
+
+ #else // _WIN32
+
++#ifndef O_LARGEFILE
++#define O_LARGEFILE 0
++#endif
++
+ static const int64_t BUF_SIZE = 0x1000000 - (0x1000000 % getpagesize());
+
+ bool HashManager::Hasher::fastHash(const string& filename, u_int8_t* , TigerTree& tth, int64_t size, CRC32Filter* xcrc32) {