aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mldonkey-gui-devel
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-20 16:48:34 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-20 16:48:34 +0000
commit6f0132a5273f17515a2357e6a47573bd3418d49d (patch)
treec4cdce89c2b0b20507c649e1c12186d590e32993 /net-p2p/mldonkey-gui-devel
parent8c6aa295bd6ac362d1f2393f68a9c1a2133bbafa (diff)
downloadports-6f0132a5273f17515a2357e6a47573bd3418d49d.tar.gz
ports-6f0132a5273f17515a2357e6a47573bd3418d49d.zip
Notes
Diffstat (limited to 'net-p2p/mldonkey-gui-devel')
-rw-r--r--net-p2p/mldonkey-gui-devel/Makefile61
-rw-r--r--net-p2p/mldonkey-gui-devel/distinfo1
-rw-r--r--net-p2p/mldonkey-gui-devel/files/wrapper.sh18
-rw-r--r--net-p2p/mldonkey-gui-devel/mldonkey-gui/Makefile61
-rw-r--r--net-p2p/mldonkey-gui-devel/mldonkey-gui/distinfo1
-rw-r--r--net-p2p/mldonkey-gui-devel/mldonkey-gui/files/wrapper.sh18
-rw-r--r--net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-comment1
-rw-r--r--net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-descr14
-rw-r--r--net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-message20
-rw-r--r--net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-plist7
-rw-r--r--net-p2p/mldonkey-gui-devel/pkg-comment1
-rw-r--r--net-p2p/mldonkey-gui-devel/pkg-descr14
-rw-r--r--net-p2p/mldonkey-gui-devel/pkg-message20
-rw-r--r--net-p2p/mldonkey-gui-devel/pkg-plist7
14 files changed, 244 insertions, 0 deletions
diff --git a/net-p2p/mldonkey-gui-devel/Makefile b/net-p2p/mldonkey-gui-devel/Makefile
new file mode 100644
index 000000000000..437294570f0c
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: mldonkey
+# Date created: 21 August 2002
+# Whom: Holger Lamm <holger@e-gitt.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mldonkey
+PORTVERSION= 1.16
+CATEGORIES= net
+MASTER_SITES= http://savannah.nongnu.org/download/mldonkey/ \
+ http://freesoftware.fsf.org/download/mldonkey/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.static.${ARCH}-FreeBSD
+
+MAINTAINER= holger@e-gitt.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+ONLY_FOR_ARCHS= i386
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-distrib
+
+DIRNAME= ${HOME}/.mldonkey
+
+# do not strip, it breaks OCAML binaries
+STRIP=
+
+post-patch:
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/wrapper.sh
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
+ ${WRKSRC}/kill_mldonkey
+
+pre-install:
+# we can strip the GTK binary
+ @${STRIP_CMD} ${WRKSRC}/mldonkey_gui
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey ${PREFIX}/bin/mldonkey-real
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/kill_mldonkey ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/mldonkey_previewer ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DOCSDIR}
+.endif
+
+post-install:
+ @${SED} -e 's|/usr/local/|${PREFIX}/|' ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+install-user: extract
+ @${TEST} -d ${DIRNAME} || ${MKDIR} ${DIRNAME}
+ @${CP} ${WRKSRC}/servers.ini ${DIRNAME}/
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/mldonkey-gui-devel/distinfo b/net-p2p/mldonkey-gui-devel/distinfo
new file mode 100644
index 000000000000..a2660a36c994
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/distinfo
@@ -0,0 +1 @@
+MD5 (mldonkey-1.16.static.i386-FreeBSD.tar.bz2) = b15aeabf1b0496f225f62baca7b0077c
diff --git a/net-p2p/mldonkey-gui-devel/files/wrapper.sh b/net-p2p/mldonkey-gui-devel/files/wrapper.sh
new file mode 100644
index 000000000000..c25fd62bc133
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/files/wrapper.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+PREFIX="%%PREFIX%%/bin"
+PROGRAM="${0}"
+DIRNAME=${HOME}/.mldonkey
+
+if [ ! -d ${DIRNAME} ]
+then
+ mkdir -p ${DIRNAME}
+fi
+
+echo " ${*} " | grep " \-createdironly " ||
+{
+ cd ${DIRNAME} &&
+ echo Running under ${DIRNAME} &&
+ exec ${PREFIX}/${PROGRAM##*/}-real "${@}" ||
+ echo PROBLEM. Cannot create directory ${DIRNAME}, make sure you have the proper permissions to create it and try again
+}
diff --git a/net-p2p/mldonkey-gui-devel/mldonkey-gui/Makefile b/net-p2p/mldonkey-gui-devel/mldonkey-gui/Makefile
new file mode 100644
index 000000000000..437294570f0c
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/mldonkey-gui/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: mldonkey
+# Date created: 21 August 2002
+# Whom: Holger Lamm <holger@e-gitt.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mldonkey
+PORTVERSION= 1.16
+CATEGORIES= net
+MASTER_SITES= http://savannah.nongnu.org/download/mldonkey/ \
+ http://freesoftware.fsf.org/download/mldonkey/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.static.${ARCH}-FreeBSD
+
+MAINTAINER= holger@e-gitt.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+ONLY_FOR_ARCHS= i386
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-distrib
+
+DIRNAME= ${HOME}/.mldonkey
+
+# do not strip, it breaks OCAML binaries
+STRIP=
+
+post-patch:
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/wrapper.sh
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
+ ${WRKSRC}/kill_mldonkey
+
+pre-install:
+# we can strip the GTK binary
+ @${STRIP_CMD} ${WRKSRC}/mldonkey_gui
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey ${PREFIX}/bin/mldonkey-real
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/kill_mldonkey ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/mldonkey_previewer ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DOCSDIR}
+.endif
+
+post-install:
+ @${SED} -e 's|/usr/local/|${PREFIX}/|' ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+install-user: extract
+ @${TEST} -d ${DIRNAME} || ${MKDIR} ${DIRNAME}
+ @${CP} ${WRKSRC}/servers.ini ${DIRNAME}/
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/mldonkey-gui-devel/mldonkey-gui/distinfo b/net-p2p/mldonkey-gui-devel/mldonkey-gui/distinfo
new file mode 100644
index 000000000000..a2660a36c994
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/mldonkey-gui/distinfo
@@ -0,0 +1 @@
+MD5 (mldonkey-1.16.static.i386-FreeBSD.tar.bz2) = b15aeabf1b0496f225f62baca7b0077c
diff --git a/net-p2p/mldonkey-gui-devel/mldonkey-gui/files/wrapper.sh b/net-p2p/mldonkey-gui-devel/mldonkey-gui/files/wrapper.sh
new file mode 100644
index 000000000000..c25fd62bc133
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/mldonkey-gui/files/wrapper.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+PREFIX="%%PREFIX%%/bin"
+PROGRAM="${0}"
+DIRNAME=${HOME}/.mldonkey
+
+if [ ! -d ${DIRNAME} ]
+then
+ mkdir -p ${DIRNAME}
+fi
+
+echo " ${*} " | grep " \-createdironly " ||
+{
+ cd ${DIRNAME} &&
+ echo Running under ${DIRNAME} &&
+ exec ${PREFIX}/${PROGRAM##*/}-real "${@}" ||
+ echo PROBLEM. Cannot create directory ${DIRNAME}, make sure you have the proper permissions to create it and try again
+}
diff --git a/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-comment b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-comment
new file mode 100644
index 000000000000..985c930c3045
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-comment
@@ -0,0 +1 @@
+A OCAML/GTK client for the eDonkey peer-to-peer network
diff --git a/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-descr b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-descr
new file mode 100644
index 000000000000..470212b5f06b
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-descr
@@ -0,0 +1,14 @@
+mldonkey is a OCAML/GTK client for the eDonkey peer-to-peer network
+(see http://www.edonkey2000.com/ and the 'edonkey' ports).
+
+It is separated into a core with telnet and web interfaces, and
+brings a GTK GUI.
+
+Other features over the original client are:
+- better stability
+- faster operation
+- much better control
+- saves its current state, checksums and known peers
+ (instead of starting from scratch every time)
+
+WWW: http://www.freesoftware.fsf.org/mldonkey/
diff --git a/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-message b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-message
new file mode 100644
index 000000000000..568af83e56c0
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-message
@@ -0,0 +1,20 @@
+ ATTENTIONATTENTION:
+
+- It is not a bad idea to install mplayer. You will be able
+ to preview half-downloaded files (if you have the beginning).
+
+- Please make sure that you read
+ /usr/local/share/doc/mldonkey/Readme.txt.
+ It contains important information about how to run mldonkey.
+
+- If this is the first time you install mldonkey,
+ please go to the mldonkey ports dir as a user and enter:
+
+ make install-user
+
+ this will set up your user config and install an
+ initial server list.
+
+- You can import the downloads started with eDonkey
+ (try "import /home/directory/path/.edonkey2000-core"
+ on the console), but you can NOT go back!
diff --git a/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-plist b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-plist
new file mode 100644
index 000000000000..dbe1cecdc4d7
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/mldonkey-gui/pkg-plist
@@ -0,0 +1,7 @@
+bin/kill_mldonkey
+bin/mldonkey
+bin/mldonkey-real
+bin/mldonkey_gui
+bin/mldonkey_previewer
+%%PORTDOCS%%share/doc/mldonkey/Readme.txt
+%%PORTDOCS%%@dirrm share/doc/mldonkey
diff --git a/net-p2p/mldonkey-gui-devel/pkg-comment b/net-p2p/mldonkey-gui-devel/pkg-comment
new file mode 100644
index 000000000000..985c930c3045
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/pkg-comment
@@ -0,0 +1 @@
+A OCAML/GTK client for the eDonkey peer-to-peer network
diff --git a/net-p2p/mldonkey-gui-devel/pkg-descr b/net-p2p/mldonkey-gui-devel/pkg-descr
new file mode 100644
index 000000000000..470212b5f06b
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/pkg-descr
@@ -0,0 +1,14 @@
+mldonkey is a OCAML/GTK client for the eDonkey peer-to-peer network
+(see http://www.edonkey2000.com/ and the 'edonkey' ports).
+
+It is separated into a core with telnet and web interfaces, and
+brings a GTK GUI.
+
+Other features over the original client are:
+- better stability
+- faster operation
+- much better control
+- saves its current state, checksums and known peers
+ (instead of starting from scratch every time)
+
+WWW: http://www.freesoftware.fsf.org/mldonkey/
diff --git a/net-p2p/mldonkey-gui-devel/pkg-message b/net-p2p/mldonkey-gui-devel/pkg-message
new file mode 100644
index 000000000000..568af83e56c0
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/pkg-message
@@ -0,0 +1,20 @@
+ ATTENTIONATTENTION:
+
+- It is not a bad idea to install mplayer. You will be able
+ to preview half-downloaded files (if you have the beginning).
+
+- Please make sure that you read
+ /usr/local/share/doc/mldonkey/Readme.txt.
+ It contains important information about how to run mldonkey.
+
+- If this is the first time you install mldonkey,
+ please go to the mldonkey ports dir as a user and enter:
+
+ make install-user
+
+ this will set up your user config and install an
+ initial server list.
+
+- You can import the downloads started with eDonkey
+ (try "import /home/directory/path/.edonkey2000-core"
+ on the console), but you can NOT go back!
diff --git a/net-p2p/mldonkey-gui-devel/pkg-plist b/net-p2p/mldonkey-gui-devel/pkg-plist
new file mode 100644
index 000000000000..dbe1cecdc4d7
--- /dev/null
+++ b/net-p2p/mldonkey-gui-devel/pkg-plist
@@ -0,0 +1,7 @@
+bin/kill_mldonkey
+bin/mldonkey
+bin/mldonkey-real
+bin/mldonkey_gui
+bin/mldonkey_previewer
+%%PORTDOCS%%share/doc/mldonkey/Readme.txt
+%%PORTDOCS%%@dirrm share/doc/mldonkey