aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mldonkey-gui/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-15 19:55:31 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-06-15 19:55:31 +0000
commitc328d32cadf39fbecd3209e7c825c6bf9906a772 (patch)
treef9d2ada76e5977f48f7122297a42f0689aa9a786 /net-p2p/mldonkey-gui/Makefile
parentc3a7daad7a1c5b879767cd378d8165887e841f48 (diff)
downloadports-c328d32cadf39fbecd3209e7c825c6bf9906a772.tar.gz
ports-c328d32cadf39fbecd3209e7c825c6bf9906a772.zip
Notes
Diffstat (limited to 'net-p2p/mldonkey-gui/Makefile')
-rw-r--r--net-p2p/mldonkey-gui/Makefile56
1 files changed, 5 insertions, 51 deletions
diff --git a/net-p2p/mldonkey-gui/Makefile b/net-p2p/mldonkey-gui/Makefile
index 9757b493bad9..1b80b728432b 100644
--- a/net-p2p/mldonkey-gui/Makefile
+++ b/net-p2p/mldonkey-gui/Makefile
@@ -5,57 +5,11 @@
# $FreeBSD$
#
-PORTNAME= mldonkey
-PORTVERSION= 2.04.r1
-CATEGORIES= net
-MASTER_SITES= http://savannah.nongnu.org/download/mldonkey/release-2.04rc1/contributed/holger/
-PKGNAMESUFFIX= -gui
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}-0.shared.${ARCH}-${OPSYS}-hl
+# build only the GUI
+WITHOUT_CORE= yes
-MAINTAINER= holger@e-gitt.net
-COMMENT= A OCAML/GTK GUI for the mldonkey peer-to-peer network client
+COMMENT= A OCAML/GTK GUI for the MLdonkey peer-to-peer network client
-ONLY_FOR_ARCHS= i386 alpha
-USE_BZIP2= yes
-USE_GNOME= gtk12
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-distrib-${PORTVERSION:S/.r/rc/}-0
+MASTERDIR= ${.CURDIR}/../mldonkey
-DIRNAME= ${HOME}/.mldonkey
-
-post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
- ${WRKDIR}/wrapper.sh
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey+gui ${PREFIX}/bin/mldonkey+gui-real
- @if [ -e ${PREFIX}/bin/mldonkey ]; then \
- ${LN} ${PREFIX}/bin/mldonkey ${PREFIX}/bin/mldonkey+gui; \
- else \
- ${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey+gui; \
- fi
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui2 ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/mldonkey_previewer ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_guistarter ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/mlim ${PREFIX}/bin
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
-.endif
-
-install-user: extract
-.if !defined(LANG)
- @${ECHO_MSG} "Please call as: make install-user LANG=<lang>"
- @${ECHO_MSG} "with <lang> one of en,de,fr,fr.noaccents,sp !"
-.else
- @${CP} ${WRKSRC}/i18n/gui_messages.ini.${LANG}\
- ${HOME}/.mldonkey_gui_messages.ini
-.endif
-
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"