aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mldonkey/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
commitb2a96c6df1c8809216eced623ec37a8372b3216e (patch)
tree0c994bc87e8a2f221a7e2be76b9aafc16eab32bb /net-p2p/mldonkey/Makefile
parent87b685f5d4325ba771e96b0ef49c71f903fb3ae0 (diff)
Notes
Diffstat (limited to 'net-p2p/mldonkey/Makefile')
-rw-r--r--net-p2p/mldonkey/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index 5f516d873f96..0f9e59b82f97 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -37,6 +37,8 @@ CONFIGURE_ENV+= \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+# FreeBSD has reentrant dns code
+PTHREAD_CFLAGS+= -D_REENTRANT
###
## Library dependency handling
@@ -109,11 +111,6 @@ ALL_TARGET+= \
.include <bsd.port.pre.mk>
-# FreeBSD has reentrant dns code
-.if ( ((${OSVERSION} >= 504102) && (${OSVERSION} < 600000)) || (${OSVERSION} >= 600029) )
-PTHREAD_CFLAGS+= -D_REENTRANT
-.endif
-
### Development version
## Thus, we will use non standard threading library
## We will switch from libpthread to libthr which should produce