aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mldonkey
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
commit02f27a83b44d4566fd409edc60570ac0734eb63e (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /net-p2p/mldonkey
parentbddf1289efd81317364118eb60cdc28cc766c3c2 (diff)
The output of tools like awk, date, sort, tr,... depends on the current
locale set by the user. Add LANG=C and LC_ALL=C at the beginning of bsd.port.mk and export them so all commands are executed with the C locale. LC_ALL=C overrides all other LC_* variables. LANG is used by setlocale(3) as default value for LC_* variables, so normally it isn't used when LC_ALL is set, but there's code out there that looks at LANG directly so it's safer to set it as well. The only commands not captured by this are != assignments before any inclusion of bsd.port.*mk. Introduce USE_LOCALE=<locale> that adds LANG=<locale> and LC_ALL=<locale> to CONFIGURE_ENV and MAKE_ENV so upstream build systems can be executed with a different locale (e.g. USE_LOCALE=en_US.UTF-8). PR: 215882 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=431796
Diffstat (limited to 'net-p2p/mldonkey')
-rw-r--r--net-p2p/mldonkey/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index 2efb97a0d9d6..6673182d638b 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -153,11 +153,11 @@ do-install:
.endif
install-user: extract
-.if !defined(LANG)
- @${ECHO_MSG} "Please call as: make install-user LANG=<lang>"
+.if !defined(LANGUAGE)
+ @${ECHO_MSG} "Please call as: make install-user LANGUAGE=<lang>"
@${ECHO_MSG} "with <lang> one of en,de,fr,fr.noaccents,sp !"
.else
- @${CP} ${WRKSRC}/distrib/i18n/gui_messages.ini.${LANG}\
+ @${CP} ${WRKSRC}/distrib/i18n/gui_messages.ini.${LANGUAGE}\
${HOME}/.mldonkey_gui_messages.ini
.endif