aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mute-net
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-12-25 17:18:34 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-12-25 17:18:34 +0000
commitcd6a31bda38fa1f27fc880b730e0d69a7286516a (patch)
treea726d1f189f6e62ea89a5c9435afb286d22f239f /net-p2p/mute-net
parent7be57018f5c44227d0e789d67dbf440c71c99825 (diff)
downloadports-cd6a31bda38fa1f27fc880b730e0d69a7286516a.tar.gz
ports-cd6a31bda38fa1f27fc880b730e0d69a7286516a.zip
Notes
Diffstat (limited to 'net-p2p/mute-net')
-rw-r--r--net-p2p/mute-net/Makefile171
-rw-r--r--net-p2p/mute-net/distinfo1
-rw-r--r--net-p2p/mute-net/files/patch-MUTE::configure72
-rw-r--r--net-p2p/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all11
-rw-r--r--net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all10
-rw-r--r--net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp19
-rw-r--r--net-p2p/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile35
-rw-r--r--net-p2p/mute-net/files/wrapper.sh37
-rw-r--r--net-p2p/mute-net/pkg-descr10
-rw-r--r--net-p2p/mute-net/pkg-message10
-rw-r--r--net-p2p/mute-net/pkg-plist32
11 files changed, 408 insertions, 0 deletions
diff --git a/net-p2p/mute-net/Makefile b/net-p2p/mute-net/Makefile
new file mode 100644
index 000000000000..fb7df87caa85
--- /dev/null
+++ b/net-p2p/mute-net/Makefile
@@ -0,0 +1,171 @@
+# New ports collection makefile for: mute-net
+# Date created: Sat Dec 20 00:39:52 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mute
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}-net
+PKGNAMESUFFIX= -net
+DISTNAME= MUTE_fileSharing-${PORTVERSION}_UnixSource
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Peer-to-peer client with privacy protection and easy search/download
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+
+USE_PERL5_BUILD=yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/MUTE_fileSharing-0.1-rc5_UnixSource/MUTE
+PATCH_WRKSRC= ${WRKDIR}/MUTE_fileSharing-0.1-rc5_UnixSource
+
+.ifndef(WITHOUT_GUI)
+LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
+
+WX_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
+.endif
+
+#
+MUTE_CORE_GUI= otherApps/fileSharing/userInterface/wxWindows/fileSharingMUTE
+MUTE_CORE_GUI_FILE= fileSharingMUTE
+MUTE_SETTINGS_GUI= otherApps/fileSharing/userInterface/wxWindows/settings/
+#
+MUTE_CORE_TEXT= otherApps/fileSharing/userInterface/textBased/textFileSharingMUTE
+MUTE_CORE_TEXT_FILE= textFileSharingMUTE
+MUTE_SETTINGS_TEXT= otherApps/fileSharing/userInterface/textBased/settings/
+
+pre-everything::
+#
+.if (defined(WITHOUT_GUI) && defined(WITHOUT_TEXT))
+ @${ECHO_MSG} "You need either GUI or TEXT interfaces."
+ @${ECHO_MSG} "Only disable one of them!"
+ @${FALSE}
+.endif
+#
+.if !defined(WITHOUT_GUI) && !defined(WITHOUT_TEXT)
+ @${ECHO_MSG} "You can disable the GUI interface by defining WITHOUT_GUI."
+ @${ECHO_MSG} "You can disable the TEXT interface by defining WITHOUT_TEXT."
+.endif
+
+post-patch:
+# C{flags,XX}, PTHREAD safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|^GXX.+$$|GXX=${CXX}|' \
+ -e 's|^(PLATFORM_LINK_FLAGS).+$$|\1=${PTHREAD_LIBS}|' \
+ -e 's|(-DBSD)|\1 ${CFLAGS} ${PTHREAD_CFLAGS}|' \
+ ${PATCH_WRKSRC}/MUTE/Makefile.FreeBSDX86
+# do not redefine socket_t
+.for file in \
+ minorGems/network/linux/SocketClientLinux.cpp \
+ minorGems/network/linux/SocketLinux.cpp \
+ minorGems/network/linux/SocketServerLinux.cpp
+ @${REINPLACE_CMD} -E \
+ -e 's|typedef int socklen_t;||' \
+ ${PATCH_WRKSRC}/${file}
+.endfor
+# do we want GUI?
+.ifndef(WITHOUT_GUI)
+ @${REINPLACE_CMD} -E \
+ -e 's|%%WX_CONFIG%%|${WX_CONFIG}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|" \
+ -e "s|%%DATADIR%%|${DATADIR}|" \
+ -e "s|%%INTERFACE%%|gui|" \
+ ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/wrapper-gui.sh
+.endif
+.ifndef(WITHOUT_TEXT)
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|" \
+ -e "s|%%DATADIR%%|${DATADIR}|" \
+ -e "s|%%INTERFACE%%|text|" \
+ ${FILESDIR}/wrapper.sh > \
+ ${WRKDIR}/wrapper-text.sh
+.endif
+
+post-configure:
+# we will use GNU make
+# XXX - g modifier does not work with sed from REINPLACE_CMD
+# @${REINPLACE_CMD} -E \
+ @${PERL} -pi \
+ -e 's| make| ${GMAKE}|g' \
+ ${CONFIGURE_WRKSRC}/${MAKEFILE}
+# CXX safeness
+ @${REINPLACE_CMD} -E \
+ -e 's|g\+\+|${CXX}|' \
+ ${WRKSRC}/otherApps/fileSharing/userInterface/wxWindows/Makefile
+# add our post-configure_patch
+ @cd ${PATCH_WRKSRC} ; ${PATCH} < \
+ ${FILESDIR}/post-configure_patch-MUTE::layers::messageRouting::Makefile
+
+post-build:
+.ifndef(WITHOUT_GUI)
+ @cd ${BUILD_WRKSRC}/otherApps/fileSharing/userInterface/wxWindows/ ; \
+ ${GMAKE}
+
+.endif
+
+do-install:
+# gui interface
+.ifndef(WITHOUT_GUI)
+# install binary
+ @${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${MUTE_CORE_GUI} \
+ ${PREFIX}/bin/${MUTE_CORE_GUI_FILE}-real
+# install wrapper
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper-gui.sh \
+ ${PREFIX}/bin/${MUTE_CORE_GUI_FILE}
+# install initial settings
+ @${MKDIR} ${DATADIR}/gui_settings/
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/${MUTE_SETTINGS_GUI}/* \
+ ${DATADIR}/gui_settings/
+.endif
+# text interface
+.ifndef(WITHOUT_TEXT)
+# install binary
+ @${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${MUTE_CORE_TEXT} \
+ ${PREFIX}/bin/${MUTE_CORE_TEXT_FILE}-real
+# install wrapper
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper-text.sh \
+ ${PREFIX}/bin/${MUTE_CORE_TEXT_FILE}
+# install initial settings
+ @${MKDIR} ${DATADIR}/text_settings/
+ @${INSTALL_DATA} ${INSTALL_WRKSRC}/${MUTE_SETTINGS_TEXT}/* \
+ ${DATADIR}/text_settings/
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+# we cannot install if either a slave or master port is already
+# installed
+CONFLICTS+= mute-net-*
+
+# gui interface
+.ifndef(WITHOUT_GUI)
+# we cannot install if slave gui port is installed
+PLIST_SUB+= GUI=""
+.else
+# tag package name properly
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-text
+
+PLIST_SUB+= GUI="@comment "
+.endif
+
+# text interface
+.ifndef(WITHOUT_TEXT)
+PLIST_SUB+= TEXT=""
+.else
+# tag package name properly
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gui
+
+PLIST_SUB+= TEXT="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/mute-net/distinfo b/net-p2p/mute-net/distinfo
new file mode 100644
index 000000000000..9c8c871a0dc8
--- /dev/null
+++ b/net-p2p/mute-net/distinfo
@@ -0,0 +1 @@
+MD5 (MUTE_fileSharing-0.1_UnixSource.tar.gz) = 914cda62258ba5f03f7d824f5c073f32
diff --git a/net-p2p/mute-net/files/patch-MUTE::configure b/net-p2p/mute-net/files/patch-MUTE::configure
new file mode 100644
index 000000000000..1a3b1934babd
--- /dev/null
+++ b/net-p2p/mute-net/files/patch-MUTE::configure
@@ -0,0 +1,72 @@
+--- MUTE/configure.orig Mon Dec 15 13:17:49 2003
++++ MUTE/configure Fri Dec 19 23:19:02 2003
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ #
+ # Modification History
+@@ -31,23 +31,9 @@
+
+ while [ -z "$userEntry" ]
+ do
+- echo "select platform:"
+-
+- echo " 1 -- GNU/Linux X86"
+- echo " 2 -- GNU/Linux PPC"
+- echo " 3 -- FreeBSD X86"
+- echo " 4 -- MacOSX"
+- echo " 5 -- Solaris"
+- echo " 6 -- Win32 using MinGW"
+- echo " q -- quit"
+-
+- echo ""
+- echo -n "> "
+-
+- read userEntry
+-
++userEntry=3
+
+- if [ "$userEntry" == "q" ]
++ if [ "$userEntry" = "q" ]
+ then
+ exit
+ fi
+@@ -55,12 +41,12 @@
+
+ # use ASCII comparison.
+
+- if [[ "$userEntry" > "6" ]]
++ if [ "$userEntry" -gt "6" ]
+ then
+ userEntry=""
+ fi
+
+- if [[ "$userEntry" < "1" ]]
++ if [ "$userEntry" -lt "1" ]
+ then
+ userEntry=""
+ fi
+@@ -316,20 +302,10 @@
+ esac
+
+
+-echo ""
+-echo ""
+-echo "Enter full path to wxWindows wx-config script."
+-echo " Example: /usr/bin/wx-config"
+-echo "To us the default setting, or if you do not plan to build the"
+-echo "wxWindows-based GUI, leave this blank."
+-
+-echo ""
+-echo -n "> "
+-
+-read userEntry
++userEntry=%%WX_CONFIG%%
+
+
+-if [ "$userEntry" == "" ]
++if [ "$userEntry" = "" ]
+ then
+ userEntry="/usr/bin/wx-config"
+ fi
diff --git a/net-p2p/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all b/net-p2p/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all
new file mode 100644
index 000000000000..cbba317c99e7
--- /dev/null
+++ b/net-p2p/mute-net/files/patch-MUTE::layers::fileTransfer::Makefile.all
@@ -0,0 +1,11 @@
+--- MUTE/layers/fileTransfer/Makefile.all.orig Sun Dec 21 01:05:38 2003
++++ MUTE/layers/fileTransfer/Makefile.all Sun Dec 21 01:05:56 2003
+@@ -50,7 +50,7 @@
+
+ # targets
+
+-all: libmuteFileTransfer.a test/testFileTransfer
++all: libmuteFileTransfer.a
+ clean:
+ rm -f ${DEPENDENCY_FILE} ${LAYER_OBJECTS} ${TEST_OBJECTS} ${NEEDED_MINOR_GEMS_OBJECTS} libmuteFileTransfer.a test/testFileTransfer
+
diff --git a/net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all b/net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all
new file mode 100644
index 000000000000..7db95eebf9e9
--- /dev/null
+++ b/net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::Makefile.all
@@ -0,0 +1,10 @@
+--- MUTE/layers/pointToPoint/Makefile.all.orig Sun Dec 21 00:53:18 2003
++++ MUTE/layers/pointToPoint/Makefile.all Sun Dec 21 00:53:26 2003
+@@ -34,6 +34,7 @@
+ LAYER_OBJECTS = ${LAYER_SOURCE:.cpp=.o}
+
+ NEEDED_MINOR_GEMS_OBJECTS = \
++${SHA1_O}
+
+
+ CRYPTO_LIB = ${ROOT_PATH}/MUTE/crypto/libcrypto.a
diff --git a/net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp b/net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp
new file mode 100644
index 000000000000..9bec3d21a8ad
--- /dev/null
+++ b/net-p2p/mute-net/files/patch-MUTE::layers::pointToPoint::pointToPointCommunicator.cpp
@@ -0,0 +1,19 @@
+--- MUTE/layers/pointToPoint/pointToPointCommunicator.cpp.orig Sun Dec 21 00:02:08 2003
++++ MUTE/layers/pointToPoint/pointToPointCommunicator.cpp Sun Dec 21 00:32:22 2003
+@@ -1153,7 +1153,7 @@
+
+ // handler to receive all messages from the routing layer
+ // extra argument not used
+-void mute_internalLowLevelMessageHandler( char *inFromAddress,
++int mute_internalLowLevelMessageHandler( char *inFromAddress,
+ char *inToAddress,
+ char *inBody,
+ void *inExtraArgument ) {
+@@ -1544,6 +1544,7 @@
+ delete [] *( tokens->getElement( i ) );
+ }
+ delete tokens;
++ return (0);
+ }
+
+
diff --git a/net-p2p/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile b/net-p2p/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile
new file mode 100644
index 000000000000..bd4ee53ae7bb
--- /dev/null
+++ b/net-p2p/mute-net/files/post-configure_patch-MUTE::layers::messageRouting::Makefile
@@ -0,0 +1,35 @@
+--- MUTE/layers/messageRouting/Makefile.orig Sat Dec 20 00:01:04 2003
++++ MUTE/layers/messageRouting/Makefile Sat Dec 20 00:02:01 2003
+@@ -532,10 +532,10 @@
+
+ # targets
+
+-all: libmuteMessageRouter.a test/testMessageRouter test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
++all: libmuteMessageRouter.a test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
+
+ clean:
+- rm -f ${DEPENDENCY_FILE} ${LAYER_OBJECTS} ${TEST_OBJECTS} ${NEEDED_MINOR_GEMS_OBJECTS} libmuteMessageRouter.a test/testMessageRouter test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
++ rm -f ${DEPENDENCY_FILE} ${LAYER_OBJECTS} ${NEEDED_MINOR_GEMS_OBJECTS} libmuteMessageRouter.a test/testMessageRouter2 test/testTalker test/testBystander test/testCatcher
+
+
+
+@@ -576,7 +576,6 @@
+ s/^SecureInputStream.o/$${STREAM_PATH}\/SecureInputStream.o/; \
+ s/^SecureOutpuStream.o/$${STREAM_PATH}\/SecureOutputStream.o/; \
+ s/^SecureStreamFactory.o/$${STREAM_PATH}\/SecureStreamFactory.o/; \
+-s/^testMessageRouter.o/test\/testMessageRouter.o/; \
+ s/^testMessageRouter2.o/test\/testMessageRouter2.o/; \
+ s/^testTalker.o/test\/testTalker.o/; \
+ s/^testBystander.o/test\/testBystander.o/; \
+@@ -585,9 +584,9 @@
+
+
+ # build the dependency file
+-${DEPENDENCY_FILE}: ${LAYER_SOURCE} ${TEST_SOURCE}
++${DEPENDENCY_FILE}: ${LAYER_SOURCE}
+ rm -f ${DEPENDENCY_FILE}
+- ${COMPILE} -I${ROOT_PATH} -MM ${LAYER_SOURCE} ${TEST_SOURCE} >> ${DEPENDENCY_FILE}.temp
++ ${COMPILE} -I${ROOT_PATH} -MM ${LAYER_SOURCE} >> ${DEPENDENCY_FILE}.temp
+ cat ${DEPENDENCY_FILE}.temp | ${MESSAGE_ROUTING_SED_FIX_COMMAND} >> ${DEPENDENCY_FILE}
+ rm -f ${DEPENDENCY_FILE}.temp
+
diff --git a/net-p2p/mute-net/files/wrapper.sh b/net-p2p/mute-net/files/wrapper.sh
new file mode 100644
index 000000000000..ed905246f9be
--- /dev/null
+++ b/net-p2p/mute-net/files/wrapper.sh
@@ -0,0 +1,37 @@
+#!/bin/sh
+
+PREFIX="%%PREFIX%%"
+PROGRAM="${0}"
+DIRNAME="${HOME}/.mute-net/%%INTERFACE%%"
+DIR_FILES="${DIRNAME}/files"
+DIR_SETTINGS_ORIGINAL="%%DATADIR%%/%%INTERFACE%%_settings"
+DIR_SETTINGS="${DIRNAME}/settings"
+
+if [ ! -d ${DIRNAME} ]
+then
+ mkdir -p ${DIRNAME}
+fi
+
+if [ ! -d ${DIR_FILES} ]
+then
+ mkdir -p ${DIR_FILES}
+fi
+
+if [ ! -d ${DIR_SETTINGS} ]
+then
+ mkdir -p "${DIR_SETTINGS}"
+ cp -R "${DIR_SETTINGS_ORIGINAL}/." "${DIR_SETTINGS}"
+fi
+
+if [ ! -h ${DIRNAME}/${PROGRAM##*/} ]
+then
+ ln -sf ${PREFIX}/bin/${PROGRAM##*/}-real ${DIRNAME}/${PROGRAM##*/}
+fi
+
+echo " ${*} " | grep " \-createdironly " ||
+{
+ cd ${DIRNAME} &&
+ echo Running under ${DIRNAME} &&
+ exec ./${PROGRAM##*/} "${@}" ||
+ echo PROBLEM. Cannot create directory ${DIRNAME}, make sure you have the proper permissions to create it and try again
+}
diff --git a/net-p2p/mute-net/pkg-descr b/net-p2p/mute-net/pkg-descr
new file mode 100644
index 000000000000..a315cf9aa94d
--- /dev/null
+++ b/net-p2p/mute-net/pkg-descr
@@ -0,0 +1,10 @@
+[ excerpt with modifications from developer's web site ]
+
+MUTE File Sharing is a new peer-to-peer network that provides easy
+search-and-download functionality while also protecting your privacy:
+
+o MUTE protects your privacy
+o Routing mechanism is inspired by ant behavior
+o Based on research
+
+WWW: http://mute-net.sourceforge.net/
diff --git a/net-p2p/mute-net/pkg-message b/net-p2p/mute-net/pkg-message
new file mode 100644
index 000000000000..274d8983e2a8
--- /dev/null
+++ b/net-p2p/mute-net/pkg-message
@@ -0,0 +1,10 @@
+ ATTENTIONATTENTION:
+
+This is a brand new peer-to-peer system. Please,
+make sure to check the developers' website if
+any problem arises.
+
+They might already be aware of the issue or you
+could let them know about it if they are not.
+
+http://mute-net.sourceforge.net/
diff --git a/net-p2p/mute-net/pkg-plist b/net-p2p/mute-net/pkg-plist
new file mode 100644
index 000000000000..da8ece810acc
--- /dev/null
+++ b/net-p2p/mute-net/pkg-plist
@@ -0,0 +1,32 @@
+%%GUI%%bin/fileSharingMUTE
+%%GUI%%bin/fileSharingMUTE-real
+%%TEXT%%bin/textFileSharingMUTE
+%%TEXT%%bin/textFileSharingMUTE-real
+%%GUI%%%%DATADIR%%/gui_settings/broadcastProbability.ini
+%%GUI%%%%DATADIR%%/gui_settings/inboundMessageLimit.ini
+%%GUI%%%%DATADIR%%/gui_settings/logConnections.ini
+%%GUI%%%%DATADIR%%/gui_settings/logLevel.ini
+%%GUI%%%%DATADIR%%/gui_settings/logMessageHistory.ini
+%%GUI%%%%DATADIR%%/gui_settings/logRoutingHistory.ini
+%%GUI%%%%DATADIR%%/gui_settings/mime.ini
+%%GUI%%%%DATADIR%%/gui_settings/outboundMessageLimit.ini
+%%GUI%%%%DATADIR%%/gui_settings/port.ini
+%%GUI%%%%DATADIR%%/gui_settings/seedHosts.ini
+%%GUI%%%%DATADIR%%/gui_settings/sharingPath.ini
+%%GUI%%%%DATADIR%%/gui_settings/showNiceQuit.ini
+%%GUI%%%%DATADIR%%/gui_settings/targetConnectionCount.ini
+%%TEXT%%%%DATADIR%%/text_settings/broadcastProbability.ini
+%%TEXT%%%%DATADIR%%/text_settings/inboundMessageLimit.ini
+%%TEXT%%%%DATADIR%%/text_settings/logConnections.ini
+%%TEXT%%%%DATADIR%%/text_settings/logLevel.ini
+%%TEXT%%%%DATADIR%%/text_settings/logMessageHistory.ini
+%%TEXT%%%%DATADIR%%/text_settings/logRoutingHistory.ini
+%%TEXT%%%%DATADIR%%/text_settings/mime.ini
+%%TEXT%%%%DATADIR%%/text_settings/outboundMessageLimit.ini
+%%TEXT%%%%DATADIR%%/text_settings/port.ini
+%%TEXT%%%%DATADIR%%/text_settings/seedHosts.ini
+%%TEXT%%%%DATADIR%%/text_settings/sharingPath.ini
+%%TEXT%%%%DATADIR%%/text_settings/targetConnectionCount.ini
+%%TEXT%%@dirrm %%DATADIR%%/text_settings
+%%GUI%%@dirrm %%DATADIR%%/gui_settings
+@dirrm %%DATADIR%%