aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/nicotine
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-01 20:33:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-01 20:33:15 +0000
commitf595fce2c6dd82f9c989c7501a133a39b7b7090a (patch)
treed05f948cdabcbb8e6ef323eebc31822f54813ca7 /net-p2p/nicotine
parent08403797922402ff916ba1c5d26efa20dbcfe6aa (diff)
downloadports-f595fce2c6dd82f9c989c7501a133a39b7b7090a.tar.gz
ports-f595fce2c6dd82f9c989c7501a133a39b7b7090a.zip
Notes
Diffstat (limited to 'net-p2p/nicotine')
-rw-r--r--net-p2p/nicotine/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/net-p2p/nicotine/Makefile b/net-p2p/nicotine/Makefile
index e309d94020ae..401977285976 100644
--- a/net-p2p/nicotine/Makefile
+++ b/net-p2p/nicotine/Makefile
@@ -22,12 +22,35 @@ USE_PYDISTUTILS= yes
.include <bsd.port.pre.mk>
+.if exists(${PYTHON_SITELIBDIR}/GeoIP.so) || defined(WITH_GEOIP)
+WITH_GEOIP= yes
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/GeoIP.so:${PORTSDIR}/net/py-GeoIP
+.endif
+
+.if exists(${PYTHON_SITELIBDIR}/psyco/_psyco.so) || defined(WITH_PSYCO)
+WITH_PSYCO= yes
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+.endif
+
.if exists(${PYTHON_SITELIBDIR}/ogg/vorbis.so) || defined(WITH_VORBIS)
+WITH_VORBIS= yes
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis
-.else
+.endif
+
+.if !defined(WITH_VORBIS) || !defined(WITH_PSYCO) || !defined(WITH_GEOIP)
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} "Define WITH_VORBIS=yes to enable OGG/Vorbis support"
+ @${ECHO_MSG} "You can define the following for additional features:"
+ @${ECHO_MSG} ""
+.if !defined(WITH_GEOIP)
+ @${ECHO_MSG} "WITH_GEOIP - enable the GeoIP based country code blocker"
+.endif
+.if !defined(WITH_PSYCO)
+ @${ECHO_MSG} "WITH_PSYCO - enable the psyco optimizing compiler"
+.endif
+.if !defined(WITH_VORBIS)
+ @${ECHO_MSG} "WITH_VORBIS - enable OGG/Vorbis support"
+.endif
@${ECHO_MSG} ""
.endif