aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/opendchub
diff options
context:
space:
mode:
authorTong LIU <nemoliu@FreeBSD.org>2010-02-03 13:50:50 +0000
committerTong LIU <nemoliu@FreeBSD.org>2010-02-03 13:50:50 +0000
commitd5af4ea9214dcd68ac12604b44b5d2ecc359588f (patch)
tree3470411fd3693473ecb4f39ebe272551aa9fe86d /net-p2p/opendchub
parentf780ba83e39085683575e83105cb1019ab94d82a (diff)
downloadports-d5af4ea9214dcd68ac12604b44b5d2ecc359588f.tar.gz
ports-d5af4ea9214dcd68ac12604b44b5d2ecc359588f.zip
Notes
Diffstat (limited to 'net-p2p/opendchub')
-rw-r--r--net-p2p/opendchub/Makefile7
-rw-r--r--net-p2p/opendchub/distinfo6
-rw-r--r--net-p2p/opendchub/files/patch-buffer_overflow_fix11
3 files changed, 8 insertions, 16 deletions
diff --git a/net-p2p/opendchub/Makefile b/net-p2p/opendchub/Makefile
index 11e188d1ff5e..f65ee8b3b836 100644
--- a/net-p2p/opendchub/Makefile
+++ b/net-p2p/opendchub/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= opendchub
-PORTVERSION= 0.7.16
+PORTVERSION= 0.8.1
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/Open%20DC%20Hub/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= yashin.dm@gmail.com
COMMENT= Unofficial Unix version of the Direct Connect Hub software
USE_PERL5= yes
@@ -25,6 +25,9 @@ PLIST_FILES= bin/${PORTNAME}
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+pre-install:
+ @${CHMOD} a+rx ${WRKSRC}/install-sh
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/net-p2p/opendchub/distinfo b/net-p2p/opendchub/distinfo
index ceb70637a3a2..5ff792e321b2 100644
--- a/net-p2p/opendchub/distinfo
+++ b/net-p2p/opendchub/distinfo
@@ -1,3 +1,3 @@
-MD5 (opendchub-0.7.16.tar.gz) = 81231a770b5fe2cb9360d0c03f004ce7
-SHA256 (opendchub-0.7.16.tar.gz) = 009e0c87e37f2840d40f82edd46cbffed9f3c3ac057b0d0b6b9c254587fbb31b
-SIZE (opendchub-0.7.16.tar.gz) = 234982
+MD5 (opendchub-0.8.1.tar.gz) = 51f3610dddc380d515a34b446bad92ef
+SHA256 (opendchub-0.8.1.tar.gz) = b7c18dda4b63e817519241c6e36fd7b6eac10f0240ad5fbb3ba731b82de7b833
+SIZE (opendchub-0.8.1.tar.gz) = 186255
diff --git a/net-p2p/opendchub/files/patch-buffer_overflow_fix b/net-p2p/opendchub/files/patch-buffer_overflow_fix
deleted file mode 100644
index 305b6c5d9558..000000000000
--- a/net-p2p/opendchub/files/patch-buffer_overflow_fix
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/commands.c.orig Sun Feb 13 17:16:37 2005
-+++ src/commands.c Sun Feb 13 17:17:18 2005
-@@ -2842,7 +2842,7 @@
- {
- char move_string[MAX_HOST_LEN+20];
-
-- sprintf(move_string, "$ForceMove %s", buf);
-+ snprintf(move_string, MAX_HOST_LEN, "$ForceMove %s", buf);
-
- send_to_humans(move_string, REGULAR | REGISTERED | OP, user);
- remove_all(UNKEYED | NON_LOGGED | REGULAR | REGISTERED | OP, 1, 1);