aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/py-bittorrent
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-05-30 03:27:00 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-05-30 03:27:00 +0000
commit6335722ac12890764b8c5e45d737bd27d77b749e (patch)
tree6708cf6f8e6214eec00ff2fdd9e930983c9056d5 /net-p2p/py-bittorrent
parent5a8b2663be28649cd59d13f90e769515ad0699e1 (diff)
downloadports-6335722ac12890764b8c5e45d737bd27d77b749e.tar.gz
ports-6335722ac12890764b8c5e45d737bd27d77b749e.zip
Notes
Diffstat (limited to 'net-p2p/py-bittorrent')
-rw-r--r--net-p2p/py-bittorrent/Makefile8
-rw-r--r--net-p2p/py-bittorrent/distinfo4
-rw-r--r--net-p2p/py-bittorrent/files/extra-psyco-patch-BitTorrent::launchmanycore.py18
-rw-r--r--net-p2p/py-bittorrent/files/extra-psyco-patch-btdownloadgui.py18
-rw-r--r--net-p2p/py-bittorrent/files/extra-psyco-patch-btmaketorrentgui.py (renamed from net-p2p/py-bittorrent/files/extra-psyco-patch-BitTorrent::makemetafile.py)12
5 files changed, 32 insertions, 28 deletions
diff --git a/net-p2p/py-bittorrent/Makefile b/net-p2p/py-bittorrent/Makefile
index 86a4ccfabf7a..ecbe998c7614 100644
--- a/net-p2p/py-bittorrent/Makefile
+++ b/net-p2p/py-bittorrent/Makefile
@@ -6,10 +6,12 @@
#
PORTNAME= BitTorrent
-PORTVERSION= 4.0.1
+PORTVERSION= 4.0.2
PORTEPOCH= 1
CATEGORIES?= net python
-MASTER_SITES= http://www.bittorrent.com/dl/
+MASTER_SITES= http://www.bittorrent.com/dl/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lioux@FreeBSD.org
@@ -67,10 +69,12 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
EXTRA_PATCHES+= \
${FILESDIR}/extra-psyco-patch-btdownloadcurses.py \
+ ${FILESDIR}/extra-psyco-patch-btdownloadgui.py \
${FILESDIR}/extra-psyco-patch-btdownloadheadless.py \
${FILESDIR}/extra-psyco-patch-btlaunchmany.py \
${FILESDIR}/extra-psyco-patch-btlaunchmanycurses.py \
${FILESDIR}/extra-psyco-patch-btmaketorrent.py \
+ ${FILESDIR}/extra-psyco-patch-btmaketorrentgui.py \
${FILESDIR}/extra-psyco-patch-btreannouce.py \
${FILESDIR}/extra-psyco-patch-btrename.py \
${FILESDIR}/extra-psyco-patch-btshowmetainfo.py \
diff --git a/net-p2p/py-bittorrent/distinfo b/net-p2p/py-bittorrent/distinfo
index 7cdeea842373..06dfeaa6a877 100644
--- a/net-p2p/py-bittorrent/distinfo
+++ b/net-p2p/py-bittorrent/distinfo
@@ -1,2 +1,2 @@
-MD5 (BitTorrent-4.0.1.tar.gz) = e890d856d43b3d0af14b28714bc5801a
-SIZE (BitTorrent-4.0.1.tar.gz) = 154427
+MD5 (BitTorrent-4.0.2.tar.gz) = 4640b7c1bac3146d628f54b20afb87b7
+SIZE (BitTorrent-4.0.2.tar.gz) = 155062
diff --git a/net-p2p/py-bittorrent/files/extra-psyco-patch-BitTorrent::launchmanycore.py b/net-p2p/py-bittorrent/files/extra-psyco-patch-BitTorrent::launchmanycore.py
deleted file mode 100644
index 5bea92e76323..000000000000
--- a/net-p2p/py-bittorrent/files/extra-psyco-patch-BitTorrent::launchmanycore.py
+++ /dev/null
@@ -1,18 +0,0 @@
---- BitTorrent/launchmanycore.py.orig Sat Mar 12 10:00:19 2005
-+++ BitTorrent/launchmanycore.py Sat Mar 12 10:00:40 2005
-@@ -13,6 +13,15 @@
- # Original version written by John Hoffman, heavily modified for different
- # multitorrent architecture by Uoti Urpala (over 40% shorter than original)
-
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
-+
- import os
- from cStringIO import StringIO
- from traceback import print_exc
diff --git a/net-p2p/py-bittorrent/files/extra-psyco-patch-btdownloadgui.py b/net-p2p/py-bittorrent/files/extra-psyco-patch-btdownloadgui.py
new file mode 100644
index 000000000000..d6af343a19df
--- /dev/null
+++ b/net-p2p/py-bittorrent/files/extra-psyco-patch-btdownloadgui.py
@@ -0,0 +1,18 @@
+--- btdownloadgui.py.orig Mon May 30 00:19:57 2005
++++ btdownloadgui.py Mon May 30 00:20:19 2005
+@@ -14,6 +14,15 @@
+
+ from __future__ import division
+
++from BitTorrent import PSYCO
++if PSYCO.psyco:
++ try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++ except:
++ pass
++
+ import sys
+
+ assert sys.version_info >= (2, 3), "Install Python 2.3 or greater"
diff --git a/net-p2p/py-bittorrent/files/extra-psyco-patch-BitTorrent::makemetafile.py b/net-p2p/py-bittorrent/files/extra-psyco-patch-btmaketorrentgui.py
index ffdceda64a19..a635ddfdd462 100644
--- a/net-p2p/py-bittorrent/files/extra-psyco-patch-BitTorrent::makemetafile.py
+++ b/net-p2p/py-bittorrent/files/extra-psyco-patch-btmaketorrentgui.py
@@ -1,8 +1,8 @@
---- BitTorrent/makemetafile.py.orig Sat Mar 12 09:58:42 2005
-+++ BitTorrent/makemetafile.py Sat Mar 12 09:59:06 2005
-@@ -12,6 +12,15 @@
+--- btmaketorrentgui.py.orig Mon May 30 00:20:48 2005
++++ btmaketorrentgui.py Mon May 30 00:21:00 2005
+@@ -14,6 +14,15 @@
- # Written by Bram Cohen
+ from __future__ import division
+from BitTorrent import PSYCO
+if PSYCO.psyco:
@@ -13,6 +13,6 @@
+ except:
+ pass
+
- from __future__ import division
-
import os
+ import sys
+