aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/py-kenosis-bittorrent/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-04-08 15:12:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-04-08 15:12:44 +0000
commit22ad20d3605c1b9c1d80422eb6ab37d7ea4cdcf1 (patch)
treea7716184ce3fde2cf7853ffd17650d4790af292b /net-p2p/py-kenosis-bittorrent/Makefile
parent95b191f02c000495e45dce7544b5ca4f10f2aec2 (diff)
downloadports-22ad20d3605c1b9c1d80422eb6ab37d7ea4cdcf1.tar.gz
ports-22ad20d3605c1b9c1d80422eb6ab37d7ea4cdcf1.zip
Notes
Diffstat (limited to 'net-p2p/py-kenosis-bittorrent/Makefile')
-rw-r--r--net-p2p/py-kenosis-bittorrent/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-p2p/py-kenosis-bittorrent/Makefile b/net-p2p/py-kenosis-bittorrent/Makefile
index 9c1e0b35b6bc..23db53979a29 100644
--- a/net-p2p/py-kenosis-bittorrent/Makefile
+++ b/net-p2p/py-kenosis-bittorrent/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= BitTorrent
-PORTVERSION= 3.4.1
-PORTREVISION= 1
+PORTVERSION= 3.4.2
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
@@ -21,11 +20,10 @@ COMMENT?= A peer-to-peer tool for distributing files written in Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_REINPLACE= yes
-USE_ZIP= yes
CONFLICTS= py??-*[Bb]it[Tt]orrent*
-DOC_FILES= BUILD.windows.txt INSTALL.unix.txt LICENSE.txt \
+PORTDOCS= BUILD.windows.txt INSTALL.unix.txt LICENSE.txt \
README.txt credits.txt
# required for GUI
@@ -33,9 +31,11 @@ DOC_FILES= BUILD.windows.txt INSTALL.unix.txt LICENSE.txt \
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython
PLIST_SUB+= GUI=''
+PLIST_FILES+= \
+ bin/btcompletedirgui.py \
+ bin/btdownloadgui.py
.else
EXTRA_PATCHES+= ${FILESDIR}/extra-nogui-patch-setup.py
-PLIST_SUB+= GUI='@comment '
.endif
pre-everything::
@@ -55,9 +55,9 @@ post-patch:
.endif
post-install:
-.ifndef(PORTDOCS)
+.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
+.for file in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif