aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/py-vertex
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-20 01:22:31 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-20 01:22:31 +0000
commitaf78f9ada8dc2b2a0f5e0e9b5e2a16c3956aa50a (patch)
tree1fdd1cedc285d715bdeb43a619517f321e512014 /net-p2p/py-vertex
parent0f8c1cf11b4be95fb990b0f3e9d68e1a775f4d19 (diff)
downloadports-af78f9ada8dc2b2a0f5e0e9b5e2a16c3956aa50a.tar.gz
ports-af78f9ada8dc2b2a0f5e0e9b5e2a16c3956aa50a.zip
Notes
Diffstat (limited to 'net-p2p/py-vertex')
-rw-r--r--net-p2p/py-vertex/Makefile28
-rw-r--r--net-p2p/py-vertex/distinfo3
-rw-r--r--net-p2p/py-vertex/pkg-descr18
-rw-r--r--net-p2p/py-vertex/pkg-plist110
4 files changed, 159 insertions, 0 deletions
diff --git a/net-p2p/py-vertex/Makefile b/net-p2p/py-vertex/Makefile
new file mode 100644
index 000000000000..1d441f38ef5a
--- /dev/null
+++ b/net-p2p/py-vertex/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-vertex
+# Date created: 19 May 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vertex
+PORTVERSION= 0.1
+CATEGORIES= net-p2p python
+MASTER_SITES= http://divmod.org/static/projects/vertex/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Vertex-${PORTVERSION}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Vertex is an implementation of the Q2Q protocol
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/epsilon/__init__.py:${PORTSDIR}/devel/py-epsilon \
+ ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/epsilon/__init__.py:${PORTSDIR}/devel/py-epsilon \
+ ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_TWISTED= yes
+NO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/net-p2p/py-vertex/distinfo b/net-p2p/py-vertex/distinfo
new file mode 100644
index 000000000000..f0c8a45af4e9
--- /dev/null
+++ b/net-p2p/py-vertex/distinfo
@@ -0,0 +1,3 @@
+MD5 (Vertex-0.1.tar.gz) = f2714a2ca2f97e35cdce3b995397d569
+SHA256 (Vertex-0.1.tar.gz) = cd197e3181101625cec1c59e08e2c058bbf918bf41e6e97ffac67bd11ae99608
+SIZE (Vertex-0.1.tar.gz) = 102739
diff --git a/net-p2p/py-vertex/pkg-descr b/net-p2p/py-vertex/pkg-descr
new file mode 100644
index 000000000000..c1f94ae46ef9
--- /dev/null
+++ b/net-p2p/py-vertex/pkg-descr
@@ -0,0 +1,18 @@
+Vertex is an implementation of the Q2Q protocol (sort of like P2P, but one
+better). There are a few moving parts in Vertex:
+
+ * PTCP: a protocol which is nearly identical to TCP, but which runs over
+ UDP. This lets Q2Q penetrate most NAT configurations.
+ * JUICE ([JU]ice [I]s [C]oncurrent [E]vents): a very simple but immensely
+ flexible protocol which forms the basis of the high-level aspects of Q2Q
+ * vertex: a command line tool which exposes a few features useful in many
+ situations (such as registration and authentication)
+
+The Q2Q network has some decentralized features (there is no one server or
+company which can control all Q2Q addresses) and features of centralization
+(addresses beneath a particular domain are issued by a server for that domain;
+once issued, some activities require the server to be contacted again, while
+others do not). Vertex includes an identity server capable of hosting Q2Q
+addresses.
+
+WWW: http://divmod.org/trac/wiki/DivmodVertex
diff --git a/net-p2p/py-vertex/pkg-plist b/net-p2p/py-vertex/pkg-plist
new file mode 100644
index 000000000000..21c46cbb59af
--- /dev/null
+++ b/net-p2p/py-vertex/pkg-plist
@@ -0,0 +1,110 @@
+bin/certcreate
+bin/vertex
+%%PYTHON_SITELIBDIR%%/vertex/__init__.py
+%%PYTHON_SITELIBDIR%%/vertex/__init__.pyc
+%%PYTHON_SITELIBDIR%%/vertex/__init__.pyo
+%%PYTHON_SITELIBDIR%%/vertex/_unfortunate_defer_hack.py
+%%PYTHON_SITELIBDIR%%/vertex/_unfortunate_defer_hack.pyc
+%%PYTHON_SITELIBDIR%%/vertex/_unfortunate_defer_hack.pyo
+%%PYTHON_SITELIBDIR%%/vertex/bits.py
+%%PYTHON_SITELIBDIR%%/vertex/bits.pyc
+%%PYTHON_SITELIBDIR%%/vertex/bits.pyo
+%%PYTHON_SITELIBDIR%%/vertex/conncache.py
+%%PYTHON_SITELIBDIR%%/vertex/conncache.pyc
+%%PYTHON_SITELIBDIR%%/vertex/conncache.pyo
+%%PYTHON_SITELIBDIR%%/vertex/depserv.py
+%%PYTHON_SITELIBDIR%%/vertex/depserv.pyc
+%%PYTHON_SITELIBDIR%%/vertex/depserv.pyo
+%%PYTHON_SITELIBDIR%%/vertex/endpoint.py
+%%PYTHON_SITELIBDIR%%/vertex/endpoint.pyc
+%%PYTHON_SITELIBDIR%%/vertex/endpoint.pyo
+%%PYTHON_SITELIBDIR%%/vertex/gtk2hack.py
+%%PYTHON_SITELIBDIR%%/vertex/gtk2hack.pyc
+%%PYTHON_SITELIBDIR%%/vertex/gtk2hack.pyo
+%%PYTHON_SITELIBDIR%%/vertex/ivertex.py
+%%PYTHON_SITELIBDIR%%/vertex/ivertex.pyc
+%%PYTHON_SITELIBDIR%%/vertex/ivertex.pyo
+%%PYTHON_SITELIBDIR%%/vertex/juice.py
+%%PYTHON_SITELIBDIR%%/vertex/juice.pyc
+%%PYTHON_SITELIBDIR%%/vertex/juice.pyo
+%%PYTHON_SITELIBDIR%%/vertex/liner.py
+%%PYTHON_SITELIBDIR%%/vertex/liner.pyc
+%%PYTHON_SITELIBDIR%%/vertex/liner.pyo
+%%PYTHON_SITELIBDIR%%/vertex/ptcp.py
+%%PYTHON_SITELIBDIR%%/vertex/ptcp.pyc
+%%PYTHON_SITELIBDIR%%/vertex/ptcp.pyo
+%%PYTHON_SITELIBDIR%%/vertex/q2q.py
+%%PYTHON_SITELIBDIR%%/vertex/q2q.pyc
+%%PYTHON_SITELIBDIR%%/vertex/q2q.pyo
+%%PYTHON_SITELIBDIR%%/vertex/q2qadmin.py
+%%PYTHON_SITELIBDIR%%/vertex/q2qadmin.pyc
+%%PYTHON_SITELIBDIR%%/vertex/q2qadmin.pyo
+%%PYTHON_SITELIBDIR%%/vertex/q2qclient.py
+%%PYTHON_SITELIBDIR%%/vertex/q2qclient.pyc
+%%PYTHON_SITELIBDIR%%/vertex/q2qclient.pyo
+%%PYTHON_SITELIBDIR%%/vertex/q2qstandalone.py
+%%PYTHON_SITELIBDIR%%/vertex/q2qstandalone.pyc
+%%PYTHON_SITELIBDIR%%/vertex/q2qstandalone.pyo
+%%PYTHON_SITELIBDIR%%/vertex/scripts/__init__.py
+%%PYTHON_SITELIBDIR%%/vertex/scripts/__init__.pyc
+%%PYTHON_SITELIBDIR%%/vertex/scripts/__init__.pyo
+%%PYTHON_SITELIBDIR%%/vertex/scripts/certcreate.py
+%%PYTHON_SITELIBDIR%%/vertex/scripts/certcreate.pyc
+%%PYTHON_SITELIBDIR%%/vertex/scripts/certcreate.pyo
+%%PYTHON_SITELIBDIR%%/vertex/sigma.py
+%%PYTHON_SITELIBDIR%%/vertex/sigma.pyc
+%%PYTHON_SITELIBDIR%%/vertex/sigma.pyo
+%%PYTHON_SITELIBDIR%%/vertex/sslverify.py
+%%PYTHON_SITELIBDIR%%/vertex/sslverify.pyc
+%%PYTHON_SITELIBDIR%%/vertex/sslverify.pyo
+%%PYTHON_SITELIBDIR%%/vertex/statemachine.py
+%%PYTHON_SITELIBDIR%%/vertex/statemachine.pyc
+%%PYTHON_SITELIBDIR%%/vertex/statemachine.pyo
+%%PYTHON_SITELIBDIR%%/vertex/subproducer.py
+%%PYTHON_SITELIBDIR%%/vertex/subproducer.pyc
+%%PYTHON_SITELIBDIR%%/vertex/subproducer.pyo
+%%PYTHON_SITELIBDIR%%/vertex/tcpdfa.py
+%%PYTHON_SITELIBDIR%%/vertex/tcpdfa.pyc
+%%PYTHON_SITELIBDIR%%/vertex/tcpdfa.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/__init__.py
+%%PYTHON_SITELIBDIR%%/vertex/test/__init__.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/__init__.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/iosim.py
+%%PYTHON_SITELIBDIR%%/vertex/test/iosim.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/iosim.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/mock_data.py
+%%PYTHON_SITELIBDIR%%/vertex/test/mock_data.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/mock_data.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_bits.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_bits.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_bits.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_dependencyservice.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_dependencyservice.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_dependencyservice.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_juice.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_juice.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_juice.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_ptcp.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_ptcp.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_ptcp.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_q2q.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_q2q.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_q2q.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_sigma.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_sigma.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_sigma.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_sslverify.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_sslverify.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_sslverify.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_statemachine.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_statemachine.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_statemachine.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/test_subproducer.py
+%%PYTHON_SITELIBDIR%%/vertex/test/test_subproducer.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/test_subproducer.pyo
+%%PYTHON_SITELIBDIR%%/vertex/test/utils.py
+%%PYTHON_SITELIBDIR%%/vertex/test/utils.pyc
+%%PYTHON_SITELIBDIR%%/vertex/test/utils.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/vertex/scripts
+@dirrm %%PYTHON_SITELIBDIR%%/vertex/test
+@dirrm %%PYTHON_SITELIBDIR%%/vertex