aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-04-18 00:35:50 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-04-18 00:35:50 +0000
commitfdf1c7185e725c66d118f9aa2fb530b5351097e2 (patch)
tree66c175d707d486a16987c8dd6643465830b80179 /net-p2p/qbittorrent/Makefile
parentda9996385bcfdada28a3a01779d0012dfe33b40d (diff)
downloadports-fdf1c7185e725c66d118f9aa2fb530b5351097e2.tar.gz
ports-fdf1c7185e725c66d118f9aa2fb530b5351097e2.zip
Notes
Diffstat (limited to 'net-p2p/qbittorrent/Makefile')
-rw-r--r--net-p2p/qbittorrent/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
new file mode 100644
index 000000000000..5e94cc772054
--- /dev/null
+++ b/net-p2p/qbittorrent/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qbittorrent
+# Date created: 2007-04-01
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= qbittorrent
+PORTVERSION= 0.9.2
+CATEGORIES= net-p2p
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Bittorrent client written in C++ / Qt4 using libtorrent
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ torrent.1:${PORTSDIR}/net-p2p/rblibtorrent-devel
+
+USE_PYTHON= 2.3+
+USE_QT_VER= 4
+QT_NONSTANDARD= yes
+INSTALLS_ICONS= yes
+HAS_CONFIGURE= yes
+CONFIGURE_TARGET= #
+CONFIGURE_ARGS= --with-libtorrent-inc="${LOCALBASE}/include" \
+ --with-libtorrent-lib="${LOCALBASE}/lib" \
+ --with-libcurl-inc="${LOCALBASE}/include" \
+ --with-libcurl-lib="${LOCALBASE}/lib"
+CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}"
+MAKE_ENV= QMAKESPEC="${QMAKESPEC}"
+
+MAN1= qbittorrent.1
+MANCOMPRESSED= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|bin/qmake|bin/${QMAKE:T}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
+ ${WRKSRC}/src/src.pro
+
+.include <bsd.port.mk>