aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-04-18 00:35:50 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-04-18 00:35:50 +0000
commitfdf1c7185e725c66d118f9aa2fb530b5351097e2 (patch)
tree66c175d707d486a16987c8dd6643465830b80179 /net-p2p/qbittorrent
parentda9996385bcfdada28a3a01779d0012dfe33b40d (diff)
downloadports-fdf1c7185e725c66d118f9aa2fb530b5351097e2.tar.gz
ports-fdf1c7185e725c66d118f9aa2fb530b5351097e2.zip
Notes
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile40
-rw-r--r--net-p2p/qbittorrent/distinfo3
-rw-r--r--net-p2p/qbittorrent/pkg-descr23
-rw-r--r--net-p2p/qbittorrent/pkg-plist38
4 files changed, 104 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
new file mode 100644
index 000000000000..5e94cc772054
--- /dev/null
+++ b/net-p2p/qbittorrent/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qbittorrent
+# Date created: 2007-04-01
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= qbittorrent
+PORTVERSION= 0.9.2
+CATEGORIES= net-p2p
+MASTER_SITES= SF
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Bittorrent client written in C++ / Qt4 using libtorrent
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ torrent.1:${PORTSDIR}/net-p2p/rblibtorrent-devel
+
+USE_PYTHON= 2.3+
+USE_QT_VER= 4
+QT_NONSTANDARD= yes
+INSTALLS_ICONS= yes
+HAS_CONFIGURE= yes
+CONFIGURE_TARGET= #
+CONFIGURE_ARGS= --with-libtorrent-inc="${LOCALBASE}/include" \
+ --with-libtorrent-lib="${LOCALBASE}/lib" \
+ --with-libcurl-inc="${LOCALBASE}/include" \
+ --with-libcurl-lib="${LOCALBASE}/lib"
+CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}"
+MAKE_ENV= QMAKESPEC="${QMAKESPEC}"
+
+MAN1= qbittorrent.1
+MANCOMPRESSED= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|bin/qmake|bin/${QMAKE:T}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
+ ${WRKSRC}/src/src.pro
+
+.include <bsd.port.mk>
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
new file mode 100644
index 000000000000..483cd44851fd
--- /dev/null
+++ b/net-p2p/qbittorrent/distinfo
@@ -0,0 +1,3 @@
+MD5 (qbittorrent-0.9.2.tar.gz) = 31fbe5628739877683cecbf7fcc0f5b4
+SHA256 (qbittorrent-0.9.2.tar.gz) = d200e03558fb8aff586bfb98fb8c59e4984e700ac3c5a4d26791e04fbe18153a
+SIZE (qbittorrent-0.9.2.tar.gz) = 833382
diff --git a/net-p2p/qbittorrent/pkg-descr b/net-p2p/qbittorrent/pkg-descr
new file mode 100644
index 000000000000..78dd0b98ce98
--- /dev/null
+++ b/net-p2p/qbittorrent/pkg-descr
@@ -0,0 +1,23 @@
+qBittorrent can now be considered as a good alternative to other bittorrent
+clients. It provides a lot of features such as:
+
+* A polished Graphical User Interface written with Qt4.2 toolkit.
+* Multiple simultaneous downloads / uploads.
+* An integrated search engine.
+* DHT (trackerless) support.
+* uTorrent Peer eXchange support (PeX).
+* Directory scanning with automated download of torrents inside.
+* Good internationalization (20+ languages supported).
+* Selective download of files in a torrent.
+* Media File previewing while downloading.
+* Torrent trackers edition and prioritizing.
+* Seeders / Leechers displayed in download list.
+* Torrent download in correct order.
+* System tray integration.
+* Tracker authentication support.
+* Unicode support.
+* Torrent downloading directly from their url.
+* Connection though a proxy.
+* IP Filtering similar to the one in eMule.
+
+WWW: http://www.qbittorrent.org/
diff --git a/net-p2p/qbittorrent/pkg-plist b/net-p2p/qbittorrent/pkg-plist
new file mode 100644
index 000000000000..aeb2a48626fc
--- /dev/null
+++ b/net-p2p/qbittorrent/pkg-plist
@@ -0,0 +1,38 @@
+bin/qbittorrent
+share/applications/qBittorrent.desktop
+share/icons/hicolor/128x128/apps/qbittorrent.png
+share/icons/hicolor/16x16/apps/qbittorrent.png
+share/icons/hicolor/192x192/apps/qbittorrent.png
+share/icons/hicolor/22x22/apps/qbittorrent.png
+share/icons/hicolor/24x24/apps/qbittorrent.png
+share/icons/hicolor/32x32/apps/qbittorrent.png
+share/icons/hicolor/36x36/apps/qbittorrent.png
+share/icons/hicolor/48x48/apps/qbittorrent.png
+share/icons/hicolor/64x64/apps/qbittorrent.png
+share/icons/hicolor/72x72/apps/qbittorrent.png
+share/icons/hicolor/96x96/apps/qbittorrent.png
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/36x36/apps
+@dirrmtry share/icons/hicolor/36x36
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/192x192/apps
+@dirrmtry share/icons/hicolor/192x192
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications