aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/rblibtorrent
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-06 12:19:43 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-06 12:19:43 +0000
commit5362f92654b00b13196eaf668fb08409092c6e6d (patch)
tree7c270502606d7d158f0e9c800c86352e9ff98453 /net-p2p/rblibtorrent
parent02e454d15d1b88464bea24b1fe794e707b78c633 (diff)
downloadports-5362f92654b00b13196eaf668fb08409092c6e6d.tar.gz
ports-5362f92654b00b13196eaf668fb08409092c6e6d.zip
Notes
Diffstat (limited to 'net-p2p/rblibtorrent')
-rw-r--r--net-p2p/rblibtorrent/Makefile4
-rw-r--r--net-p2p/rblibtorrent/distinfo6
-rw-r--r--net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp92
-rw-r--r--net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_error.hpp11
-rw-r--r--net-p2p/rblibtorrent/files/patch-include_libtorrent_socket.hpp11
-rw-r--r--net-p2p/rblibtorrent/files/patch-peer_connection.cpp35
-rw-r--r--net-p2p/rblibtorrent/pkg-plist176
7 files changed, 281 insertions, 54 deletions
diff --git a/net-p2p/rblibtorrent/Makefile b/net-p2p/rblibtorrent/Makefile
index 18a3f7ce82d0..ecf64016caa7 100644
--- a/net-p2p/rblibtorrent/Makefile
+++ b/net-p2p/rblibtorrent/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.9.1
+PORTVERSION= 0.10
CATEGORIES= net-p2p
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=libtorrent
@@ -20,7 +20,7 @@ LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost \
boost_thread.3:${PORTSDIR}/devel/boost
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-debug
CONFIGURE_ENV= CXXFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/net-p2p/rblibtorrent/distinfo b/net-p2p/rblibtorrent/distinfo
index ee5a75508f24..5c4a4b366674 100644
--- a/net-p2p/rblibtorrent/distinfo
+++ b/net-p2p/rblibtorrent/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-0.9.1.tar.gz) = 2e5d08a8f26e8e1e39b50020cb056818
-SHA256 (libtorrent-0.9.1.tar.gz) = 85796fa82c57dfba384ac3e2b1862f2ae30d24da1c11e57b51bcbab55e0a5415
-SIZE (libtorrent-0.9.1.tar.gz) = 711353
+MD5 (libtorrent-0.10.tar.gz) = 73de41c4782c120f56bce73d8f534d0b
+SHA256 (libtorrent-0.10.tar.gz) = b337eb174a26722ec4cdd4349e07bb5ef51eda7d8de1414c9d5ad5251c021edf
+SIZE (libtorrent-0.10.tar.gz) = 989448
diff --git a/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp b/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp
new file mode 100644
index 000000000000..35611ecb4084
--- /dev/null
+++ b/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp
@@ -0,0 +1,92 @@
+--- include/libtorrent/asio/detail/socket_ops.hpp Sun Jun 11 18:51:07 2006
++++ include/libtorrent/asio/detail/socket_ops.hpp Sun Jul 23 13:54:19 2006
+@@ -63,7 +63,8 @@
+ socket_addr_len_type* addrlen)
+ {
+ set_error(0);
+-#if defined(__MACH__) && defined(__APPLE__)
++//#if defined(__MACH__) && defined(__APPLE__)
++#if (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ socket_type new_s = error_wrapper(::accept(s, addr, addrlen));
+ if (new_s == invalid_socket)
+ return new_s;
+@@ -266,7 +267,8 @@
+ #if defined(BOOST_WINDOWS) || defined(__CYGWIN__)
+ return error_wrapper(::WSASocket(af, type, protocol, 0, 0,
+ WSA_FLAG_OVERLAPPED));
+-#elif defined(__MACH__) && defined(__APPLE__)
++//#elif defined(__MACH__) && defined(__APPLE__)
++#elif (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ socket_type s = error_wrapper(::socket(af, type, protocol));
+ if (s == invalid_socket)
+ return s;
+@@ -585,7 +587,7 @@
+ buffer, buflength, error));
+ *error = translate_netdb_error(*error);
+ return retval;
+-#elif defined(__MACH__) && defined(__APPLE__)
++#elif (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ (void)(buffer);
+ (void)(buflength);
+ hostent* retval = error_wrapper(::getipnodebyaddr(addr, length, af, error));
+@@ -633,7 +635,7 @@
+ buflength, error));
+ *error = translate_netdb_error(*error);
+ return retval;
+-#elif defined(__MACH__) && defined(__APPLE__)
++#elif (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ (void)(buffer);
+ (void)(buflength);
+ hostent* retval = error_wrapper(::getipnodebyname(
+@@ -660,7 +662,8 @@
+
+ inline void freehostent(hostent* h)
+ {
+-#if defined(__MACH__) && defined(__APPLE__)
++//#if defined(__MACH__) && defined(__APPLE__)
++#if (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ if (h)
+ ::freehostent(h);
+ #else
+@@ -1137,7 +1140,11 @@
+ case NO_RECOVERY:
+ return EAI_FAIL;
+ case NO_DATA:
++#if defined(__FreeBSD__)
++ return EAI_NONAME;
++#else
+ return EAI_NODATA;
++#endif
+ default:
+ return EAI_NONAME;
+ }
+@@ -1277,7 +1284,8 @@
+ int error = getaddrinfo_emulation(host, service, hints, result);
+ return translate_addrinfo_error(error);
+ # endif
+-#elif defined(__MACH__) && defined(__APPLE__)
++//#elif defined(__MACH__) && defined(__APPLE__)
++#elif (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ int error = getaddrinfo_emulation(host, service, hints, result);
+ return translate_addrinfo_error(error);
+ #else
+@@ -1305,7 +1313,8 @@
+ }
+ freeaddrinfo_emulation(ai);
+ # endif
+-#elif defined(__MACH__) && defined(__APPLE__)
++//#elif defined(__MACH__) && defined(__APPLE__)
++#elif (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ freeaddrinfo_emulation(ai);
+ #else
+ ::freeaddrinfo(ai);
+@@ -1466,7 +1475,8 @@
+ host, hostlen, serv, servlen, flags);
+ return translate_addrinfo_error(error);
+ # endif
+-#elif defined(__MACH__) && defined(__APPLE__)
++//#elif defined(__MACH__) && defined(__APPLE__)
++#elif (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ using namespace std; // For memcpy.
+ sockaddr_storage_type tmp_addr;
+ memcpy(&tmp_addr, addr, addrlen);
diff --git a/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_error.hpp b/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_error.hpp
new file mode 100644
index 000000000000..a26b5106e3ef
--- /dev/null
+++ b/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_error.hpp
@@ -0,0 +1,11 @@
+--- include/libtorrent/asio/error.hpp Sun Jun 11 18:51:03 2006
++++ include/libtorrent/asio/error.hpp Sun Jul 23 13:49:29 2006
+@@ -272,7 +272,7 @@
+ default:
+ #if defined(__sun) || defined(__QNX__)
+ return strerror(code_);
+-#elif defined(__MACH__) && defined(__APPLE__)
++#elif (defined(__MACH__) && defined(__APPLE__)) || defined(__FreeBSD__)
+ try
+ {
+ char buf[256] = "";
diff --git a/net-p2p/rblibtorrent/files/patch-include_libtorrent_socket.hpp b/net-p2p/rblibtorrent/files/patch-include_libtorrent_socket.hpp
new file mode 100644
index 000000000000..8dc4b5544cde
--- /dev/null
+++ b/net-p2p/rblibtorrent/files/patch-include_libtorrent_socket.hpp
@@ -0,0 +1,11 @@
+--- include/libtorrent/socket.hpp.orig Thu Aug 3 01:39:59 2006
++++ include/libtorrent/socket.hpp Thu Aug 3 01:40:02 2006
+@@ -75,7 +75,7 @@
+ using boost::asio::ipv4::host;
+ using boost::asio::deadline_timer;
+ */
+- namespace asio = ::asio;
++// namespace asio = ::asio;
+
+ using asio::ip::tcp;
+ using asio::ip::udp;
diff --git a/net-p2p/rblibtorrent/files/patch-peer_connection.cpp b/net-p2p/rblibtorrent/files/patch-peer_connection.cpp
deleted file mode 100644
index 19c691734589..000000000000
--- a/net-p2p/rblibtorrent/files/patch-peer_connection.cpp
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/peer_connection.cpp.orig Fri Dec 16 00:32:21 2005
-+++ src/peer_connection.cpp Thu Feb 23 13:07:01 2006
-@@ -1011,6 +1011,7 @@
-
- if (b != m_download_queue.end())
- {
-+/*
- for (i = m_download_queue.begin();
- i != b; ++i)
- {
-@@ -1023,7 +1024,7 @@
- // be requested from other peers
- picker.abort_download(*i);
- }
--
-+*/
- #ifdef TORRENT_VERBOSE_LOGGING
- (*m_logger) << to_simple_string(second_clock::universal_time())
- << " <== PIECE [ piece: " << p.piece << " | "
-@@ -1031,12 +1032,14 @@
- "s: " << p.start << " | "
- "l: " << p.length << " ]\n";
- #endif
--
-+/*
- // remove the request that just finished
- // from the download queue plus the
- // skipped blocks.
- m_download_queue.erase(m_download_queue.begin()
- , boost::next(b));
-+*/
-+ m_download_queue.erase(b);
- send_block_requests();
- }
- else
diff --git a/net-p2p/rblibtorrent/pkg-plist b/net-p2p/rblibtorrent/pkg-plist
index 91282392941e..c493179ba339 100644
--- a/net-p2p/rblibtorrent/pkg-plist
+++ b/net-p2p/rblibtorrent/pkg-plist
@@ -1,8 +1,157 @@
+bin/client_test
+bin/dump_torrent
+bin/make_torrent
+bin/simple_client
+bin/test_bencoding
+bin/test_buffer
+bin/test_hasher
+bin/test_ip_filter
+bin/test_metadata_extension
+bin/test_piece_picker
+bin/test_storage
include/libtorrent/alert.hpp
include/libtorrent/alert_types.hpp
include/libtorrent/allocate_resources.hpp
-include/libtorrent/async_gethostbyname.hpp
+include/libtorrent/asio.hpp
+include/libtorrent/asio/basic_datagram_socket.hpp
+include/libtorrent/asio/basic_deadline_timer.hpp
+include/libtorrent/asio/basic_io_object.hpp
+include/libtorrent/asio/basic_resolver.hpp
+include/libtorrent/asio/basic_socket.hpp
+include/libtorrent/asio/basic_socket_acceptor.hpp
+include/libtorrent/asio/basic_socket_iostream.hpp
+include/libtorrent/asio/basic_socketbuf.hpp
+include/libtorrent/asio/basic_strand.hpp
+include/libtorrent/asio/basic_stream_socket.hpp
+include/libtorrent/asio/basic_streambuf.hpp
+include/libtorrent/asio/buffer.hpp
+include/libtorrent/asio/buffered_read_stream.hpp
+include/libtorrent/asio/buffered_read_stream_fwd.hpp
+include/libtorrent/asio/buffered_stream.hpp
+include/libtorrent/asio/buffered_stream_fwd.hpp
+include/libtorrent/asio/buffered_write_stream.hpp
+include/libtorrent/asio/buffered_write_stream_fwd.hpp
+include/libtorrent/asio/completion_condition.hpp
+include/libtorrent/asio/datagram_socket_service.hpp
+include/libtorrent/asio/deadline_timer.hpp
+include/libtorrent/asio/deadline_timer_service.hpp
+include/libtorrent/asio/detail/bind_handler.hpp
+include/libtorrent/asio/detail/buffer_resize_guard.hpp
+include/libtorrent/asio/detail/buffered_stream_storage.hpp
+include/libtorrent/asio/detail/call_stack.hpp
+include/libtorrent/asio/detail/const_buffers_iterator.hpp
+include/libtorrent/asio/detail/consuming_buffers.hpp
+include/libtorrent/asio/detail/epoll_reactor.hpp
+include/libtorrent/asio/detail/epoll_reactor_fwd.hpp
+include/libtorrent/asio/detail/event.hpp
+include/libtorrent/asio/detail/fd_set_adapter.hpp
+include/libtorrent/asio/detail/handler_alloc_helpers.hpp
+include/libtorrent/asio/detail/hash_map.hpp
+include/libtorrent/asio/detail/io_control.hpp
+include/libtorrent/asio/detail/kqueue_reactor.hpp
+include/libtorrent/asio/detail/kqueue_reactor_fwd.hpp
+include/libtorrent/asio/detail/mutex.hpp
+include/libtorrent/asio/detail/noncopyable.hpp
+include/libtorrent/asio/detail/null_event.hpp
+include/libtorrent/asio/detail/null_mutex.hpp
+include/libtorrent/asio/detail/null_signal_blocker.hpp
+include/libtorrent/asio/detail/null_thread.hpp
+include/libtorrent/asio/detail/null_tss_ptr.hpp
+include/libtorrent/asio/detail/old_win_sdk_compat.hpp
+include/libtorrent/asio/detail/pipe_select_interrupter.hpp
+include/libtorrent/asio/detail/pop_options.hpp
+include/libtorrent/asio/detail/posix_event.hpp
+include/libtorrent/asio/detail/posix_mutex.hpp
+include/libtorrent/asio/detail/posix_signal_blocker.hpp
+include/libtorrent/asio/detail/posix_thread.hpp
+include/libtorrent/asio/detail/posix_tss_ptr.hpp
+include/libtorrent/asio/detail/push_options.hpp
+include/libtorrent/asio/detail/reactive_deadline_timer_service.hpp
+include/libtorrent/asio/detail/reactive_socket_service.hpp
+include/libtorrent/asio/detail/reactor_op_queue.hpp
+include/libtorrent/asio/detail/reactor_timer_queue.hpp
+include/libtorrent/asio/detail/resolver_service.hpp
+include/libtorrent/asio/detail/scoped_lock.hpp
+include/libtorrent/asio/detail/select_interrupter.hpp
+include/libtorrent/asio/detail/select_reactor.hpp
+include/libtorrent/asio/detail/select_reactor_fwd.hpp
+include/libtorrent/asio/detail/service_registry.hpp
+include/libtorrent/asio/detail/signal_blocker.hpp
+include/libtorrent/asio/detail/signal_init.hpp
+include/libtorrent/asio/detail/socket_holder.hpp
+include/libtorrent/asio/detail/socket_ops.hpp
+include/libtorrent/asio/detail/socket_option.hpp
+include/libtorrent/asio/detail/socket_select_interrupter.hpp
+include/libtorrent/asio/detail/socket_types.hpp
+include/libtorrent/asio/detail/strand_service.hpp
+include/libtorrent/asio/detail/task_io_service.hpp
+include/libtorrent/asio/detail/task_io_service_fwd.hpp
+include/libtorrent/asio/detail/thread.hpp
+include/libtorrent/asio/detail/tss_ptr.hpp
+include/libtorrent/asio/detail/win_event.hpp
+include/libtorrent/asio/detail/win_iocp_io_service.hpp
+include/libtorrent/asio/detail/win_iocp_io_service_fwd.hpp
+include/libtorrent/asio/detail/win_iocp_operation.hpp
+include/libtorrent/asio/detail/win_iocp_socket_service.hpp
+include/libtorrent/asio/detail/win_local_free_on_block_exit.hpp
+include/libtorrent/asio/detail/win_mutex.hpp
+include/libtorrent/asio/detail/win_signal_blocker.hpp
+include/libtorrent/asio/detail/win_thread.hpp
+include/libtorrent/asio/detail/win_tss_ptr.hpp
+include/libtorrent/asio/detail/winsock_init.hpp
+include/libtorrent/asio/detail/wrapped_handler.hpp
+include/libtorrent/asio/error.hpp
+include/libtorrent/asio/error_handler.hpp
+include/libtorrent/asio/handler_alloc_hook.hpp
+include/libtorrent/asio/impl/io_service.ipp
+include/libtorrent/asio/impl/read.ipp
+include/libtorrent/asio/impl/read_until.ipp
+include/libtorrent/asio/impl/write.ipp
+include/libtorrent/asio/io_service.hpp
+include/libtorrent/asio/ip/address.hpp
+include/libtorrent/asio/ip/address_v4.hpp
+include/libtorrent/asio/ip/address_v6.hpp
+include/libtorrent/asio/ip/basic_endpoint.hpp
+include/libtorrent/asio/ip/basic_resolver_entry.hpp
+include/libtorrent/asio/ip/basic_resolver_iterator.hpp
+include/libtorrent/asio/ip/basic_resolver_query.hpp
+include/libtorrent/asio/ip/detail/socket_option.hpp
+include/libtorrent/asio/ip/host_name.hpp
+include/libtorrent/asio/ip/multicast.hpp
+include/libtorrent/asio/ip/resolver_query_base.hpp
+include/libtorrent/asio/ip/tcp.hpp
+include/libtorrent/asio/ip/udp.hpp
+include/libtorrent/asio/is_read_buffered.hpp
+include/libtorrent/asio/is_write_buffered.hpp
+include/libtorrent/asio/placeholders.hpp
+include/libtorrent/asio/read.hpp
+include/libtorrent/asio/read_until.hpp
+include/libtorrent/asio/resolver_service.hpp
+include/libtorrent/asio/socket_acceptor_service.hpp
+include/libtorrent/asio/socket_base.hpp
+include/libtorrent/asio/ssl.hpp
+include/libtorrent/asio/ssl/basic_context.hpp
+include/libtorrent/asio/ssl/context.hpp
+include/libtorrent/asio/ssl/context_base.hpp
+include/libtorrent/asio/ssl/context_service.hpp
+include/libtorrent/asio/ssl/detail/openssl_context_service.hpp
+include/libtorrent/asio/ssl/detail/openssl_init.hpp
+include/libtorrent/asio/ssl/detail/openssl_operation.hpp
+include/libtorrent/asio/ssl/detail/openssl_stream_service.hpp
+include/libtorrent/asio/ssl/detail/openssl_types.hpp
+include/libtorrent/asio/ssl/stream.hpp
+include/libtorrent/asio/ssl/stream_base.hpp
+include/libtorrent/asio/ssl/stream_service.hpp
+include/libtorrent/asio/strand.hpp
+include/libtorrent/asio/strand_service.hpp
+include/libtorrent/asio/stream_socket_service.hpp
+include/libtorrent/asio/streambuf.hpp
+include/libtorrent/asio/system_exception.hpp
+include/libtorrent/asio/thread.hpp
+include/libtorrent/asio/time_traits.hpp
+include/libtorrent/asio/write.hpp
include/libtorrent/bencode.hpp
+include/libtorrent/bt_peer_connection.hpp
include/libtorrent/buffer.hpp
include/libtorrent/config.hpp
include/libtorrent/debug.hpp
@@ -11,7 +160,6 @@ include/libtorrent/escape_string.hpp
include/libtorrent/file.hpp
include/libtorrent/fingerprint.hpp
include/libtorrent/hasher.hpp
-include/libtorrent/http_settings.hpp
include/libtorrent/http_tracker_connection.hpp
include/libtorrent/identify_client.hpp
include/libtorrent/invariant_check.hpp
@@ -27,6 +175,7 @@ include/libtorrent/piece_picker.hpp
include/libtorrent/policy.hpp
include/libtorrent/resource_request.hpp
include/libtorrent/session.hpp
+include/libtorrent/session_settings.hpp
include/libtorrent/size_type.hpp
include/libtorrent/socket.hpp
include/libtorrent/stat.hpp
@@ -38,18 +187,17 @@ include/libtorrent/tracker_manager.hpp
include/libtorrent/udp_tracker_connection.hpp
include/libtorrent/utf8.hpp
include/libtorrent/version.hpp
-lib/libtorrent.so.1
-lib/libtorrent.so
-lib/libtorrent.la
+include/libtorrent/web_peer_connection.hpp
lib/libtorrent.a
+lib/libtorrent.la
+lib/libtorrent.so
+lib/libtorrent.so.1
libdata/pkgconfig/libtorrent.pc
-bin/client_test
-bin/dump_torrent
-bin/make_torrent
-bin/simple_client
-bin/test_hasher
-bin/test_bencoding
-bin/test_ip_filter
-bin/test_piece_picker
-bin/test_storage
+@dirrm include/libtorrent/asio/ssl/detail
+@dirrm include/libtorrent/asio/ssl
+@dirrm include/libtorrent/asio/ip/detail
+@dirrm include/libtorrent/asio/ip
+@dirrm include/libtorrent/asio/impl
+@dirrm include/libtorrent/asio/detail
+@dirrm include/libtorrent/asio
@dirrm include/libtorrent