aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/rblibtorrent
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-03-24 20:44:18 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-03-24 20:44:18 +0000
commitebe89309c3f9e2a4fe97a5d71d5eaa75635f5f51 (patch)
tree6b3986fb53c9c712aad6ae543e768c3b9532d2f7 /net-p2p/rblibtorrent
parentc7725a656e405a718907042f0d67fe29cc47831a (diff)
downloadports-ebe89309c3f9e2a4fe97a5d71d5eaa75635f5f51.tar.gz
ports-ebe89309c3f9e2a4fe97a5d71d5eaa75635f5f51.zip
Notes
Diffstat (limited to 'net-p2p/rblibtorrent')
-rw-r--r--net-p2p/rblibtorrent/Makefile36
-rw-r--r--net-p2p/rblibtorrent/distinfo3
-rw-r--r--net-p2p/rblibtorrent/files/patch-Makefile.in11
-rw-r--r--net-p2p/rblibtorrent/files/patch-configure32
-rw-r--r--net-p2p/rblibtorrent/files/patch-peer_connection.cpp35
-rw-r--r--net-p2p/rblibtorrent/pkg-descr13
-rw-r--r--net-p2p/rblibtorrent/pkg-plist54
7 files changed, 184 insertions, 0 deletions
diff --git a/net-p2p/rblibtorrent/Makefile b/net-p2p/rblibtorrent/Makefile
new file mode 100644
index 000000000000..18a3f7ce82d0
--- /dev/null
+++ b/net-p2p/rblibtorrent/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: rblibtorrent
+# Date created: 5 February 2006
+# Whom: Johan Ström <johan@stromnet.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtorrent
+PORTVERSION= 0.9.1
+CATEGORIES= net-p2p
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=libtorrent
+PKGNAMEPREFIX= rb
+
+MAINTAINER= johan@stromnet.org
+COMMENT= A C++ library implementing a BitTorrent client
+
+LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost \
+ boost_filesystem.3:${PORTSDIR}/devel/boost \
+ boost_thread.3:${PORTSDIR}/devel/boost
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --disable-debug
+CONFIGURE_ENV= CXXFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+CONFLICTS= libtorrent-[0-9]*
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= is unsupported on FreeBSD < 5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/rblibtorrent/distinfo b/net-p2p/rblibtorrent/distinfo
new file mode 100644
index 000000000000..ee5a75508f24
--- /dev/null
+++ b/net-p2p/rblibtorrent/distinfo
@@ -0,0 +1,3 @@
+MD5 (libtorrent-0.9.1.tar.gz) = 2e5d08a8f26e8e1e39b50020cb056818
+SHA256 (libtorrent-0.9.1.tar.gz) = 85796fa82c57dfba384ac3e2b1862f2ae30d24da1c11e57b51bcbab55e0a5415
+SIZE (libtorrent-0.9.1.tar.gz) = 711353
diff --git a/net-p2p/rblibtorrent/files/patch-Makefile.in b/net-p2p/rblibtorrent/files/patch-Makefile.in
new file mode 100644
index 000000000000..632f8b3cbd0e
--- /dev/null
+++ b/net-p2p/rblibtorrent/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Mar 24 21:28:28 2006
++++ Makefile.in Fri Mar 24 21:28:52 2006
+@@ -206,7 +206,7 @@
+ m4/ac_cxx_namespaces.m4 m4/acx_pthread.m4 m4/ax_boost_date-time.m4 \
+ m4/ax_boost_filesystem.m4 m4/ax_boost_thread.m4 src/file_win.cpp libtorrent.pc
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = libtorrent.pc
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/net-p2p/rblibtorrent/files/patch-configure b/net-p2p/rblibtorrent/files/patch-configure
new file mode 100644
index 000000000000..a8e38063d8fc
--- /dev/null
+++ b/net-p2p/rblibtorrent/files/patch-configure
@@ -0,0 +1,32 @@
+--- configure.orig Sun Feb 5 22:01:29 2006
++++ configure Sun Feb 5 22:03:10 2006
+@@ -20398,7 +20398,8 @@
+ echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
+ echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
+ if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+- BOOST_DATE_TIME_LIB=$ax_lib break
++ BOOST_DATE_TIME_LIB=$ax_lib
++ break
+ fi
+
+ done
+@@ -20558,7 +20559,8 @@
+ echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
+ echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
+ if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+- BOOST_FILESYSTEM_LIB=$ax_lib break
++ BOOST_FILESYSTEM_LIB=$ax_lib
++ break
+ fi
+
+ done
+@@ -20719,7 +20721,8 @@
+ echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
+ echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
+ if test `eval echo '${'$as_ac_Lib'}'` = yes; then
+- BOOST_THREAD_LIB=$ax_lib break
++ BOOST_THREAD_LIB=$ax_lib
++ break
+ fi
+
+ done
diff --git a/net-p2p/rblibtorrent/files/patch-peer_connection.cpp b/net-p2p/rblibtorrent/files/patch-peer_connection.cpp
new file mode 100644
index 000000000000..19c691734589
--- /dev/null
+++ b/net-p2p/rblibtorrent/files/patch-peer_connection.cpp
@@ -0,0 +1,35 @@
+--- src/peer_connection.cpp.orig Fri Dec 16 00:32:21 2005
++++ src/peer_connection.cpp Thu Feb 23 13:07:01 2006
+@@ -1011,6 +1011,7 @@
+
+ if (b != m_download_queue.end())
+ {
++/*
+ for (i = m_download_queue.begin();
+ i != b; ++i)
+ {
+@@ -1023,7 +1024,7 @@
+ // be requested from other peers
+ picker.abort_download(*i);
+ }
+-
++*/
+ #ifdef TORRENT_VERBOSE_LOGGING
+ (*m_logger) << to_simple_string(second_clock::universal_time())
+ << " <== PIECE [ piece: " << p.piece << " | "
+@@ -1031,12 +1032,14 @@
+ "s: " << p.start << " | "
+ "l: " << p.length << " ]\n";
+ #endif
+-
++/*
+ // remove the request that just finished
+ // from the download queue plus the
+ // skipped blocks.
+ m_download_queue.erase(m_download_queue.begin()
+ , boost::next(b));
++*/
++ m_download_queue.erase(b);
+ send_block_requests();
+ }
+ else
diff --git a/net-p2p/rblibtorrent/pkg-descr b/net-p2p/rblibtorrent/pkg-descr
new file mode 100644
index 000000000000..814d0c42687a
--- /dev/null
+++ b/net-p2p/rblibtorrent/pkg-descr
@@ -0,0 +1,13 @@
+libtorrent is a C++ library that aims to be a good alternative to
+all the other bittorrent implementations around.
+It is a library and not a full featured client, although it comes
+with a working example client.
+
+The main goals of libtorrent are:
+ * to be cpu efficient
+ * to be memory efficient
+ * to be very easy to use
+
+Note that this is NOT the same library as the libtorrent port!
+
+WWW: http://www.rasterbar.com/products/libtorrent.html
diff --git a/net-p2p/rblibtorrent/pkg-plist b/net-p2p/rblibtorrent/pkg-plist
new file mode 100644
index 000000000000..c9240c5438e8
--- /dev/null
+++ b/net-p2p/rblibtorrent/pkg-plist
@@ -0,0 +1,54 @@
+include/libtorrent/alert.hpp
+include/libtorrent/alert_types.hpp
+include/libtorrent/allocate_resources.hpp
+include/libtorrent/async_gethostbyname.hpp
+include/libtorrent/bencode.hpp
+include/libtorrent/buffer.hpp
+include/libtorrent/config.hpp
+include/libtorrent/debug.hpp
+include/libtorrent/entry.hpp
+include/libtorrent/escape_string.hpp
+include/libtorrent/file.hpp
+include/libtorrent/fingerprint.hpp
+include/libtorrent/hasher.hpp
+include/libtorrent/http_settings.hpp
+include/libtorrent/http_tracker_connection.hpp
+include/libtorrent/identify_client.hpp
+include/libtorrent/invariant_check.hpp
+include/libtorrent/io.hpp
+include/libtorrent/ip_filter.hpp
+include/libtorrent/peer.hpp
+include/libtorrent/peer_connection.hpp
+include/libtorrent/peer_id.hpp
+include/libtorrent/peer_info.hpp
+include/libtorrent/peer_request.hpp
+include/libtorrent/piece_block_progress.hpp
+include/libtorrent/piece_picker.hpp
+include/libtorrent/policy.hpp
+include/libtorrent/resource_request.hpp
+include/libtorrent/session.hpp
+include/libtorrent/size_type.hpp
+include/libtorrent/socket.hpp
+include/libtorrent/stat.hpp
+include/libtorrent/storage.hpp
+include/libtorrent/torrent.hpp
+include/libtorrent/torrent_handle.hpp
+include/libtorrent/torrent_info.hpp
+include/libtorrent/tracker_manager.hpp
+include/libtorrent/udp_tracker_connection.hpp
+include/libtorrent/utf8.hpp
+include/libtorrent/version.hpp
+lib/libtorrent.so.1
+lib/libtorrent.so
+lib/libtorrent.la
+lib/libtorrent.a
+libdata/pkgconfig/libtorrent.pc
+bin/dump_torrent
+bin/make_torrent
+bin/simple_client
+bin/test_hasher
+bin/test_bencoding
+bin/test_ip_filter
+bin/test_piece_picker
+bin/test_storage
+@dirrm include/libtorrent