aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/rtorrent-devel/Makefile
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-01-15 13:18:57 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-01-15 13:18:57 +0000
commit2a281c0c60d656b54ff8ceeaf3b51663be3300e5 (patch)
treed6fd63cc871a5e3e6f900d273cbe0be1e820a63d /net-p2p/rtorrent-devel/Makefile
parent122fce5fd9282574987ff137c92f854d00c43393 (diff)
downloadports-2a281c0c60d656b54ff8ceeaf3b51663be3300e5.tar.gz
ports-2a281c0c60d656b54ff8ceeaf3b51663be3300e5.zip
Notes
Diffstat (limited to 'net-p2p/rtorrent-devel/Makefile')
-rw-r--r--net-p2p/rtorrent-devel/Makefile52
1 files changed, 45 insertions, 7 deletions
diff --git a/net-p2p/rtorrent-devel/Makefile b/net-p2p/rtorrent-devel/Makefile
index 188272d00662..1504251741ef 100644
--- a/net-p2p/rtorrent-devel/Makefile
+++ b/net-p2p/rtorrent-devel/Makefile
@@ -8,6 +8,8 @@
PORTNAME= rtorrent-devel
PORTVERSION= 0.9.1
PORTREVISION= 0
+CATEGORIES= net-p2p
+MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
DISTNAME= ${PORTNAME:S/-devel//}-${PORTVERSION}
MAINTAINER= az@FreeBSD.org
@@ -15,15 +17,51 @@ COMMENT= BitTorrent Client written in C++ (development version)
BUILD_DEPENDS= libtorrent-devel=0.13.1_1:${PORTSDIR}/net-p2p/libtorrent-devel
RUN_DEPENDS= libtorrent-devel=0.13.1_1:${PORTSDIR}/net-p2p/libtorrent-devel
-
-MASTERDIR= ${.CURDIR}/../rtorrent
-PATCHDIR= ${.CURDIR}/files/
-DISTINFO_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
-DESCR= ${MASTERDIR}/pkg-descr
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
CONFLICTS= rtorrent-[0-9]*
USE_GCC= 4.2+
-.include "${MASTERDIR}/Makefile"
+GNU_CONFIGURE= yes
+LDFLAGS+= -pthread
+CONFIGURE_ARGS= --disable-debug
+
+SUB_FILES= pkg-message
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= XMLRPC IPV6 DOCS
+OPTIONS_DEFAULT= XMLRPC IPV6
+XMLRPC_DESC= Compile with xmlrpc-c support
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
+.if ${PORT_OPTIONS:MXMLRPC}
+CONFIGURE_ARGS+= --with-xmlrpc-c
+LIB_DEPENDS+= xmlrpc:${PORTSDIR}/net/xmlrpc-c-devel
+.else
+CONFIGURE_ARGS+= --with-xmlrpc-c=no
+.endif
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${EXAMPLESDIR}/
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>