aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/rtorrent
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-03-20 14:40:06 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-03-20 14:40:06 +0000
commit35b8f7806b044bcbc56a151223f86ae89dbc5287 (patch)
treeb11a2fbfdf610651bf4addea73a875e3c2728600 /net-p2p/rtorrent
parente0227725e379c7aaed6a485654465d937d16f67c (diff)
downloadports-35b8f7806b044bcbc56a151223f86ae89dbc5287.tar.gz
ports-35b8f7806b044bcbc56a151223f86ae89dbc5287.zip
Notes
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/Makefile4
-rw-r--r--net-p2p/rtorrent/distinfo4
-rw-r--r--net-p2p/rtorrent/files/patch-src_display_canvas.h38
-rw-r--r--net-p2p/rtorrent/files/patch-src_display_window__log.cc14
4 files changed, 18 insertions, 42 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index 8a1a3402b781..f5694fc30e87 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rtorrent
-PORTVERSION= 0.1.0
+PORTVERSION= 0.1.4
CATEGORIES= net
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
@@ -19,7 +19,7 @@ LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
USE_GCC= 3.4
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-debug
+CONFIGURE_ARGS= --disable-debug
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_INC_LIBTOOL_VER= 13
diff --git a/net-p2p/rtorrent/distinfo b/net-p2p/rtorrent/distinfo
index 94fe29fad646..d20ac39527a6 100644
--- a/net-p2p/rtorrent/distinfo
+++ b/net-p2p/rtorrent/distinfo
@@ -1,2 +1,2 @@
-MD5 (rtorrent-0.1.0.tar.gz) = 4617ff0076b27a2004a1fd2a3bf31d2d
-SIZE (rtorrent-0.1.0.tar.gz) = 160077
+MD5 (rtorrent-0.1.4.tar.gz) = 4cc6c723a6c9df12b8d30ffcb3a196c3
+SIZE (rtorrent-0.1.4.tar.gz) = 172628
diff --git a/net-p2p/rtorrent/files/patch-src_display_canvas.h b/net-p2p/rtorrent/files/patch-src_display_canvas.h
deleted file mode 100644
index 6b1b0e31fdb6..000000000000
--- a/net-p2p/rtorrent/files/patch-src_display_canvas.h
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/display/canvas.h.orig
-+++ src/display/canvas.h
-@@ -34,28 +34,28 @@
- chtype tl, chtype tr,
- chtype bl, chtype br) { wborder(m_window, ls, rs, ts, bs, tl, tr, bl, br); }
-
-- void print(int x, int y, const char* str) { mvwprintw(m_window, y, x, str); }
-+ void print(int x, int y, char* str) { mvwprintw(m_window, y, x, str); }
-
- template <typename A1>
-- void print(int x, int y, const char* str, A1 a1) { mvwprintw(m_window, y, x, str, a1); }
-+ void print(int x, int y, char* str, A1 a1) { mvwprintw(m_window, y, x, str, a1); }
-
- template <typename A1, typename A2>
-- void print(int x, int y, const char* str, A1 a1, A2 a2) { mvwprintw(m_window, y, x, str, a1, a2); }
-+ void print(int x, int y, char* str, A1 a1, A2 a2) { mvwprintw(m_window, y, x, str, a1, a2); }
-
- template <typename A1, typename A2, typename A3>
-- void print(int x, int y, const char* str,
-+ void print(int x, int y, char* str,
- A1 a1, A2 a2, A3 a3) { mvwprintw(m_window, y, x, str, a1, a2, a3); }
-
- template <typename A1, typename A2, typename A3, typename A4>
-- void print(int x, int y, const char* str,
-+ void print(int x, int y, char* str,
- A1 a1, A2 a2, A3 a3, A4 a4) { mvwprintw(m_window, y, x, str, a1, a2, a3, a4); }
-
- template <typename A1, typename A2, typename A3, typename A4, typename A5>
-- void print(int x, int y, const char* str,
-+ void print(int x, int y, char* str,
- A1 a1, A2 a2, A3 a3, A4 a4, A5 a5) { mvwprintw(m_window, y, x, str, a1, a2, a3, a4, a5); }
-
- template <typename A1, typename A2, typename A3, typename A4, typename A5, typename A6>
-- void print(int x, int y, const char* str,
-+ void print(int x, int y, char* str,
- A1 a1, A2 a2, A3 a3, A4 a4, A5 a5, A6 a6) { mvwprintw(m_window, y, x, str, a1, a2, a3, a4, a5, a6); }
-
- void set_attr(int x, int y, int n, int attr, int color) { mvwchgat(m_window, y, x, n, attr, color, NULL); }
diff --git a/net-p2p/rtorrent/files/patch-src_display_window__log.cc b/net-p2p/rtorrent/files/patch-src_display_window__log.cc
new file mode 100644
index 000000000000..106b68bca144
--- /dev/null
+++ b/net-p2p/rtorrent/files/patch-src_display_window__log.cc
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/display/window_log.cc.orig
++++ src/display/window_log.cc
+@@ -69,7 +69,7 @@
+ void
+ WindowLog::receive_update() {
+ iterator itr = find_older();
+- int h = std::min(std::distance(m_log->begin(), itr), 10);
++ int h = std::min(std::distance(m_log->begin(), itr), (ptrdiff_t) 10);
+
+ if (h != m_minHeight) {
+ set_active(h != 0);