aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/rtorrent
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-12-18 22:08:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-12-18 22:08:56 +0000
commit916edfcd48a50aec4aa9aaaca649014bf22b419d (patch)
tree2eea39f3f22655746320f7f008c6df75ea45bd6f /net-p2p/rtorrent
parent90f973349d69d4fbfa668bb817ed1040a954a72e (diff)
downloadports-916edfcd48a50aec4aa9aaaca649014bf22b419d.tar.gz
ports-916edfcd48a50aec4aa9aaaca649014bf22b419d.zip
Notes
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/Makefile16
-rw-r--r--net-p2p/rtorrent/files/patch-src_command__network.cc23
2 files changed, 31 insertions, 8 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index 3264b034a670..009d234da25b 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= rtorrent
PORTVERSION?= 0.7.9
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -36,16 +36,16 @@ SUB_FILES= pkg-message
PORTDOCS= README
-#OPTIONS= XMLRPC "Compile with xmlrpc-c support" on
+OPTIONS= XMLRPC "Compile with xmlrpc-c support" on
.include <bsd.port.pre.mk>
-#.if !defined(WITHOUT_XMLRPC)
-#CONFIGURE_ARGS+= --with-xmlrpc-c
-#LIB_DEPENDS+= xmlrpc.7:${PORTSDIR}/net/xmlrpc-c
-#.else
-#CONFIGURE_ARGS+= --with-xmlrpc-c=no
-#.endif
+.if !defined(WITHOUT_XMLRPC)
+CONFIGURE_ARGS+= --with-xmlrpc-c
+LIB_DEPENDS+= xmlrpc.9:${PORTSDIR}/net/xmlrpc-c
+.else
+CONFIGURE_ARGS+= --with-xmlrpc-c=no
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
diff --git a/net-p2p/rtorrent/files/patch-src_command__network.cc b/net-p2p/rtorrent/files/patch-src_command__network.cc
new file mode 100644
index 000000000000..3fd848ae4e71
--- /dev/null
+++ b/net-p2p/rtorrent/files/patch-src_command__network.cc
@@ -0,0 +1,23 @@
+--- src/command_network.cc.orig 2007-12-18 21:13:53.000000000 +0000
++++ src/command_network.cc 2007-12-18 21:14:26.000000000 +0000
+@@ -224,6 +224,8 @@
+ saPtr->set_port(port);
+ control->scgi()->open_port(saPtr, saPtr->length(), rpc::call_command_value("get_scgi_dont_route"));
+
++ rak::address_info::free_address_info(ai);
++
+ break;
+
+ case 2:
+@@ -232,10 +234,8 @@
+ break;
+ }
+
+- rak::address_info::free_address_info(ai);
+-
+ } catch (torrent::local_error& e) {
+- rak::address_info::free_address_info(ai);
++ //rak::address_info::free_address_info(ai);
+
+ throw torrent::input_error(e.what());
+ }