aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrent-file-editor/files
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-10-31 10:08:09 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-10-31 10:08:09 +0000
commitaa5bdb2d46eb1a4bdc09076215db82b6162e92a3 (patch)
treed26d93a3c585ff69a45847b86d9f17c31af9cc6c /net-p2p/torrent-file-editor/files
parent50dfc1cfbe6100c3e3911197097a5eea9d197878 (diff)
downloadports-aa5bdb2d46eb1a4bdc09076215db82b6162e92a3.tar.gz
ports-aa5bdb2d46eb1a4bdc09076215db82b6162e92a3.zip
Notes
Diffstat (limited to 'net-p2p/torrent-file-editor/files')
-rw-r--r--net-p2p/torrent-file-editor/files/patch-CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
index 6f23f3f190fb..6117e3ef41b1 100644
--- a/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
+++ b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
@@ -1,10 +1,19 @@
---- CMakeLists.txt.orig 2017-04-17 14:19:04 UTC
+--- CMakeLists.txt.orig 2017-09-26 09:30:09 UTC
+++ CMakeLists.txt
-@@ -73,6 +73,7 @@ if(QT5_BUILD)
+@@ -46,7 +46,7 @@ if(CMAKE_BUILD_TYPE STREQUAL Release OR CMAKE_BUILD_TY
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+
+ # #warning is not an error
+- if(NOT APPLE)
++ if(NOT APPLE AND NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-error=cpp")
+ else()
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-#warnings")
+@@ -108,6 +108,7 @@ if(QT5_BUILD)
else()
find_package(Qt4 REQUIRED)
find_package(QJSON 0.8.0 REQUIRED)
+ include_directories(${QJSON_INCLUDE_DIR})
- include(${QT_USE_FILE})
- endif()
+ add_definitions("'-DQStringLiteral(str)=QString::fromUtf8(\"\" str \"\", sizeof(str) - 1)'")
+ if(WIN32)