aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrent-file-editor
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-07-13 11:59:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-07-13 11:59:53 +0000
commitf1334eb2cb1d01cc6344e6e90ce6d14a61ee11be (patch)
tree0eaf2c9571f3c432e4c9c5e23f621c07812c37e8 /net-p2p/torrent-file-editor
parentfcda43dfbe9c3ca4347a8740596d3c1734d1ad28 (diff)
downloadports-f1334eb2cb1d01cc6344e6e90ce6d14a61ee11be.tar.gz
ports-f1334eb2cb1d01cc6344e6e90ce6d14a61ee11be.zip
net-p2p/torrent-file-editor: prepare for Qt 5.13
PR: 238782
Notes
Notes: svn path=/head/; revision=506540
Diffstat (limited to 'net-p2p/torrent-file-editor')
-rw-r--r--net-p2p/torrent-file-editor/files/patch-CMakeLists.txt16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
index b9146573470b..c03ce1c23cc9 100644
--- a/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
+++ b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
@@ -1,10 +1,20 @@
---- CMakeLists.txt.orig 2017-12-11 09:39:35 UTC
+--- CMakeLists.txt.orig 2019-04-11 19:45:13 UTC
+++ CMakeLists.txt
-@@ -108,6 +108,7 @@ if(QT5_BUILD)
+@@ -31,6 +31,9 @@ add_custom_target(update_version ALL
+ COMMAND ${CMAKE_COMMAND} -DWIN32=${WIN32} -DAPP_VERSION="v${APP_VERSION}" -P "${CMAKE_SOURCE_DIR}/Version.cmake"
+ )
+
++# Fix build with Qt 5.13
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQT_NO_DEPRECATED_WARNINGS=Y")
++
+ # Enable C++11
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+
+@@ -129,6 +132,7 @@ if(QT5_BUILD)
else()
find_package(Qt4 REQUIRED)
find_package(QJSON 0.8.0 REQUIRED)
+ include_directories(${QJSON_INCLUDE_DIR})
add_definitions("'-DQStringLiteral(str)=QString::fromUtf8(\"\" str \"\", sizeof(str) - 1)'")
+ include_directories(${QJSON_INCLUDE_DIR})
- if(WIN32)