aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrent-file-editor
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-06-01 20:22:18 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-06-01 20:22:18 +0000
commite069a888cf7ad17a3833e7bacf1b206997b5bf85 (patch)
treeaf648ee94a2ed6bd22e8298c147a10cb02438d97 /net-p2p/torrent-file-editor
parent78475d870b156093d28b2a1f0a5eae0b50aecb25 (diff)
downloadports-e069a888cf7ad17a3833e7bacf1b206997b5bf85.tar.gz
ports-e069a888cf7ad17a3833e7bacf1b206997b5bf85.zip
Notes
Diffstat (limited to 'net-p2p/torrent-file-editor')
-rw-r--r--net-p2p/torrent-file-editor/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index 56eeaf11e5ec..8701ce22e5dd 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -11,16 +11,21 @@ COMMENT= Qt-based GUI tool for creating and editing .torrent files
LICENSE= GPLv3
-USES= cmake
+USES= cmake desktop-file-utils
_QT4_DEPS= linguisttools_build moc_build qmake_build rcc_build \
uic_build corelib gui
_QT5_DEPS= buildtools_build linguisttools_build qmake_build \
core gui widgets
-OPTIONS_DEFINE= QT5
+OPTIONS_DEFINE= DONATION QT5
+OPTIONS_DEFAULT= DONATION
+
+DONATION_DESC= Show donation text in the About dialog
QT5_DESC= Build against Qt 5 instead of Qt 4
+DONATION_CMAKE_OFF= -DDISABLE_DONATION:BOOL=ON
+
QT5_USE= QT5=${_QT5_DEPS:ts,}
QT5_USE_OFF= QT4=${_QT4_DEPS:ts,}
QT5_LIB_DEPENDS_OFF= libqjson.so:devel/qjson