aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrentsniff/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-14 22:49:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-14 22:49:14 +0000
commitee3e9393b00491d22f914ae4b247b0ccbed59c53 (patch)
treeb5d160a58da0205c4423258d4581f941e67a72d3 /net-p2p/torrentsniff/Makefile
parent9c917bf574757794879c55d1069ad43ec63b83cd (diff)
downloadports-ee3e9393b00491d22f914ae4b247b0ccbed59c53.tar.gz
ports-ee3e9393b00491d22f914ae4b247b0ccbed59c53.zip
Notes
Diffstat (limited to 'net-p2p/torrentsniff/Makefile')
-rw-r--r--net-p2p/torrentsniff/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/torrentsniff/Makefile b/net-p2p/torrentsniff/Makefile
new file mode 100644
index 000000000000..59deef6d85e4
--- /dev/null
+++ b/net-p2p/torrentsniff/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: torrentsniff
+# Date created: 06 July 2003
+# Whom: Pav Lucistnik <pav@oook.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= torrentsniff
+PORTVERSION= 0.3.0
+CATEGORIES= net perl5
+MASTER_SITES= http://www.highprogrammer.com/alan/perl/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Commandline tool for getting status of torrent
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+post-patch:
+ ${PERL} -pi -e "s#/usr/local/bin/perl#${PERL5}#" ${WRKSRC}/torrentsniff
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/torrentsniff ${LOCALBASE}/bin
+ ${MKDIR} ${SITE_PERL}/BitTorrent
+ ${INSTALL_DATA} ${WRKSRC}/BitTorrent/BDecode.pm ${SITE_PERL}/BitTorrent
+
+.include <bsd.port.mk>