aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-09-13 20:53:52 +0000
committerJohn Marino <marino@FreeBSD.org>2013-09-13 20:53:52 +0000
commit08e12b0c257faaa1c1101472f1c39f7c1f4a2004 (patch)
tree95efc4152c29a845388b11f8d44dd64c86be6d7c /net-p2p/transmission-cli/Makefile
parent9818b60f151cd1f64c38d171ff7d4d1562e9d792 (diff)
downloadports-08e12b0c257faaa1c1101472f1c39f7c1f4a2004.tar.gz
ports-08e12b0c257faaa1c1101472f1c39f7c1f4a2004.zip
Notes
Diffstat (limited to 'net-p2p/transmission-cli/Makefile')
-rw-r--r--net-p2p/transmission-cli/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 985ae1039e36..0598dc6f78e4 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -35,12 +35,12 @@ GEN_LIB_DEPENDS=curl:${PORTSDIR}/ftp/curl \
event-2.0.6:${PORTSDIR}/devel/libevent2
GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/transmission-web
-USE_GMAKE= yes
-USES= pkgconfig
+# This is master port of transmission-*, so don't override USES definition
+USES+= gmake pkgconfig iconv
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS=--with-zlib=/usr \
${EXTRA_CONF_ARGS}
EXTRA_CONF_ARGS?=--enable-cli \