aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-06-25 04:10:38 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-06-25 04:10:38 +0000
commit655b27ec372a79b5ae805075d595748d972c195c (patch)
tree26188895936e065e27d16f9df96fb8bac54e6f73 /net-p2p/transmission-cli
parente57d87912f0036b8dd5f9cdc4ac04989415cd4d2 (diff)
downloadports-655b27ec372a79b5ae805075d595748d972c195c.tar.gz
ports-655b27ec372a79b5ae805075d595748d972c195c.zip
Notes
Diffstat (limited to 'net-p2p/transmission-cli')
-rw-r--r--net-p2p/transmission-cli/Makefile49
-rw-r--r--net-p2p/transmission-cli/distinfo6
-rw-r--r--net-p2p/transmission-cli/files/patch-freebsd427
-rw-r--r--net-p2p/transmission-cli/pkg-plist6
4 files changed, 33 insertions, 55 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index fcf4ef580b8a..f3387c765da9 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= transmission
-PORTVERSION= 0.5
+PORTVERSION= 0.6
PORTREVISION?= 0
CATEGORIES= net-p2p
MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/ \
@@ -17,26 +17,32 @@ DISTNAME= Transmission-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT?= A free BitTorrent client written from scratch in C
-BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
-
-CFLAGS+= -Wall -W ${CPPFLAGS}
+USE_GMAKE= yes
HAS_CONFIGURE= yes
-USE_GETOPT_LONG=yes
CONFIGURE_ARGS?=--prefix=${PREFIX} \
--disable-gtk
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude beos \
--exclude macosx \
- --exclude packageOSX.sh
+ --exclude packageOSX.sh \
+ --exclude Sparkle.framework \
+ --exclude Transmission.xcodeproj
+
+DOCS= AUTHORS LICENSE NEWS README
-PLIST_FILES?= bin/transmissioncli
-PORTDOCS= AUTHORS LICENSE NEWS README
+.if defined(SLAVE_TRANS)
+EXTRACT_AFTER_ARGS+=--exclude cli
+.else
+CFLAGS+= ${CPPFLAGS}
+USE_GETOPT_LONG=yes
+EXTRACT_AFTER_ARGS+=--exclude gtk
+MAN1= transmissioncli.1
+.endif
.if defined(WITHOUT_OPENSSL)
CONFIGURE_ARGS+=--disable-openssl
.else
USE_OPENSSL= yes
-CONFIGURE_ARGS+=--openssl-prefix=${OPENSSLBASE}
.endif
pre-everything::
@@ -48,27 +54,20 @@ pre-everything::
@${ECHO_MSG} "WITHOUT_OPENSSL=yes to disable OpenSSL support, using built-in SHA1 implementation. Warning, it is a bit slower if you use this option." | ${FMT} 75 75
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
- s|$$LINKLIBS ;|${LDFLAGS} $$LINKLIBS ;|g ; \
- s|/usr/local/|${LOCALBASE}/|g ; s|/usr/X11R6/|${X11BASE}/|g' \
+general-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g ; \
+ s|/usr/X11R6/|${X11BASE}/|g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-O3||g' \
- ${WRKSRC}/Jamrules
-
-# jam -dx, it will giving a verbose of build.
-do-build:
- @(cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} jam -dx)
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
+ s|-g -Wall -W -O3 -funroll-loops|-Wall -W|g' \
+ ${WRKSRC}/mk/common.mk
-.if !defined(SLAVE_PORT)
-do-install: docsfiles
- ${INSTALL_PROGRAM} ${WRKSRC}/transmissioncli ${PREFIX}/bin/
-.endif
+post-patch: general-patch
-docsfiles:
.ifndef (NOPORTDOCS)
+post-install:
@${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
+.for i in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index d544ed0d8657..992ae65bc8c4 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,3 +1,3 @@
-MD5 (Transmission-0.5.tar.gz) = 07f737c837d25af7d14056edd4a81d49
-SHA256 (Transmission-0.5.tar.gz) = d098259b0414515228e48abc44fc0bb587bef39db30908c9b11102d4ab25b98f
-SIZE (Transmission-0.5.tar.gz) = 236266
+MD5 (Transmission-0.6.tar.gz) = 63b5cdd59c82fadfc2d26bd7aaa186f5
+SHA256 (Transmission-0.6.tar.gz) = a912aada06a106bd4f608ef0950a1d5f8e9969a1e506c5e059e92360d035d04f
+SIZE (Transmission-0.6.tar.gz) = 531467
diff --git a/net-p2p/transmission-cli/files/patch-freebsd4 b/net-p2p/transmission-cli/files/patch-freebsd4
deleted file mode 100644
index 8c776fb626a5..000000000000
--- a/net-p2p/transmission-cli/files/patch-freebsd4
+++ /dev/null
@@ -1,27 +0,0 @@
---- configure.orig Sat Mar 18 23:21:44 2006
-+++ configure Sat Mar 18 23:29:04 2006
-@@ -223,6 +223,13 @@
- FreeBSD)
- DEFINES="$DEFINES SYS_FREEBSD"
- LINKLIBS="$LINKLIBS -pthread -lm"
-+
-+ RELEASE=`uname -r`
-+ case $RELEASE in
-+ 4.*)
-+ DEFINES="$DEFINES SYS_FREEBSD_4"
-+ ;;
-+ esac
- ;;
-
- NetBSD)
---- libtransmission/choking.c.orig Sat Mar 18 23:30:46 2006
-+++ libtransmission/choking.c Sat Mar 18 23:31:15 2006
-@@ -23,7 +23,7 @@
- #include <math.h>
- #include "transmission.h"
-
--#ifdef SYS_BEOS
-+#if defined(SYS_BEOS) || defined(SYS_FREEBSD_4)
- #define lrintf(a) ((int)(0.5+(a)))
- #endif
-
diff --git a/net-p2p/transmission-cli/pkg-plist b/net-p2p/transmission-cli/pkg-plist
new file mode 100644
index 000000000000..81dfef200185
--- /dev/null
+++ b/net-p2p/transmission-cli/pkg-plist
@@ -0,0 +1,6 @@
+bin/transmissioncli
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%